summaryrefslogtreecommitdiffstats
path: root/abs/extra/rtmpdump/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <mihanson@linhes.org>2012-04-14 05:13:05 (GMT)
committerMichael Hanson <mihanson@linhes.org>2012-04-14 05:13:05 (GMT)
commit5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43 (patch)
treeacde2ddc972337f648a826f3d961dcb8bebf892a /abs/extra/rtmpdump/PKGBUILD
parent8e721470713e6a5a164f1d7682b0d248cb87b03c (diff)
parent502a19b42d9df3fb3c3e521a37eebd20f9fbd984 (diff)
downloadlinhes_pkgbuild-5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43.zip
linhes_pkgbuild-5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43.tar.gz
linhes_pkgbuild-5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43.tar.bz2
Merge branch 'testing' of linhes.org:linhes_pkgbuild into testing
Conflicts: abs/extra/bluez/PKGBUILD abs/extra/bluez/__changelog
Diffstat (limited to 'abs/extra/rtmpdump/PKGBUILD')
-rw-r--r--abs/extra/rtmpdump/PKGBUILD39
1 files changed, 16 insertions, 23 deletions
diff --git a/abs/extra/rtmpdump/PKGBUILD b/abs/extra/rtmpdump/PKGBUILD
index ee3c007..03263a4 100644
--- a/abs/extra/rtmpdump/PKGBUILD
+++ b/abs/extra/rtmpdump/PKGBUILD
@@ -1,34 +1,27 @@
-# Maintainer: xduugu
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: xduugu
# Contributor: Elis Hughes <elishughes@googlemail.com>
+
pkgname=rtmpdump
-pkgver=2.3
-pkgrel=2
-pkgdesc="A tool to download rtmp:// and rtmpe:// streams"
+pkgver=2.4
+pkgrel=1
+pkgdesc="A tool to download rtmp streams"
arch=('i686' 'x86_64')
url="http://rtmpdump.mplayerhq.hu/"
-license=('LGPL')
+license=('GPL2' 'LGPL2.1')
depends=('openssl')
-source=(
- http://mirrors.kernel.org/gentoo/distfiles/$pkgname-$pkgver.tgz
- # Upstream is not accessible from Vodafone/Germany
- #http://rtmpdump.mplayerhq.hu/download/$pkgname-$pkgver.tgz
-)
-md5sums=('eb961f31cd55f0acf5aad1a7b900ef59')
-sha256sums=('ef38b7a99d82ce6912063d21063aeaf28185341b3df486e24bffce5354224b2c')
-
-#if [[ ! -e "$SRCDEST/${source[0]##*/}" ]]; then
- #cd "$SRCDEST"
- #download_file "$(get_downloadclient "$(get_url "${source[0]}")")" "$(get_url "${source[0]}")" "$(get_filename "${source[0]}")" \
- #|| download_file "$(get_downloadclient "$(get_url "${source[1]}")")" "$(get_url "${source[1]}")" "$(get_filename "${source[1]}")"
- #cd "$OLDPWD"
-#fi
+#source=(http://rtmpdump.mplayerhq.hu/download/${pkgname}-${pkgver}.tgz)
+source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz)
+sha256sums=('2c3b76d46d56180176ef099b8ad50a1608bef1dac35d8cb0b21ceac31b5c0656')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- sed -i 's/^install_so.0:.*/& install_base/' librtmp/Makefile
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make prefix=/usr MANDIR="$pkgdir/usr/share/man" DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d -m755 "${pkgdir}/usr/lib"
+ make prefix=/usr mandir=/usr/share/man DESTDIR="${pkgdir}" install
}