summaryrefslogtreecommitdiffstats
path: root/abs/extra/rtmpdump
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2012-04-08 05:17:14 (GMT)
committerBritney Fransen <brfransen@gmail.com>2012-04-08 05:17:14 (GMT)
commitef73af8420b849b6dc74fb33b04e8303622d4a31 (patch)
tree19ed5ed51c09d1e67b32a43b03f34f746c58c0d2 /abs/extra/rtmpdump
parentee01e37d0775a4720f2a6d0e093507bef1c3f266 (diff)
downloadlinhes_pkgbuild-ef73af8420b849b6dc74fb33b04e8303622d4a31.zip
linhes_pkgbuild-ef73af8420b849b6dc74fb33b04e8303622d4a31.tar.gz
linhes_pkgbuild-ef73af8420b849b6dc74fb33b04e8303622d4a31.tar.bz2
rtmpdump: update to 2.4
Diffstat (limited to 'abs/extra/rtmpdump')
-rw-r--r--abs/extra/rtmpdump/PKGBUILD39
1 files changed, 16 insertions, 23 deletions
diff --git a/abs/extra/rtmpdump/PKGBUILD b/abs/extra/rtmpdump/PKGBUILD
index ee3c007..03263a4 100644
--- a/abs/extra/rtmpdump/PKGBUILD
+++ b/abs/extra/rtmpdump/PKGBUILD
@@ -1,34 +1,27 @@
-# Maintainer: xduugu
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: xduugu
# Contributor: Elis Hughes <elishughes@googlemail.com>
+
pkgname=rtmpdump
-pkgver=2.3
-pkgrel=2
-pkgdesc="A tool to download rtmp:// and rtmpe:// streams"
+pkgver=2.4
+pkgrel=1
+pkgdesc="A tool to download rtmp streams"
arch=('i686' 'x86_64')
url="http://rtmpdump.mplayerhq.hu/"
-license=('LGPL')
+license=('GPL2' 'LGPL2.1')
depends=('openssl')
-source=(
- http://mirrors.kernel.org/gentoo/distfiles/$pkgname-$pkgver.tgz
- # Upstream is not accessible from Vodafone/Germany
- #http://rtmpdump.mplayerhq.hu/download/$pkgname-$pkgver.tgz
-)
-md5sums=('eb961f31cd55f0acf5aad1a7b900ef59')
-sha256sums=('ef38b7a99d82ce6912063d21063aeaf28185341b3df486e24bffce5354224b2c')
-
-#if [[ ! -e "$SRCDEST/${source[0]##*/}" ]]; then
- #cd "$SRCDEST"
- #download_file "$(get_downloadclient "$(get_url "${source[0]}")")" "$(get_url "${source[0]}")" "$(get_filename "${source[0]}")" \
- #|| download_file "$(get_downloadclient "$(get_url "${source[1]}")")" "$(get_url "${source[1]}")" "$(get_filename "${source[1]}")"
- #cd "$OLDPWD"
-#fi
+#source=(http://rtmpdump.mplayerhq.hu/download/${pkgname}-${pkgver}.tgz)
+source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz)
+sha256sums=('2c3b76d46d56180176ef099b8ad50a1608bef1dac35d8cb0b21ceac31b5c0656')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- sed -i 's/^install_so.0:.*/& install_base/' librtmp/Makefile
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make prefix=/usr MANDIR="$pkgdir/usr/share/man" DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d -m755 "${pkgdir}/usr/lib"
+ make prefix=/usr mandir=/usr/share/man DESTDIR="${pkgdir}" install
}