summaryrefslogtreecommitdiffstats
path: root/abs/extra/rtmpdump
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-15 20:27:03 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:02 (GMT)
commitf99abb5ee4b218cc375dd891f7a2e35ccb044afa (patch)
tree1bd7df6209c2932c476607c3db126a6b1a349062 /abs/extra/rtmpdump
parent62d36fb73362e85acb8649099dbc62030931d225 (diff)
downloadlinhes_pkgbuild-f99abb5ee4b218cc375dd891f7a2e35ccb044afa.zip
linhes_pkgbuild-f99abb5ee4b218cc375dd891f7a2e35ccb044afa.tar.gz
linhes_pkgbuild-f99abb5ee4b218cc375dd891f7a2e35ccb044afa.tar.bz2
poweroff-scripts: update for systemd
Diffstat (limited to 'abs/extra/rtmpdump')
-rw-r--r--abs/extra/rtmpdump/PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/abs/extra/rtmpdump/PKGBUILD b/abs/extra/rtmpdump/PKGBUILD
index b1e933a..e7432cb 100644
--- a/abs/extra/rtmpdump/PKGBUILD
+++ b/abs/extra/rtmpdump/PKGBUILD
@@ -1,27 +1,29 @@
-# $Id: PKGBUILD 134127 2011-08-02 03:47:07Z eric $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
+# $Id: PKGBUILD 202973 2013-12-29 17:17:31Z bpiotrowski $
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: xduugu
# Contributor: Elis Hughes <elishughes@googlemail.com>
pkgname=rtmpdump
-pkgver=2.4
+pkgver=20131205
pkgrel=1
-pkgdesc="A tool to download rtmp streams"
+pkgdesc='Tool to download rtmp streams'
arch=('i686' 'x86_64')
-url="http://rtmpdump.mplayerhq.hu/"
+url='http://rtmpdump.mplayerhq.hu/'
license=('GPL2' 'LGPL2.1')
depends=('openssl')
-#source=(http://rtmpdump.mplayerhq.hu/download/${pkgname}-${pkgver}.tgz)
-source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.xz)
-sha256sums=('2c3b76d46d56180176ef099b8ad50a1608bef1dac35d8cb0b21ceac31b5c0656')
+makedepends=('git')
+options=('!makeflags')
+source=(git://git.ffmpeg.org/rtmpdump#commit=dc76f0a8)
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- install -d -m755 "${pkgdir}/usr/lib"
- make prefix=/usr mandir=/usr/share/man DESTDIR="${pkgdir}" install
+ cd $pkgname
+ make prefix=/usr sbindir=/usr/bin \
+ mandir=/usr/share/man DESTDIR="$pkgdir" \
+ install
}
+md5sums=('SKIP')