summaryrefslogtreecommitdiffstats
path: root/abs/extra/samba
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-10-07 20:03:30 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-10-07 20:03:30 (GMT)
commit43119008f7b05b24cfdb85fc2b715503b1f93da9 (patch)
tree7bc7560c3d8b9d29080a6ce5c6793ae67bd607a6 /abs/extra/samba
parent3f9ba2bf1dd81a0d2797448f4093900c453ccc54 (diff)
downloadlinhes_pkgbuild-43119008f7b05b24cfdb85fc2b715503b1f93da9.zip
linhes_pkgbuild-43119008f7b05b24cfdb85fc2b715503b1f93da9.tar.gz
linhes_pkgbuild-43119008f7b05b24cfdb85fc2b715503b1f93da9.tar.bz2
samba: update to 4.1.12
Diffstat (limited to 'abs/extra/samba')
-rw-r--r--abs/extra/samba/PKGBUILD27
-rw-r--r--abs/extra/samba/__changelog3
-rw-r--r--abs/extra/samba/readline-6.3.patch26
3 files changed, 9 insertions, 47 deletions
diff --git a/abs/extra/samba/PKGBUILD b/abs/extra/samba/PKGBUILD
index c65cf93..d1b2e44 100644
--- a/abs/extra/samba/PKGBUILD
+++ b/abs/extra/samba/PKGBUILD
@@ -10,17 +10,17 @@
pkgbase=samba
pkgname=('libwbclient' 'smbclient' 'samba')
-pkgver=4.1.6
+pkgver=4.1.12
# We use the 'A' to fake out pacman's version comparators. Samba chooses
# to append 'a','b',etc to their subsequent releases, which pamcan
# misconstrues as alpha, beta, etc. Bad samba!
-_realver=4.1.6
-pkgrel=3
+_realver=4.1.12
+pkgrel=1
arch=(i686 x86_64)
url="http://www.samba.org"
license=('GPL3')
makedepends=('python2' 'docbook-xsl' 'pkg-config' 'libbsd' 'db' 'popt' 'libcups'
- 'readline' 'tevent' 'acl' 'libldap' 'libcap' 'ldb>=1.1.15' 'krb5' 'pam'
+ 'readline' 'tevent' 'acl' 'libldap' 'libcap' 'ldb>=1.1.17' 'krb5' 'pam'
'gnutls>=2.4.1' 'talloc' 'tdb' 'dbus')
source=(http://us1.samba.org/samba/ftp/stable/${pkgbase}-${_realver}.tar.gz
samba.logrotate
@@ -32,8 +32,7 @@ source=(http://us1.samba.org/samba/ftp/stable/${pkgbase}-${_realver}.tar.gz
nmbd.service
smbd@.service
winbindd.service
- samba.conf
- readline-6.3.patch)
+ samba.conf)
### UNINSTALL dmapi package before building!!!
build() {
@@ -63,7 +62,6 @@ _samba4_idmap_modules=idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2
_samba4_pdb_modules=pdb_tdbsam,pdb_ldap,pdb_ads,pdb_smbpasswd,pdb_wbc_sam,pdb_samba4
_samba4_auth_modules=auth_unix,auth_wbc,auth_server,auth_netlogond,auth_script,auth_samba4
cd ${srcdir}/samba-${_realver}
- patch -Np1 -i ${srcdir}/readline-6.3.patch
./configure --enable-fhs \
--prefix=/usr \
--sbindir=/usr/bin \
@@ -80,6 +78,7 @@ _samba4_auth_modules=auth_unix,auth_wbc,auth_server,auth_netlogond,auth_script,a
--enable-gnutls \
--with-pam \
--with-pammodulesdir=/usr/lib/security \
+ --bundled-libraries=!tdb,!talloc,!pytalloc-util,!tevent,!popt,!ldb,!pyldb-util \
--with-shared-modules=${_samba4_idmap_modules},${_samba4_pdb_modules},${_samba4_auth_modules} \
--disable-rpath-install
@@ -242,7 +241,7 @@ sys.path.insert(0, '/usr/lib/python${_pyver}/site-packages')" \
# copy ldap example
install -D -m644 ${srcdir}/samba-${_realver}/examples/LDAP/samba.schema ${pkgdir}/usr/share/doc/samba/examples/LDAP/samba.schema
}
-md5sums=('9dc64658c0cc81e7637f9b975c19638c'
+md5sums=('232016d7581a1ba11e991ec2674553c4'
'5697da77590ec092cc8a883bae06093c'
'96f82c38f3f540b53f3e5144900acf17'
'ee4763a656cf00d92bfda31b6bb2c5cb'
@@ -253,15 +252,3 @@ md5sums=('9dc64658c0cc81e7637f9b975c19638c'
'70afd2db60a2e8eff7615dbdecd887ac'
'd5f56f43e1280bba20f6bbd88d16fa41'
'49abd7b719e3713a3f75a8a50958e381')
-md5sums=('9dc64658c0cc81e7637f9b975c19638c'
- '5697da77590ec092cc8a883bae06093c'
- '96f82c38f3f540b53f3e5144900acf17'
- 'ee4763a656cf00d92bfda31b6bb2c5cb'
- '6c447748a064d631435dbef0a3dcf32f'
- 'e4ae6a3cac080602120aa151918c4a36'
- 'a78b9aa93eb14b0ac445897395693225'
- 'df6380c73cb73163968eabc8650f7358'
- '70afd2db60a2e8eff7615dbdecd887ac'
- 'd5f56f43e1280bba20f6bbd88d16fa41'
- '49abd7b719e3713a3f75a8a50958e381'
- '1179c1dcdb95f79b0d5813698d010d2c')
diff --git a/abs/extra/samba/__changelog b/abs/extra/samba/__changelog
index bb83999..b6a8d39 100644
--- a/abs/extra/samba/__changelog
+++ b/abs/extra/samba/__changelog
@@ -1 +1,2 @@
-removed fam/gamin
+PKGBUILD: removefam/gamin, systemd
+samba.install: add systemconfig.py -m fileshare
diff --git a/abs/extra/samba/readline-6.3.patch b/abs/extra/samba/readline-6.3.patch
deleted file mode 100644
index 0dcb1cf..0000000
--- a/abs/extra/samba/readline-6.3.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Function, CPFunction, CPPFunction and VFunction typedefs are considered
-old-style (deprecated) starting from readline 4.2.
-Compatibility typedefs have been in place up to readline 6.2 but were
-removed with the 6.3 release thus causing builds to break.
-Swtich to the new-style specific prototyped typedef.
-
-Signed-off-by: Gustavo Zacarias <gustavo at zacarias.com.ar>
----
- libcli/smbreadline/smbreadline.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libcli/smbreadline/smbreadline.c b/libcli/smbreadline/smbreadline.c
-index cff25a7..80e10b0 100644
---- a/libcli/smbreadline/smbreadline.c
-+++ b/libcli/smbreadline/smbreadline.c
-@@ -141,7 +141,7 @@ char *smb_readline(const char *prompt, void (*callback)(void),
-
- #if HAVE_DECL_RL_EVENT_HOOK
- if (callback)
-- rl_event_hook = (Function *)callback;
-+ rl_event_hook = (rl_hook_func_t *)callback;
- #endif
- ret = readline(prompt);
- if (ret && *ret)
---
-1.8.3.2