summaryrefslogtreecommitdiffstats
path: root/abs/extra/sapphire/sapphire.patch
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2012-04-22 22:26:22 (GMT)
committerCecil <knoppmyth@gmail.com>2012-04-22 22:26:22 (GMT)
commit95f93a5cd8b9e9d91a38850f652d65e41474628f (patch)
tree46a05353ac1495b1ce94a97d4ebaa769578d5d03 /abs/extra/sapphire/sapphire.patch
parent3ca705e54de65bc4c8cb852b71a73b0c156a6a5d (diff)
downloadlinhes_pkgbuild-95f93a5cd8b9e9d91a38850f652d65e41474628f.zip
linhes_pkgbuild-95f93a5cd8b9e9d91a38850f652d65e41474628f.tar.gz
linhes_pkgbuild-95f93a5cd8b9e9d91a38850f652d65e41474628f.tar.bz2
sapphire: Bumped to version 3.3.
Diffstat (limited to 'abs/extra/sapphire/sapphire.patch')
-rw-r--r--abs/extra/sapphire/sapphire.patch43
1 files changed, 30 insertions, 13 deletions
diff --git a/abs/extra/sapphire/sapphire.patch b/abs/extra/sapphire/sapphire.patch
index ddd0653..36cf217 100644
--- a/abs/extra/sapphire/sapphire.patch
+++ b/abs/extra/sapphire/sapphire.patch
@@ -1,24 +1,41 @@
-diff -ruaN sapphire-3.2.orig//Makefile sapphire-3.2/Makefile
---- sapphire-3.2.orig//Makefile 2012-04-12 18:00:50.000000000 +0000
-+++ sapphire-3.2/Makefile 2012-04-22 08:42:19.000000000 +0000
-@@ -4,7 +4,7 @@
- #
+diff -ruaN sapphire-3.3.orig/Makefile sapphire-3.3/Makefile
+--- sapphire-3.3.orig/Makefile 2012-04-22 16:19:27.000000000 +0000
++++ sapphire-3.3/Makefile 2012-04-22 22:19:18.000000000 +0000
+@@ -5,7 +5,7 @@
MODNAME=sapphire
+ MODSOURCE=$(MODNAME).c
CONFLICTS=hid_topseed
-BLACKLIST=/etc/modprobe.d/blacklist-$(CONFLICTS).conf
+BLACKLIST=$(DESTDIR)/etc/modprobe.d/blacklist-$(CONFLICTS).conf
+ KEYMAP_SCRIPT=sapphire_keymap.sh
+ EXTRACT_KEYDEFS=extract_keydefs.sh
+ INPUT_H=/usr/include/linux/input.h
+@@ -39,12 +39,12 @@
- ## MODPARMS is not used any more, but we have to nuke old copies to prevent issues:
- MODPARMS=/etc/modprobe.d/$(MODNAME).conf
-@@ -49,8 +49,8 @@
+ modinstall: $(MODNAME).ko
+ $(MAKE) -C $(KDIR)/build M=`pwd` modules_install
+- depmod $(KVER)
+- @if [ "$(KVER)" = "$$(uname -r)" ]; then \
+- rmmod $(MODNAME) 2>/dev/null ;\
+- rmmod $(CONFLICTS) 2>/dev/null ;\
+- modprobe -v $(MODNAME) ;\
+- fi
++# depmod $(KVER)
++# @if [ "$(KVER)" = "$$(uname -r)" ]; then \
++# rmmod $(MODNAME) 2>/dev/null ;\
++# rmmod $(CONFLICTS) 2>/dev/null ;\
++# modprobe -v $(MODNAME) ;\
++# fi
+
+ clean:
+ $(MAKE) -C $(KDIR)/build M=`pwd` clean
+@@ -61,7 +61,7 @@
depmod
- install: $(MODNAME).ko clean_modparms modloader $(BLACKLIST)
-- cp sapphire_keymap.sh /usr/local/bin/
-- chmod a+rx /usr/local/bin/sapphire_keymap.sh
+ install: $(MODNAME).ko clean_modparms modinstall $(BLACKLIST) $(KEYMAP_SCRIPT)
+- install -m 0755 $(KEYMAP_SCRIPT) /usr/local/bin/
- sync
-+# cp sapphire_keymap.sh /usr/local/bin/
-+# chmod a+rx /usr/local/bin/sapphire_keymap.sh
++# install -m 0755 $(KEYMAP_SCRIPT) /usr/local/bin/
+# sync
all: install