summaryrefslogtreecommitdiffstats
path: root/abs/extra/schroedinger
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-10 03:41:11 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-10 03:41:11 (GMT)
commitbe99d44cf39a86f7c86d93652e00f5e8074beb79 (patch)
tree1bd2f73710c0169b19f3803e4c7508204f4be457 /abs/extra/schroedinger
parent1b3f6a06593fd983729f4aff290e442373367e70 (diff)
downloadlinhes_pkgbuild-be99d44cf39a86f7c86d93652e00f5e8074beb79.zip
linhes_pkgbuild-be99d44cf39a86f7c86d93652e00f5e8074beb79.tar.gz
linhes_pkgbuild-be99d44cf39a86f7c86d93652e00f5e8074beb79.tar.bz2
schroedinger: initial include (for ffmpeg)
Diffstat (limited to 'abs/extra/schroedinger')
-rw-r--r--abs/extra/schroedinger/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra/schroedinger/PKGBUILD b/abs/extra/schroedinger/PKGBUILD
new file mode 100644
index 0000000..0de2d23
--- /dev/null
+++ b/abs/extra/schroedinger/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 79531 2010-05-04 09:01:27Z ibiru $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Timm Preetz <timm@preetz.us>
+# Contributor: rabyte <rabyte__gmail>
+pkgname=schroedinger
+pkgver=1.0.9
+pkgrel=1
+pkgdesc="An implemenation of the Dirac video codec in ANSI C code"
+arch=('i686' 'x86_64')
+url="http://www.diracvideo.org/"
+license=('GPL2' 'LGPL2' 'MPL' 'MIT')
+depends=('orc>=0.4.3')
+makedepends=('pkgconfig')
+options=(!libtool)
+source=(http://www.diracvideo.org/download/schroedinger/$pkgname-$pkgver.tar.gz)
+md5sums=('d67ec48b7c506db8c8b49156bf409e60')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
+ ./configure --prefix=/usr
+
+ make || return 1
+ make DESTDIR=$pkgdir install
+
+ install -m644 -D COPYING.MIT $pkgdir/usr/share/licenses/$pkgname/COPYING.MIT
+}
+