summaryrefslogtreecommitdiffstats
path: root/abs/extra/scons
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-02 03:48:04 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-02 03:48:04 (GMT)
commita7011e8b84283158a756e33ff36db5e9d3eb6f3a (patch)
tree0f5bb4056f665d48a7e95400a7e5165899176a27 /abs/extra/scons
parentacfc0d66dafc1e0a7536c9dbfc899eb0baafbe4f (diff)
downloadlinhes_pkgbuild-a7011e8b84283158a756e33ff36db5e9d3eb6f3a.zip
linhes_pkgbuild-a7011e8b84283158a756e33ff36db5e9d3eb6f3a.tar.gz
linhes_pkgbuild-a7011e8b84283158a756e33ff36db5e9d3eb6f3a.tar.bz2
scons: initial include for fceu
Diffstat (limited to 'abs/extra/scons')
-rw-r--r--abs/extra/scons/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra/scons/PKGBUILD b/abs/extra/scons/PKGBUILD
new file mode 100644
index 0000000..edc4fbc
--- /dev/null
+++ b/abs/extra/scons/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 90304 2010-09-10 14:41:36Z schiv $
+# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+# Contributor: Lukas Sabota <punkrockguy318@comcast.net>
+# Contributor: Brice Carpentier <brice@dlfp.org>
+
+pkgname=scons
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Extensible Python-based build utility"
+arch=('any')
+url="http://scons.org"
+license=('MIT')
+depends=('python2')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('beca648b894cdbf85383fffc79516d18')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python2 setup.py install --standard-lib \
+ --prefix=/usr \
+ --install-data=/usr/share \
+ --optimize=1 \
+ --root="$pkgdir"
+
+ # fix for python 2.7
+ sed -i 's:^#!.*bin/env python:#!/usr/bin/env python2:' "$pkgdir"/usr/bin/*
+
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+