summaryrefslogtreecommitdiffstats
path: root/abs/extra/sdl_image
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
commitf591ead4c8a9b64b0630900aa12c260027a7db6f (patch)
tree091b31cdc3a24c0b9108f0ea718ecaad166cc834 /abs/extra/sdl_image
parent9b35fb3e4f637252b4674a78adf9026faeaa5340 (diff)
downloadlinhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.zip
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.gz
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.bz2
compiled/added programs needed by xbmc: Moved some programs out of community into extra.
libmpeg2 pm-utils afpfs-ng fluidsynth libmodplug libnfs libshairport dbus-c__ doxygen libocnfig libffado libimobiledevice libmicrothttpd sdl_image sdl_mixer smpeg upower usbmuxd vdpau-video
Diffstat (limited to 'abs/extra/sdl_image')
-rw-r--r--abs/extra/sdl_image/PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/abs/extra/sdl_image/PKGBUILD b/abs/extra/sdl_image/PKGBUILD
index 062490b..3f5fefb 100644
--- a/abs/extra/sdl_image/PKGBUILD
+++ b/abs/extra/sdl_image/PKGBUILD
@@ -1,22 +1,29 @@
-# $Id$
-# Maintainer: Allan McRae <allan@archlinux.org>
+# $Id: PKGBUILD 148924 2012-02-05 11:56:07Z ibiru $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=sdl_image
-pkgver=1.2.10
+pkgver=1.2.12
pkgrel=2
pkgdesc="A simple library to load images of various formats as SDL surfaces"
arch=('i686' 'x86_64')
-license=('LGPL')
+license=('custom')
depends=('sdl>=1.2.13' 'libpng' 'libjpeg>=7' 'libtiff' 'zlib')
options=('!libtool')
url="http://www.libsdl.org/projects/SDL_image/"
-source=(http://www.libsdl.org/projects/SDL_image/release/SDL_image-${pkgver}.tar.gz)
-md5sums=('6c06584b31559e2b59f2b982d0d1f628')
+source=(http://www.libsdl.org/projects/SDL_image/release/SDL_image-$pkgver.tar.gz)
+md5sums=('a0f9098ebe5400f0bdc9b62e60797ecb')
build() {
- cd ${srcdir}/SDL_image-${pkgver}
- ./configure --prefix=/usr
- make || return 1
- make DESTDIR=${pkgdir} install
+ cd "$srcdir/SDL_image-$pkgver"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/SDL_image-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}