summaryrefslogtreecommitdiffstats
path: root/abs/extra/sdl_mixer/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
commitf591ead4c8a9b64b0630900aa12c260027a7db6f (patch)
tree091b31cdc3a24c0b9108f0ea718ecaad166cc834 /abs/extra/sdl_mixer/PKGBUILD
parent9b35fb3e4f637252b4674a78adf9026faeaa5340 (diff)
downloadlinhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.zip
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.gz
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.bz2
compiled/added programs needed by xbmc: Moved some programs out of community into extra.
libmpeg2 pm-utils afpfs-ng fluidsynth libmodplug libnfs libshairport dbus-c__ doxygen libocnfig libffado libimobiledevice libmicrothttpd sdl_image sdl_mixer smpeg upower usbmuxd vdpau-video
Diffstat (limited to 'abs/extra/sdl_mixer/PKGBUILD')
-rw-r--r--abs/extra/sdl_mixer/PKGBUILD47
1 files changed, 33 insertions, 14 deletions
diff --git a/abs/extra/sdl_mixer/PKGBUILD b/abs/extra/sdl_mixer/PKGBUILD
index f241519..626d401 100644
--- a/abs/extra/sdl_mixer/PKGBUILD
+++ b/abs/extra/sdl_mixer/PKGBUILD
@@ -1,29 +1,48 @@
-# $Id: PKGBUILD 70367 2010-02-26 13:24:25Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
+# $Id: PKGBUILD 170804 2012-11-12 02:00:36Z heftig $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
# Contributor: Lukas Sabota <punkrockguy318@cocmast.net> (Timidity Patch)
pkgname=sdl_mixer
-pkgver=1.2.11
-pkgrel=2
+pkgver=1.2.12
+pkgrel=3
pkgdesc="A simple multi-channel audio mixer"
arch=('i686' 'x86_64')
url="http://www.libsdl.org/projects/SDL_mixer/"
-license=('LGPL' 'GPL')
+license=('custom')
depends=('sdl>=1.2.12' 'libvorbis' 'libmikmod' 'smpeg')
+makedepends=('fluidsynth')
+optdepends=('fluidsynth: MIDI software synth, replaces built-in timidity')
options=('!libtool')
-source=(http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${pkgver}.tar.gz)
-md5sums=('65ada3d997fe85109191a5fb083f248c')
+source=(http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-$pkgver.tar.gz
+ mikmod1.patch mikmod2.patch fluidsynth-volume.patch double-free-crash.patch)
+md5sums=('e03ff73d77a55e3572ad0217131dc4a1'
+ '95a6d58686fe3017d58c39e3e1dd40f7'
+ 'd823994c3961f2ff48644478f27a27d1'
+ 'eed8b61defde36ac2077ef96d868ea3e'
+ '4b4835c63297f016a198cacb7dd68ec1')
build() {
- cd ${srcdir}/SDL_mixer-${pkgver}
+ cd "$srcdir/SDL_mixer-$pkgver"
- sed -e "/CONFIG_FILE_ETC/s/\/etc\/timidity.cfg/\/etc\/timidity++\/timidity.cfg/" \
- -e "/DEFAULT_PATH/s/\/etc\/timidity/\/etc\/timidity++/" \
- -e "/DEFAULT_PATH2/s/\/usr\/local\/lib\/timidity/\/usr\/lib\/timidity/" \
+ patch -Np1 -i ../mikmod1.patch
+ patch -Np1 -i ../mikmod2.patch
+ patch -Np1 -i ../fluidsynth-volume.patch
+ patch -Np1 -i ../double-free-crash.patch
+
+ sed -e "/CONFIG_FILE_ETC/s|/etc/timidity.cfg|/etc/timidity++/timidity.cfg|" \
+ -e "/DEFAULT_PATH/s|/etc/timidity|/etc/timidity++|" \
+ -e "/DEFAULT_PATH2/s|/usr/local/lib/timidity|/usr/lib/timidity|" \
-i timidity/config.h
- ./configure --prefix=/usr
- make || return 1
- make DESTDIR=${pkgdir} install
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/SDL_mixer-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}