summaryrefslogtreecommitdiffstats
path: root/abs/extra/sdl_sound/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-16 22:42:03 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-16 22:42:03 (GMT)
commitd62e2577add650f603546a013d65400e4e37de4a (patch)
treee986f1eef43b5e6997d99863747a28c4d7736936 /abs/extra/sdl_sound/PKGBUILD
parent7c730c71be7dd5f79d115d9edf570bea7dd475ec (diff)
downloadlinhes_pkgbuild-d62e2577add650f603546a013d65400e4e37de4a.zip
linhes_pkgbuild-d62e2577add650f603546a013d65400e4e37de4a.tar.gz
linhes_pkgbuild-d62e2577add650f603546a013d65400e4e37de4a.tar.bz2
sdl_sound: initial inclusion. dep of openal
Diffstat (limited to 'abs/extra/sdl_sound/PKGBUILD')
-rw-r--r--abs/extra/sdl_sound/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/extra/sdl_sound/PKGBUILD b/abs/extra/sdl_sound/PKGBUILD
new file mode 100644
index 0000000..28ee210
--- /dev/null
+++ b/abs/extra/sdl_sound/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=sdl_sound
+pkgver=1.0.3
+pkgrel=5
+pkgdesc="A library to decode several popular sound file formats, such as .WAV and .MP3"
+arch=('i686' 'x86_64')
+url="http://icculus.org/SDL_sound/"
+license=('LGPL')
+depends=('sdl' 'libmikmod' 'libvorbis' 'flac' 'speex' 'smpeg')
+source=(http://icculus.org/SDL_sound/downloads/SDL_sound-$pkgver.tar.gz
+ flac.patch)
+md5sums=('aa09cd52df85d29bee87a664424c94b5'
+ '302aa9dc94cc71dd3339ca3177d36e1c')
+
+build() {
+ cd ${srcdir}/SDL_sound-${pkgver}
+
+ CFLAGS="$CFLAGS -I/usr/include/smpeg" \
+ CXXFLAGS="$CXXFLAGS -I/usr/include/smpeg" \
+ ./configure --prefix=/usr --disable-static
+
+ make
+}
+
+package() {
+ cd ${srcdir}/SDL_sound-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+