summaryrefslogtreecommitdiffstats
path: root/abs/extra/sdl_sound
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-07-04 21:23:32 (GMT)
committerCecil <knoppmyth@gmail.com>2011-07-04 21:23:32 (GMT)
commit348e69411c5c9edf79dbbcbca9d2830ede28e37f (patch)
tree5d64ff99a81bd73309a63f3af08c9c91e6fc5019 /abs/extra/sdl_sound
parent4eb37367f30443395581844843732b1818c3c955 (diff)
downloadlinhes_pkgbuild-348e69411c5c9edf79dbbcbca9d2830ede28e37f.zip
linhes_pkgbuild-348e69411c5c9edf79dbbcbca9d2830ede28e37f.tar.gz
linhes_pkgbuild-348e69411c5c9edf79dbbcbca9d2830ede28e37f.tar.bz2
sdl_sound:bumped to latest
Diffstat (limited to 'abs/extra/sdl_sound')
-rw-r--r--abs/extra/sdl_sound/PKGBUILD36
1 files changed, 20 insertions, 16 deletions
diff --git a/abs/extra/sdl_sound/PKGBUILD b/abs/extra/sdl_sound/PKGBUILD
index 87885c2..cf47cae 100644
--- a/abs/extra/sdl_sound/PKGBUILD
+++ b/abs/extra/sdl_sound/PKGBUILD
@@ -1,25 +1,29 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 22259 2008-12-24 15:26:14Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-# Maintainer: dorphell <dorphell@archlinux.org>
+
pkgname=sdl_sound
-pkgver=1.0.1
-pkgrel=7
+pkgver=1.0.3
+pkgrel=2
pkgdesc="A library to decode several popular sound file formats, such as .WAV and .MP3"
-arch=(i686 x86_64)
-depends=('sdl' 'libmikmod' 'libvorbis' 'flac>=1.1.4' 'speex')
-source=(http://icculus.org/SDL_sound/downloads/SDL_sound-$pkgver.tar.gz flac.patch)
+arch=('i686' 'x86_64')
url="http://icculus.org/SDL_sound/"
+license=('LGPL')
+depends=('sdl' 'libmikmod' 'libvorbis' 'flac' 'speex' 'smpeg')
+options=('!libtool')
+source=(http://icculus.org/SDL_sound/downloads/SDL_sound-$pkgver.tar.gz
+ flac.patch)
+md5sums=('aa09cd52df85d29bee87a664424c94b5'
+ '302aa9dc94cc71dd3339ca3177d36e1c')
build() {
- cd $startdir/src/SDL_sound-$pkgver
- patch -Np1 -i ../flac.patch || return 1
- aclocal
- autoconf
- automake --foreign
+ cd ${srcdir}/SDL_sound-${pkgver}
+
+ CFLAGS="$CFLAGS -I/usr/include/smpeg" \
+ CXXFLAGS="$CXXFLAGS -I/usr/include/smpeg" \
./configure --prefix=/usr
+
make || return 1
- make DESTDIR=$startdir/pkg install
- # libtoolslay
- find $startdir/pkg -name '*.la' -exec rm {} \;
+ make DESTDIR=${pkgdir} install
}
-md5sums=('49e197ef7c8ab623d0640dc74be43160' '302aa9dc94cc71dd3339ca3177d36e1c')
+