summaryrefslogtreecommitdiffstats
path: root/abs/extra/sdlmame
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/sdlmame
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/sdlmame')
-rw-r--r--abs/extra/sdlmame/ChangeLog5
-rw-r--r--abs/extra/sdlmame/PKGBUILD65
-rw-r--r--abs/extra/sdlmame/extras.tar.gzbin0 -> 4093 bytes
-rw-r--r--abs/extra/sdlmame/sdlmame.install32
-rw-r--r--abs/extra/sdlmame/sdlmame.sh58
5 files changed, 160 insertions, 0 deletions
diff --git a/abs/extra/sdlmame/ChangeLog b/abs/extra/sdlmame/ChangeLog
new file mode 100644
index 0000000..872c595
--- /dev/null
+++ b/abs/extra/sdlmame/ChangeLog
@@ -0,0 +1,5 @@
+2008-02-13 JJDaNiMoTh <jjdanimoth.aur@gmail.com>
+ * 0.123 version
+
+2008-01-22 JJDaNiMoTh <jjdanimoth.aur@gmail.com>
+ * 0.122u6 version
diff --git a/abs/extra/sdlmame/PKGBUILD b/abs/extra/sdlmame/PKGBUILD
new file mode 100644
index 0000000..cb9d65b
--- /dev/null
+++ b/abs/extra/sdlmame/PKGBUILD
@@ -0,0 +1,65 @@
+# $Id: PKGBUILD,v 1.19 2009/04/24 15:05:30 sergej Exp $
+# Contributor: robb_force <robb_force@holybuffalo.net>
+# Maintainer: JJDaNiMoTh <jjdanimoth@gmail.com>
+
+pkgname=sdlmame
+pkgver=0.131
+pkgrel=1
+pkgdesc="A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support."
+url="http://rbelmont.mameworld.info/?page_id=163"
+license=('custom:MAME License')
+arch=('i686' 'x86_64')
+depends=('sdl>=1.2.11' 'libxinerama' 'gconf')
+makedepends=('unzip' 'nasm' 'mesa')
+DLAGENTS=('http::/usr/bin/wget -U "" -c -t 3 --waitretry=3')
+options=('!makeflags' 'force')
+install=sdlmame.install
+source=(http://rbelmont.mameworld.info/${pkgname}${pkgver%.*}${pkgver#*.}.zip \
+ sdlmame.sh \
+ extras.tar.gz)
+md5sums=('d4891999ec2ee11cb0d75a1596e17060'
+ '3119ccfa1e970eba4467df31208adaf0'
+ '420b61240bf5ae11615ba7c6100ee00d')
+
+build() {
+ cd ${startdir}/src/${pkgname}${pkgver%.*}${pkgver#*.}
+
+ sed -i 's/-Werror//' makefile || return 1
+
+ # Modify the make options based on the user's architecture
+ if [ "$CARCH" == "x86_64" ]; then
+ echo "Compiling for AMD64..."
+ make AMD64=1 PTR64=1 || return 1
+ elif [ "$CARCH" == "i686" ]; then
+ make I686=1 || return 1
+ else
+ echo "Compiling for i386..."
+ make PM=1 || return 1
+ fi
+
+ # Install the sdlmame script
+ install -Dm755 ${startdir}/src/${pkgname}.sh ${startdir}/pkg/usr/bin/${pkgname} || return 1
+
+ # Install the applications and the UI font in /usr/share
+ install -Dm755 mame* ${startdir}/pkg/usr/share/${pkgname}/${pkgname} && \
+ install -m755 chdman ${startdir}/pkg/usr/share/${pkgname}/chdman && \
+ install -m755 jedutil ${startdir}/pkg/usr/share/${pkgname}/jedutil && \
+# install -m755 makemeta ${startdir}/pkg/usr/share/${pkgname}/makemeta && \
+ install -m755 regrep ${startdir}/pkg/usr/share/${pkgname}/regrep && \
+ install -m755 romcmp ${startdir}/pkg/usr/share/${pkgname}/romcmp && \
+ install -m755 runtest ${startdir}/pkg/usr/share/${pkgname}/runtest && \
+ install -m755 testkeys ${startdir}/pkg/usr/share/${pkgname}/testkeys && \
+ install -m755 src2html ${startdir}/pkg/usr/share/${pkgname}/src2html && \
+ install -m755 srcclean ${startdir}/pkg/usr/share/${pkgname}/srcclean && \
+ install -m755 ldverify ${startdir}/pkg/usr/share/${pkgname}/ldverify && \
+ install -m644 ui.bdf ${startdir}/pkg/usr/share/${pkgname}/ui.bdf || return 1
+
+ # Install the extra bits
+ install -d ${startdir}/pkg/usr/share/${pkgname}/{artwork,ctrlr,keymaps} && \
+ install -m644 ${startdir}/src/artwork/* ${startdir}/pkg/usr/share/${pkgname}/artwork/ && \
+ install -m644 ${startdir}/src/ctrlr/* ${startdir}/pkg/usr/share/${pkgname}/ctrlr/ && \
+ install -m644 keymaps/* ${startdir}/pkg/usr/share/${pkgname}/keymaps/ || return 1
+
+ # Include the license
+ install -Dm644 docs/license.txt $startdir/pkg/usr/share/licenses/${pkgname}/license.txt
+}
diff --git a/abs/extra/sdlmame/extras.tar.gz b/abs/extra/sdlmame/extras.tar.gz
new file mode 100644
index 0000000..ae0bc2a
--- /dev/null
+++ b/abs/extra/sdlmame/extras.tar.gz
Binary files differ
diff --git a/abs/extra/sdlmame/sdlmame.install b/abs/extra/sdlmame/sdlmame.install
new file mode 100644
index 0000000..eedae49
--- /dev/null
+++ b/abs/extra/sdlmame/sdlmame.install
@@ -0,0 +1,32 @@
+# Message displayed for a fresh install.
+post_install()
+{
+ echo ""
+ echo "***************************************************************"
+ echo " SDLMAME and the additional MAME utilities have been installed"
+ echo " in /usr/share/sdlmame However, SDLMAME can be run by"
+ echo " typing sdlmame and it's options. Try running SDLMAME with"
+ echo " these options:"
+ echo " sdlmame <rom> -nowindow -noswitchres"
+ echo "***************************************************************"
+ echo ""
+}
+
+# Message for an update.
+post_upgrade()
+{
+ echo ""
+ echo "***************************************************************"
+ echo " SDLMAME has been updated. If you are upgrading directly from"
+ echo " 0.117 or earlier, you must delete all .cfg files and"
+ echo " re-configure your controllers. You should also run"
+ echo " 'SDLMAME --newini' to force the script to create a new ini"
+ echo " file with default settings at ~/.mame/sdlmame.ini"
+ echo " since there may be new ini options."
+ echo "***************************************************************"
+ echo ""
+}
+
+op=$1
+shift
+$op $*
diff --git a/abs/extra/sdlmame/sdlmame.sh b/abs/extra/sdlmame/sdlmame.sh
new file mode 100644
index 0000000..38b4870
--- /dev/null
+++ b/abs/extra/sdlmame/sdlmame.sh
@@ -0,0 +1,58 @@
+#!/bin/sh
+
+# Create a variable equal to $HOME that will be used later in the ini creation
+home=('$HOME')
+
+if [ "$1" != "" ] && [ "$1" = "--newini" ]; then
+ echo "Rebuilding the ini file at $HOME/.mame/sdlmame.ini"
+ echo "Modify this file for permanent changes to your SDLMAME"
+ echo "options and paths before running SDLMAME again."
+ cd $HOME/.mame
+ if [ -e sdlmame.ini ]; then
+ echo "Your old ini file has been renamed to sdlmameini.bak"
+ mv sdlmame.ini sdlmameini.bak
+ fi
+ /usr/share/sdlmame/sdlmame \
+ -artpath "$home/.mame/artwork;artwork" \
+ -ctrlrpath "$home/.mame/ctrlr;ctrlr" \
+ -inipath $home/.mame/ini \
+ -rompath $home/.mame/roms \
+ -samplepath $home/.mame/samples \
+ -cfg_directory $home/.mame/cfg \
+ -comment_directory $home/.mame/comments \
+ -diff_directory $home/.mame/diff \
+ -input_directory $home/.mame/inp \
+ -memcard_directory $home/.mame/memcard \
+ -nvram_directory $home/.mame/nvram \
+ -snapshot_directory $home/.mame/snap \
+ -state_directory $home/.mame/sta \
+ -video opengl \
+ -createconfig
+elif [ ! -e $HOME/.mame ]; then
+ echo "Running SDLMAME for the first time..."
+ echo "Creating an ini file for SDLMAME at $HOME/.mame/sdlmame.ini"
+ echo "Modify this file for permanent changes to your SDLMAME"
+ echo "options and paths before running SDLMAME again."
+ mkdir $HOME/.mame
+ mkdir $HOME/.mame/{artwork,cfg,comments,ctrlr,diff,ini,inp,memcard,nvram,samples,snap,sta}
+ cd $HOME/.mame
+ /usr/share/sdlmame/sdlmame \
+ -artpath "$home/.mame/artwork;artwork" \
+ -ctrlrpath "$home/.mame/ctrlr;ctrlr" \
+ -inipath $home/.mame/ini \
+ -rompath $home/.mame/roms \
+ -samplepath $home/.mame/samples \
+ -cfg_directory $home/.mame/cfg \
+ -comment_directory $home/.mame/comments \
+ -diff_directory $home/.mame/diff \
+ -input_directory $home/.mame/inp \
+ -memcard_directory $home/.mame/memcard \
+ -nvram_directory $home/.mame/nvram \
+ -snapshot_directory $home/.mame/snap \
+ -state_directory $home/.mame/sta \
+ -video opengl \
+ -createconfig
+else
+ cd /usr/share/sdlmame
+ ./sdlmame "$@"
+fi