summaryrefslogtreecommitdiffstats
path: root/abs/extra/sip
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-11-04 19:21:33 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-11-04 19:21:33 (GMT)
commit056c8fbec98ad06a112306eeb783efa83d862305 (patch)
tree7fae9128c1ed5568a860e72c8b625196cdf9db62 /abs/extra/sip
parent67989fe1be117ac23fa3a98acbc2794a17d7d0ed (diff)
downloadlinhes_pkgbuild-056c8fbec98ad06a112306eeb783efa83d862305.zip
linhes_pkgbuild-056c8fbec98ad06a112306eeb783efa83d862305.tar.gz
linhes_pkgbuild-056c8fbec98ad06a112306eeb783efa83d862305.tar.bz2
sip: update to latest fror qscintilla
Diffstat (limited to 'abs/extra/sip')
-rw-r--r--abs/extra/sip/PKGBUILD55
1 files changed, 40 insertions, 15 deletions
diff --git a/abs/extra/sip/PKGBUILD b/abs/extra/sip/PKGBUILD
index b17f34b..f50d054 100644
--- a/abs/extra/sip/PKGBUILD
+++ b/abs/extra/sip/PKGBUILD
@@ -1,30 +1,55 @@
-# $Id: PKGBUILD 96646 2010-10-23 10:39:10Z andrea $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# $Id$
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: riai <riai@bigfoot.com>, Ben <ben@benmazer.net>
-pkgname=sip
-pkgver=4.11.2
-pkgrel=2
-pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
+pkgbase=sip
+pkgname=('sip' 'python2-sip')
+pkgver=4.13
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.riverbankcomputing.com/software/sip/"
license=('custom:"sip"')
-depends=('python2' 'gcc-libs')
-source=("http://www.riverbankcomputing.com/static/Downloads/sip4/${pkgname}-${pkgver}.tar.gz")
-md5sums=('d799804ca0a88bd76c6c2cdf8935c3cb')
+makedepends=('python' 'python2')
+source=("http://www.riverbankcomputing.com/static/Downloads/sip4/${pkgbase}-${pkgver}.tar.gz")
+md5sums=('21b4e2cad56e4156df2220143264b8ff')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}"
+ cp -r ${pkgbase}-${pkgver} python2-${pkgbase}-${pkgver}
- python2 configure.py
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python configure.py CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
+ make
+
+ ### Python2 version ###
+ cd "${srcdir}/python2-${pkgbase}-${pkgver}"
+ python2 configure.py CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
make
}
-package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+package_sip() {
+ pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
+ depends=('python')
+ replaces=('python-sip')
+ provides=('python-sip')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+package_python2-sip() {
+ pkgdesc="A tool that makes it easy to create Python2 bindings for C and C++ libraries"
+ depends=('sip' 'python2')
+
+ cd "${srcdir}/python2-${pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Provided by sip
+ rm "${pkgdir}/usr/bin/sip"
+}