summaryrefslogtreecommitdiffstats
path: root/abs/extra/sip
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 20:49:22 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 20:49:22 (GMT)
commitf3ed85f517da4f9c61e2cc42098a5344ba92b92a (patch)
treef77c23284da4395fa208c93f247e6d5699962bd8 /abs/extra/sip
parentd0967e41b6a11c0565ff5cd6c291bf6b7db8896e (diff)
downloadlinhes_pkgbuild-f3ed85f517da4f9c61e2cc42098a5344ba92b92a.zip
linhes_pkgbuild-f3ed85f517da4f9c61e2cc42098a5344ba92b92a.tar.gz
linhes_pkgbuild-f3ed85f517da4f9c61e2cc42098a5344ba92b92a.tar.bz2
sip 4.13.3
Diffstat (limited to 'abs/extra/sip')
-rw-r--r--abs/extra/sip/PKGBUILD52
-rw-r--r--abs/extra/sip/__changelog1
2 files changed, 32 insertions, 21 deletions
diff --git a/abs/extra/sip/PKGBUILD b/abs/extra/sip/PKGBUILD
index f50d054..866d89d 100644
--- a/abs/extra/sip/PKGBUILD
+++ b/abs/extra/sip/PKGBUILD
@@ -1,27 +1,26 @@
-# $Id$
-# Maintainer:
-# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# $Id: PKGBUILD 162739 2012-06-29 11:34:13Z andrea $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: riai <riai@bigfoot.com>, Ben <ben@benmazer.net>
pkgbase=sip
pkgname=('sip' 'python2-sip')
-pkgver=4.13
-pkgrel=1
+pkgver=4.13.3
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.riverbankcomputing.com/software/sip/"
license=('custom:"sip"')
-makedepends=('python' 'python2')
+makedepends=( 'python2')
source=("http://www.riverbankcomputing.com/static/Downloads/sip4/${pkgbase}-${pkgver}.tar.gz")
-md5sums=('21b4e2cad56e4156df2220143264b8ff')
+md5sums=('76192829cc42ec558db46e4f9e1d8ba9')
build() {
cd "${srcdir}"
cp -r ${pkgbase}-${pkgver} python2-${pkgbase}-${pkgver}
- cd "${srcdir}/${pkgbase}-${pkgver}"
- python configure.py CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
- make
+ #cd "${srcdir}/${pkgbase}-${pkgver}"
+ #python configure.py CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
+ #make
### Python2 version ###
cd "${srcdir}/python2-${pkgbase}-${pkgver}"
@@ -31,25 +30,36 @@ build() {
package_sip() {
pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
- depends=('python')
- replaces=('python-sip')
- provides=('python-sip')
+ depends=('glibc')
- cd "${srcdir}/${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/python2-${pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install -C sipgen
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+package_python-sip1() {
+ pkgdesc="Python 3.x SIP bindings for C and C++ libraries"
+ depends=('sip' 'python')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ make DESTDIR="${pkgdir}" install -C siplib
+
+ install -Dm644 sipconfig.py "${pkgdir}"/usr/lib/python3.2/site-packages/sipconfig.py
+ install -Dm644 sipdistutils.py "${pkgdir}"/usr/lib/python3.2/site-packages/sipdistutils.py
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
package_python2-sip() {
- pkgdesc="A tool that makes it easy to create Python2 bindings for C and C++ libraries"
+ pkgdesc="Python 2.x SIP bindings for C and C++ libraries"
depends=('sip' 'python2')
cd "${srcdir}/python2-${pkgbase}-${pkgver}"
- make DESTDIR="${pkgdir}" install
-
+ make DESTDIR="${pkgdir}" install -C siplib
+
+ install -Dm644 sipconfig.py "${pkgdir}"/usr/lib/python2.7/site-packages/sipconfig.py
+ install -Dm644 sipdistutils.py "${pkgdir}"/usr/lib/python2.7/site-packages/sipdistutils.py
+
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- # Provided by sip
- rm "${pkgdir}/usr/bin/sip"
}
diff --git a/abs/extra/sip/__changelog b/abs/extra/sip/__changelog
new file mode 100644
index 0000000..9731eb3
--- /dev/null
+++ b/abs/extra/sip/__changelog
@@ -0,0 +1 @@
+removed python3