summaryrefslogtreecommitdiffstats
path: root/abs/extra/slang
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/slang
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/slang')
-rw-r--r--abs/extra/slang/ChangeLog7
-rw-r--r--abs/extra/slang/PKGBUILD24
2 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/slang/ChangeLog b/abs/extra/slang/ChangeLog
new file mode 100644
index 0000000..450a2a2
--- /dev/null
+++ b/abs/extra/slang/ChangeLog
@@ -0,0 +1,7 @@
+2008-12-19 Eric Belanger <eric@archlinux.org>
+
+ * slang 2.1.4-1
+ * Upstream update
+ * Added pcre depends
+ * Added backup array
+ * Added ChangeLog
diff --git a/abs/extra/slang/PKGBUILD b/abs/extra/slang/PKGBUILD
new file mode 100644
index 0000000..16622d4
--- /dev/null
+++ b/abs/extra/slang/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 21963 2008-12-19 07:30:56Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=slang
+pkgver=2.1.4
+pkgrel=1
+pkgdesc="S-Lang is a powerful interpreted language"
+arch=('i686' 'x86_64')
+url="http://www.s-lang.org/"
+license=('GPL')
+depends=('glibc' 'pcre')
+backup=('etc/slsh.rc')
+options=('!makeflags')
+source=(ftp://ftp.fu-berlin.de/pub/unix/misc/slang/v${pkgver%.*}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('3516f593bc04975844f26137c18275d2')
+sha1sums=('5c97698f7dcd91834ce64a4dac476a3587851ead')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc || return 1
+ make || return 1
+ make install-all DESTDIR=${pkgdir} || return 1
+}