summaryrefslogtreecommitdiffstats
path: root/abs/extra/smartmontools/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-08-16 17:54:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-08-16 17:59:29 (GMT)
commit786eef48b2fb22dff520b45560b124225a1155dc (patch)
tree96d97eb33af1edb996fdcc99fc3d974f78a38d65 /abs/extra/smartmontools/PKGBUILD
parentef2a0c8b6785730d7ef65b5ba4f98dc5c669209d (diff)
downloadlinhes_pkgbuild-786eef48b2fb22dff520b45560b124225a1155dc.zip
linhes_pkgbuild-786eef48b2fb22dff520b45560b124225a1155dc.tar.gz
linhes_pkgbuild-786eef48b2fb22dff520b45560b124225a1155dc.tar.bz2
smartmon tools: 6.3
refs #961
Diffstat (limited to 'abs/extra/smartmontools/PKGBUILD')
-rw-r--r--abs/extra/smartmontools/PKGBUILD47
1 files changed, 32 insertions, 15 deletions
diff --git a/abs/extra/smartmontools/PKGBUILD b/abs/extra/smartmontools/PKGBUILD
index fe12bd5..685750d 100644
--- a/abs/extra/smartmontools/PKGBUILD
+++ b/abs/extra/smartmontools/PKGBUILD
@@ -1,28 +1,45 @@
-# $Id: PKGBUILD 6701 2008-07-27 13:29:59Z giovanni $
+# $Id: PKGBUILD 219339 2014-08-05 17:28:35Z giovanni $
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Jeff Mickey <jeff@archlinux.org>
# Contributor: Jani Talikka <jani.talikka@gmail.com>
+# Contributor: Ralf Barth <archlinux.org@haggy.org>
pkgname=smartmontools
-pkgver=5.41
+pkgver=6.3
pkgrel=1
-pkgdesc="Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives."
+pkgdesc="Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives"
url="http://smartmontools.sourceforge.net"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('gcc-libs')
-backup=('etc/smartd.conf')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-install=smartmontools.install
+depends=('gcc-libs' 'libcap-ng' 'bash')
+optdepends=('heirloom-mailx: to get mail alerts to work')
+backup=('etc/smartd.conf'
+ 'etc/conf.d/smartd')
+source=("http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'smartd.conf')
+md5sums=('2ea0c62206e110192a97b59291b17f54'
+ '28c1b80c41dac52d433961dcfb4f70e0')
-build()
-{
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --sysconfdir=/etc --includedir=/usr/src/linux-2.6.39-LinHES
- make || return 1
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --enable-drivedb \
+ --with-libcap-ng=yes \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
+ make
}
+
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -i -e "s:sysconfig/smartmontools:conf.d/smartd:g" smartd.service
+ sed -i -e "s:smartd_opts:SMARTD_ARGS:g" smartd.service
+
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf ${pkgdir}/etc/rc.d
+ install -Dm644 ${srcdir}/smartd.conf "${pkgdir}/etc/conf.d/smartd"
}
-md5sums=('4577886bea79d4ff12bd9a7d323ce692')