summaryrefslogtreecommitdiffstats
path: root/abs/extra/smartmontools
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-08-04 23:36:19 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-08-04 23:36:19 (GMT)
commit4bc7b0f67aa62aa9455b940cb7ec14661be98193 (patch)
tree18a2a5232f3a47b4774c6a9222a896ff8062d90c /abs/extra/smartmontools
parent0c83ce8883d7c353049974197679731e33b410f2 (diff)
downloadlinhes_pkgbuild-4bc7b0f67aa62aa9455b940cb7ec14661be98193.zip
linhes_pkgbuild-4bc7b0f67aa62aa9455b940cb7ec14661be98193.tar.gz
linhes_pkgbuild-4bc7b0f67aa62aa9455b940cb7ec14661be98193.tar.bz2
smartmontools: update to 5.41
Diffstat (limited to 'abs/extra/smartmontools')
-rw-r--r--abs/extra/smartmontools/PKGBUILD13
-rw-r--r--abs/extra/smartmontools/__changelog2
-rw-r--r--abs/extra/smartmontools/smartmontools.install24
3 files changed, 31 insertions, 8 deletions
diff --git a/abs/extra/smartmontools/PKGBUILD b/abs/extra/smartmontools/PKGBUILD
index ecb4fd5..fe12bd5 100644
--- a/abs/extra/smartmontools/PKGBUILD
+++ b/abs/extra/smartmontools/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Jani Talikka <jani.talikka@gmail.com>
pkgname=smartmontools
-pkgver=5.40
+pkgver=5.41
pkgrel=1
pkgdesc="Control and monitor S.M.A.R.T. enabled ATA and SCSI Hard Drives."
url="http://smartmontools.sourceforge.net"
@@ -12,20 +12,17 @@ license=('GPL')
arch=('i686' 'x86_64')
depends=('gcc-libs')
backup=('etc/smartd.conf')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz \
- smartd)
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+install=smartmontools.install
build()
{
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --sysconfdir=/etc --includedir=/usr/src/linux-2.6.37-LinHES
+ ./configure --prefix=/usr --sysconfdir=/etc --includedir=/usr/src/linux-2.6.39-LinHES
make || return 1
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
- rm -rf ${pkgdir}/etc/rc.d
- install -D -m 755 ../smartd ${pkgdir}/etc/rc.d/smartd
}
-md5sums=('0f0be0239914ad87830a4fff594bda5b'
- '850f98b6792b7642ff193a49a2f1139d')
+md5sums=('4577886bea79d4ff12bd9a7d323ce692')
diff --git a/abs/extra/smartmontools/__changelog b/abs/extra/smartmontools/__changelog
new file mode 100644
index 0000000..8e0d8a6
--- /dev/null
+++ b/abs/extra/smartmontools/__changelog
@@ -0,0 +1,2 @@
+* remove the rc script. runit script in runit-scripts pkg
+* added smartmontools.install
diff --git a/abs/extra/smartmontools/smartmontools.install b/abs/extra/smartmontools/smartmontools.install
new file mode 100644
index 0000000..f2baacd
--- /dev/null
+++ b/abs/extra/smartmontools/smartmontools.install
@@ -0,0 +1,24 @@
+#!/bin/bash
+
+post_install() {
+
+ echo ""
+ echo "==> Configure your /etc/smart.conf config file and then"
+ echo "==> $ sudo add_service.sh smartd"
+ echo "==> to start the monitoring service."
+
+}
+
+post_upgrade() {
+
+ post_install
+
+}
+
+pre_remove() {
+
+ if [ -L /service/smartd ]; then
+ remove_service.sh smartd
+ fi
+
+}