summaryrefslogtreecommitdiffstats
path: root/abs/extra/source-highlight/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2019-03-19 20:11:10 (GMT)
committerBritney Fransen <brfransen@gmail.com>2019-03-19 20:11:10 (GMT)
commit73cfb83a5baecfe0529fda59ca57233d8843f783 (patch)
tree2dba2103a6f6e43912fc645ca8b48a85ab500ad2 /abs/extra/source-highlight/PKGBUILD
parent7b41a9288f5d1332c8136df798bb8ca2465bc21c (diff)
parent448cb8d0708224d78c24ce3615dc7eef44d4689b (diff)
downloadlinhes_pkgbuild-73cfb83a5baecfe0529fda59ca57233d8843f783.zip
linhes_pkgbuild-73cfb83a5baecfe0529fda59ca57233d8843f783.tar.gz
linhes_pkgbuild-73cfb83a5baecfe0529fda59ca57233d8843f783.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/source-highlight/PKGBUILD')
-rw-r--r--abs/extra/source-highlight/PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/abs/extra/source-highlight/PKGBUILD b/abs/extra/source-highlight/PKGBUILD
index 6c1ae0c..250ab53 100644
--- a/abs/extra/source-highlight/PKGBUILD
+++ b/abs/extra/source-highlight/PKGBUILD
@@ -1,18 +1,24 @@
-# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
pkgname=source-highlight
pkgver=3.1.8
-pkgrel=14
+pkgrel=18
pkgdesc="Convert source code to syntax highlighted document"
arch=('x86_64')
url="http://www.gnu.org/software/src-highlite/"
license=('GPL')
depends=('bash' 'boost-libs')
makedepends=('ctags' 'boost')
-source=("ftp://ftp.gnu.org/gnu/src-highlite/${pkgname}-${pkgver}.tar.gz")
-md5sums=('3243470706ef5fefdc3e43b5306a4e41')
+source=("ftp://ftp.gnu.org/gnu/src-highlite/${pkgname}-${pkgver}.tar.gz"
+ "fix-zsh-highlighting-hangups.patch")
+md5sums=('3243470706ef5fefdc3e43b5306a4e41'
+ '5b6129bca6fcd0ea252fa31bf7a988fa')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -Np1 -i "${srcdir}/fix-zsh-highlighting-hangups.patch"
+}
build() {
cd ${pkgname}-${pkgver}