summaryrefslogtreecommitdiffstats
path: root/abs/extra/spidermonkey/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-08-03 20:50:44 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-08-03 20:50:44 (GMT)
commit1b9e65f20bdc2e7445a016865c2542ebe7e74eff (patch)
treec3188e81f3ea20ea450f32a4df09d3d9dfabde61 /abs/extra/spidermonkey/PKGBUILD
parent335c95d040f49b0bca473fd03e4f91340f1966ff (diff)
downloadlinhes_pkgbuild-1b9e65f20bdc2e7445a016865c2542ebe7e74eff.zip
linhes_pkgbuild-1b9e65f20bdc2e7445a016865c2542ebe7e74eff.tar.gz
linhes_pkgbuild-1b9e65f20bdc2e7445a016865c2542ebe7e74eff.tar.bz2
js: initial include as dep of gpac. Replaces spidermonkey.
Diffstat (limited to 'abs/extra/spidermonkey/PKGBUILD')
-rw-r--r--abs/extra/spidermonkey/PKGBUILD31
1 files changed, 0 insertions, 31 deletions
diff --git a/abs/extra/spidermonkey/PKGBUILD b/abs/extra/spidermonkey/PKGBUILD
deleted file mode 100644
index e923cbe..0000000
--- a/abs/extra/spidermonkey/PKGBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# $Id: PKGBUILD 55903 2009-10-15 23:18:35Z andrea $
-# Contributor: Aaron Griffin <aaron@archlinux.org>
-
-pkgname=spidermonkey
-pkgver=1.7.0
-pkgrel=3
-pkgdesc="Mozilla's C implementation of JavaScript."
-arch=("i686" "x86_64")
-url="http://www.mozilla.org/js/spidermonkey/"
-license=('MPL' 'GPL' 'LGPL')
-depends=('nspr')
-options=('!makeflags')
-source=("http://ftp.mozilla.org/pub/mozilla.org/js/js-$pkgver.tar.gz" \
- "spidermonkey-1.7-threadsafe.patch" "spidermonkey-Makefile.patch")
-md5sums=('5571134c3863686b623ebe4e6b1f6fe6'
- 'b2ef9be017b6aa1857354b5223975a4f'
- '161d4c0f2c604d15cba29dab60b1f7a7')
-
-build() {
- cd "$srcdir/js/src"
- patch -p0 < "$srcdir/spidermonkey-Makefile.patch" || return 1
- sed -i 's|include|include/js|' rules.mk || return 1
- # fix for the lib location
- [ "$CARCH" = "x86_64" ] && (sed -i -e "s:lib64:lib:g" config.mk || return 1)
- # patch Makefile for threadsafe support with native nspr
- patch -p2 -i "$srcdir/spidermonkey-1.7-threadsafe.patch" || return 1
- # FS#16673
- export CFLAGS="${CFLAGS} -DJS_C_STRINGS_ARE_UTF8"
- # build - threadsafe
- make -f Makefile.ref BUILD_OPT=1 JS_THREADSAFE=1 DIST="$pkgdir/usr" all export || return 1
-}