summaryrefslogtreecommitdiffstats
path: root/abs/extra/strace
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-08-05 20:03:32 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-08-05 20:03:32 (GMT)
commitbe5265a6fbad290bddfae4181a2ff093e1d273fb (patch)
treef334b860e1af80a7fbf7e23df36a87529f083690 /abs/extra/strace
parente1da8f3a5c013b91a66645790b637a2bed9335eb (diff)
downloadlinhes_pkgbuild-be5265a6fbad290bddfae4181a2ff093e1d273fb.zip
linhes_pkgbuild-be5265a6fbad290bddfae4181a2ff093e1d273fb.tar.gz
linhes_pkgbuild-be5265a6fbad290bddfae4181a2ff093e1d273fb.tar.bz2
strace: Bump to latest.
Diffstat (limited to 'abs/extra/strace')
-rw-r--r--abs/extra/strace/PKGBUILD26
-rw-r--r--abs/extra/strace/no_linux_socket_h.patch22
2 files changed, 16 insertions, 32 deletions
diff --git a/abs/extra/strace/PKGBUILD b/abs/extra/strace/PKGBUILD
index c965f24..5a33af7 100644
--- a/abs/extra/strace/PKGBUILD
+++ b/abs/extra/strace/PKGBUILD
@@ -1,21 +1,27 @@
-# $Id: PKGBUILD 13699 2008-09-27 22:25:37Z giovanni $
+# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
pkgname=strace
-pkgver=4.5.18
+pkgver=4.6
pkgrel=1
pkgdesc="A useful diagnositic, instructional, and debugging tool"
arch=('i686' 'x86_64')
-license=('custom')
url="http://sourceforge.net/projects/strace/"
-depends=('glibc')
-source=(http://downloads.sourceforge.net/sourceforge/strace/strace-$pkgver.tar.bz2)
-md5sums=('e9449fcee97e6a8ed73934c883c870e0')
+license=('custom')
+depends=('perl')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-$pkgver.tar.xz)
+md5sums=('e537b2b1afeec70c0e6e27a0d0fd671e')
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install
- install -Dm644 COPYRIGHT ${startdir}/pkg/usr/share/licenses/strace/COPYRIGHT
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+
+ install -Dm644 COPYRIGHT ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
diff --git a/abs/extra/strace/no_linux_socket_h.patch b/abs/extra/strace/no_linux_socket_h.patch
deleted file mode 100644
index f1c3598..0000000
--- a/abs/extra/strace/no_linux_socket_h.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- strace-4.5.12.orig/configure.ac
-+++ strace-4.5.12/configure.ac
-@@ -193,8 +193,7 @@
-
- AC_CHECK_FUNCS(sigaction strerror strsignal pread sys_siglist _sys_siglist getdents mctl prctl sendmsg inet_ntop if_indextoname)
- AC_CHECK_HEADERS([sys/reg.h sys/filio.h sys/acl.h sys/asynch.h sys/door.h stropts.h sys/conf.h sys/stream.h sys/tihdr.h sys/tiuser.h sys/sysconfig.h ioctls.h sys/ioctl.h sys/ptrace.h termio.h linux/ptrace.h asm/reg.h sys/uio.h sys/aio.h poll.h sys/poll.h sys/vfs.h asm/sysmips.h linux/utsname.h sys/nscsys.h mqueue.h sys/epoll.h libaio.h], [], [])
--AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h],
-- [], [], [#include <linux/socket.h>])
-+AC_CHECK_HEADERS([linux/icmp.h linux/in6.h linux/netlink.h linux/if_packet.h])
- AC_CHECK_HEADERS([asm/sigcontext.h], [], [], [#include <signal.h>])
- AC_CHECK_HEADERS([netinet/tcp.h netinet/udp.h],,, [#include <netinet/in.h>])
-
---- strace-4.5.12.orig/configure
-+++ strace-4.5.12/configure
-@@ -6945,7 +6945,6 @@
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
--#include <linux/socket.h>
-
- #include <$ac_header>
- _ACEOF