summaryrefslogtreecommitdiffstats
path: root/abs/extra/syslinux/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 20:50:47 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 20:50:47 (GMT)
commit57d54c587ee2598e7e90b3149feba6722f020e44 (patch)
tree341690ec6c63c116c68fb6f43bff7e257b1f1610 /abs/extra/syslinux/PKGBUILD
parent68988b0cc1a1b3e8d412f9a1b020732f7abf49f0 (diff)
downloadlinhes_pkgbuild-57d54c587ee2598e7e90b3149feba6722f020e44.zip
linhes_pkgbuild-57d54c587ee2598e7e90b3149feba6722f020e44.tar.gz
linhes_pkgbuild-57d54c587ee2598e7e90b3149feba6722f020e44.tar.bz2
syslinux 4.05
Diffstat (limited to 'abs/extra/syslinux/PKGBUILD')
-rw-r--r--abs/extra/syslinux/PKGBUILD32
1 files changed, 23 insertions, 9 deletions
diff --git a/abs/extra/syslinux/PKGBUILD b/abs/extra/syslinux/PKGBUILD
index e2c9eb8..f8bcb92 100644
--- a/abs/extra/syslinux/PKGBUILD
+++ b/abs/extra/syslinux/PKGBUILD
@@ -1,22 +1,30 @@
-# $Id: PKGBUILD 97504 2010-10-30 20:11:46Z tpowa $
+# $Id: PKGBUILD 155387 2012-04-03 08:18:06Z thomas $
# Maintainer: Thomas Bächler <thomas@archlinux.org>
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=syslinux
-pkgver=4.03
-pkgrel=1
+pkgver=4.05
+pkgrel=4
arch=('i686' 'x86_64')
-pkgdesc="Collection of flexible boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE"
+pkgdesc="Collection of boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE"
url="http://syslinux.zytor.com/"
license=('GPL2')
depends=('perl' 'glibc')
optdepends=('perl-passwd-md5: For md5pass'
'perl-digest-sha1: For sha1pass'
- 'mtools: For mkdiskimage and syslinux'
+ 'mtools: For mkdiskimage and syslinux support'
)
makedepends=('nasm')
+backup=('boot/syslinux/syslinux.cfg')
+install=syslinux.install
source=(http://www.kernel.org/pub/linux/utils/boot/syslinux/$pkgname-${pkgver}.tar.bz2
- syslinux-dont-build-dos-windows-targets.patch)
+ syslinux-dont-build-dos-windows-targets.patch
+ syslinux.cfg
+ syslinux-install_update)
+md5sums=('82299242418385da1274c9479a778cb2'
+ '1528c376e43f0eaccaa80d8ad1bc13b4'
+ '832595501944fbcabcdc1207f4724fe7'
+ '680750f73dc2e587ac567d057d485813')
build() {
# Do not try to build syslinux with our default LDFLAGS, it will fail
@@ -25,13 +33,19 @@ build() {
# Do not try to build the Windows or DOS installers
patch -p1 -i "$srcdir"/syslinux-dont-build-dos-windows-targets.patch
# Fix FHS manpage path
- sed 's|/usr/man|/usr/share/man|g' -i MCONFIG
+ sed 's|/usr/man|/usr/share/man|g' -i mk/syslinux.mk
make
}
package() {
cd "$srcdir"/$pkgname-${pkgver}
make INSTALLROOT="$pkgdir" AUXDIR=/usr/lib/syslinux install
+
+ # Install the default configuration
+ install -D -m644 "$srcdir"/syslinux.cfg "$pkgdir"/boot/syslinux/syslinux.cfg
+ # Install the installation and update script
+ # This script is maintained at git://gist.github.com/772138.git
+ install -D -m755 "$srcdir"/syslinux-install_update "$pkgdir"/usr/sbin/syslinux-install_update
+ # move extlinux binary to /usr/sbin
+ mv "$pkgdir"/sbin/extlinux "$pkgdir"/usr/sbin/extlinux
}
-md5sums=('a7ca38a0a5786b6efae8fb01a1ae8070'
- '895722a392f3d798a7cc24bc154656f0')