summaryrefslogtreecommitdiffstats
path: root/abs/extra/syslinux/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-12-02 20:57:37 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-12-02 20:57:37 (GMT)
commit7b9f0efdfe07a53b3bf5dfb89508fbc7089ec41e (patch)
treeae90ae4b4d1c2ed4cfe96971dad03f66266ac239 /abs/extra/syslinux/PKGBUILD
parentfc8330fc4a8aa4c8607c63590522aa3582a468ea (diff)
downloadlinhes_pkgbuild-7b9f0efdfe07a53b3bf5dfb89508fbc7089ec41e.zip
linhes_pkgbuild-7b9f0efdfe07a53b3bf5dfb89508fbc7089ec41e.tar.gz
linhes_pkgbuild-7b9f0efdfe07a53b3bf5dfb89508fbc7089ec41e.tar.bz2
syslinux: readd for cd creation
Diffstat (limited to 'abs/extra/syslinux/PKGBUILD')
-rw-r--r--abs/extra/syslinux/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/abs/extra/syslinux/PKGBUILD b/abs/extra/syslinux/PKGBUILD
new file mode 100644
index 0000000..e2c9eb8
--- /dev/null
+++ b/abs/extra/syslinux/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 97504 2010-10-30 20:11:46Z tpowa $
+# Maintainer: Thomas Bächler <thomas@archlinux.org>
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=syslinux
+pkgver=4.03
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Collection of flexible boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE"
+url="http://syslinux.zytor.com/"
+license=('GPL2')
+depends=('perl' 'glibc')
+optdepends=('perl-passwd-md5: For md5pass'
+ 'perl-digest-sha1: For sha1pass'
+ 'mtools: For mkdiskimage and syslinux'
+ )
+makedepends=('nasm')
+source=(http://www.kernel.org/pub/linux/utils/boot/syslinux/$pkgname-${pkgver}.tar.bz2
+ syslinux-dont-build-dos-windows-targets.patch)
+
+build() {
+ # Do not try to build syslinux with our default LDFLAGS, it will fail
+ unset LDFLAGS
+ cd "$srcdir"/$pkgname-${pkgver}
+ # Do not try to build the Windows or DOS installers
+ patch -p1 -i "$srcdir"/syslinux-dont-build-dos-windows-targets.patch
+ # Fix FHS manpage path
+ sed 's|/usr/man|/usr/share/man|g' -i MCONFIG
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-${pkgver}
+ make INSTALLROOT="$pkgdir" AUXDIR=/usr/lib/syslinux install
+}
+md5sums=('a7ca38a0a5786b6efae8fb01a1ae8070'
+ '895722a392f3d798a7cc24bc154656f0')