summaryrefslogtreecommitdiffstats
path: root/abs/extra/tevent
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-10 16:29:16 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-10 16:29:16 (GMT)
commitb97a12870468d65695a17b0060fdbd3ba83cc067 (patch)
treecee5d0a9efe1f1b0c54d68befbf37075e0658cf2 /abs/extra/tevent
parentd14da8dc6a524942b6a7b8585fd53c127ea74efd (diff)
downloadlinhes_pkgbuild-b97a12870468d65695a17b0060fdbd3ba83cc067.zip
linhes_pkgbuild-b97a12870468d65695a17b0060fdbd3ba83cc067.tar.gz
linhes_pkgbuild-b97a12870468d65695a17b0060fdbd3ba83cc067.tar.bz2
tevent: initial inclusion. dep of samba. refs #961
Diffstat (limited to 'abs/extra/tevent')
-rw-r--r--abs/extra/tevent/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/extra/tevent/PKGBUILD b/abs/extra/tevent/PKGBUILD
new file mode 100644
index 0000000..c9dcc03
--- /dev/null
+++ b/abs/extra/tevent/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Christian Hesse <mail@eworm.de>
+# Contributor: Marco A Rojas <marquicus at gmail dot com>
+# Contributor: Ng Oon-Ee <ngoonee.talk@gmail.com>
+# Contributor: Thomas Burdick <thomas.burdick@gmail.com>
+
+pkgname=tevent
+pkgver=0.9.21
+pkgrel=2
+pkgdesc="An event system based on the talloc memory management library"
+arch=('i686' 'x86_64')
+url="https://tevent.samba.org/"
+source=("http://samba.org/ftp/tevent/${pkgname}-${pkgver}.tar.gz")
+license=('GPL3')
+depends=('talloc')
+makedepends=('python2')
+optdepends=('python2: for python bindings')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # change to use python2
+ sed -i -e "s|/usr/bin/env python$|/usr/bin/env python2|" buildtools/bin/waf
+ export PYTHON=/usr/bin/python2
+
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make
+ make DESTDIR=${pkgdir}/ install
+}
+md5sums=('3d5a76c0a1b5f724842d785fd055633f')