summaryrefslogtreecommitdiffstats
path: root/abs/extra/texlive-latexextra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-16 20:49:32 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-16 20:49:32 (GMT)
commit12a99008551cb41387c757eccf095e4cc56a6edd (patch)
treeca4ef693f3ed01e070231fa21f1feb550f98aad7 /abs/extra/texlive-latexextra
parent695cb7ebbb20361cba818eed4e0841c0e0ef5e63 (diff)
downloadlinhes_pkgbuild-12a99008551cb41387c757eccf095e4cc56a6edd.zip
linhes_pkgbuild-12a99008551cb41387c757eccf095e4cc56a6edd.tar.gz
linhes_pkgbuild-12a99008551cb41387c757eccf095e4cc56a6edd.tar.bz2
texlive-latexextra: initial inclusion. dep of doxygen
Diffstat (limited to 'abs/extra/texlive-latexextra')
-rw-r--r--abs/extra/texlive-latexextra/PKGBUILD76
-rw-r--r--abs/extra/texlive-latexextra/texlive-latexextra.maps3
2 files changed, 79 insertions, 0 deletions
diff --git a/abs/extra/texlive-latexextra/PKGBUILD b/abs/extra/texlive-latexextra/PKGBUILD
new file mode 100644
index 0000000..bd9873b
--- /dev/null
+++ b/abs/extra/texlive-latexextra/PKGBUILD
@@ -0,0 +1,76 @@
+# $Id$
+# Maintainer: Firmicus <firmicus āt gmx dōt net>
+# Maintainer: Rémy Oudompheng <remy@archlinux.org>
+
+pkgname=texlive-latexextra
+pkgver=2017.45733
+_revnr=${pkgver#2017.}
+pkgrel=1
+pkgdesc="TeX Live - Large collection of add-on packages for LaTeX"
+license=('GPL')
+arch=(any)
+depends=('texlive-core'
+ 'perl-file-which' # for pdfannotextractor
+ )
+optdepends=(
+ 'texlive-genericextra: to use the calctab package'
+ 'texlive-pictures: to use the package overpic'
+ 'java-environment: to use pdfannotextractor'
+)
+groups=('texlive-most')
+url='http://tug.org/texlive/'
+source=("https://sources.archlinux.org/other/texlive/$pkgname-$pkgver-src.zip"
+ "$pkgname.maps")
+options=('!emptydirs')
+sha256sums=('20360e1a799c237653caa1d66e4a3811b58520421633611c96ff812be93f6c36'
+ 'd53750a03a52472a1c7c5ba5142959ba382a5d69215471691c0b12c3663950ce')
+
+build() {
+ for p in *.tar.xz; do
+ bsdtar -xf $p
+ done
+ rm -rf {tlpkg,doc,source} || true
+}
+
+package() {
+ install -m755 -d "$pkgdir"/var/lib/texmf/arch/installedpkgs
+ sed -i '/^#/d' CONTENTS
+ install -m644 CONTENTS "$pkgdir"/var/lib/texmf/arch/installedpkgs/${pkgname}_${_revnr}.pkgs
+ install -m644 $pkgname.maps "$pkgdir"/var/lib/texmf/arch/installedpkgs/
+ install -m755 -d "$pkgdir"/usr/share
+ wanteddirs=$(for d in *; do test -d $d && [[ $d != texmf* ]] && echo $d; done) || true
+ for dir in $wanteddirs; do
+ find $dir -type d -exec install -d -m755 "$pkgdir"/usr/share/texmf-dist/'{}' \;
+ find $dir -type f -exec install -m644 '{}' "$pkgdir"/usr/share/texmf-dist/'{}' \;
+ done
+ if [[ -d texmf-dist ]]; then
+ find texmf-dist -type d -exec install -d -m755 "$pkgdir"/usr/share/'{}' \;
+ find texmf-dist -type f -exec install -m644 '{}' "$pkgdir"/usr/share/'{}' \;
+ fi
+ if [[ -d "$pkgdir"/usr/share/texmf-dist/scripts ]]; then
+ find "$pkgdir"/usr/share/texmf-dist/scripts -type f -exec chmod a+x '{}' \;
+ fi
+
+ #add symlinks that were in texlive-bin:
+ _linked_scripts="
+authorindex/authorindex
+exceltex/exceltex
+glossaries/makeglossaries
+glossaries/makeglossaries-lite.lua
+makedtx/makedtx.pl
+pax/pdfannotextractor.pl
+perltex/perltex.pl
+splitindex/splitindex.pl
+svn-multi/svn-multi.pl
+vpe/vpe.pl
+yplan/yplan
+"
+ install -m755 -d "$pkgdir"/usr/bin
+ for _script in ${_linked_scripts}; do
+ _scriptbase=$(basename $_script)
+ _scriptbase=${_scriptbase%.*}
+ ln -s /usr/share/texmf-dist/scripts/${_script} ${pkgdir}/usr/bin/${_scriptbase}
+ done
+
+ rm "$pkgdir"/usr/share/texmf-dist/scripts/shipunov/biokey2html.bat
+}
diff --git a/abs/extra/texlive-latexextra/texlive-latexextra.maps b/abs/extra/texlive-latexextra/texlive-latexextra.maps
new file mode 100644
index 0000000..234c9f6
--- /dev/null
+++ b/abs/extra/texlive-latexextra/texlive-latexextra.maps
@@ -0,0 +1,3 @@
+Map epiolmec.map
+Map scanpages.map
+MixedMap esint.map