summaryrefslogtreecommitdiffstats
path: root/abs/extra/texlive-science
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-06 22:07:57 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-06 22:07:57 (GMT)
commit3ac905120a11caea7cc96debebf7616c3372e734 (patch)
tree35918acd283f0d28a44f383c7749042da7622f10 /abs/extra/texlive-science
parentc061bb69d9c411976bd2a0c45df33bf3cb22c07c (diff)
downloadlinhes_pkgbuild-3ac905120a11caea7cc96debebf7616c3372e734.zip
linhes_pkgbuild-3ac905120a11caea7cc96debebf7616c3372e734.tar.gz
linhes_pkgbuild-3ac905120a11caea7cc96debebf7616c3372e734.tar.bz2
texlive-science: dep of dblatex
Diffstat (limited to 'abs/extra/texlive-science')
-rw-r--r--abs/extra/texlive-science/PKGBUILD52
-rw-r--r--abs/extra/texlive-science/texlive-science.fmts1
-rw-r--r--abs/extra/texlive-science/texlive-science.maps3
3 files changed, 56 insertions, 0 deletions
diff --git a/abs/extra/texlive-science/PKGBUILD b/abs/extra/texlive-science/PKGBUILD
new file mode 100644
index 0000000..6db257e
--- /dev/null
+++ b/abs/extra/texlive-science/PKGBUILD
@@ -0,0 +1,52 @@
+# $Id: PKGBUILD$
+# Maintainer: Rémy Oudompheng <remy@archlinux.org>
+
+pkgname=texlive-science
+pkgver=2017.46789
+_revnr=${pkgver#2017.}
+pkgrel=1
+pkgdesc="TeX Live - Typesetting for mathematics, natural and computer sciences"
+license=('GPL')
+arch=(any)
+depends=('texlive-core')
+groups=('texlive-most')
+url='http://tug.org/texlive/'
+source=("https://sources.archlinux.org/other/texlive/$pkgname-$pkgver-src.zip"
+ "$pkgname.maps"
+ "$pkgname.fmts")
+options=('!emptydirs')
+sha256sums=('1f7af4692b44cd23d3ab2732109ee124eef3a93ae4b8552695eb0d9040f08060'
+ '1d9151c9cabc3521b4406731b0147d80e0bf600bdedaf55a1a49b8775165daa8'
+ '1cbd5339f8cfa32214a749a408cf7136fd5acffaffcde6500a337d332c70c5c3')
+
+build() {
+ cd "$srcdir"
+ for p in *.tar.xz; do
+ bsdtar -xf $p
+ done
+ rm -rf {tlpkg,doc,source} || true
+}
+
+package() {
+ cd "$srcdir"
+ install -m755 -d $pkgdir/var/lib/texmf/arch/installedpkgs
+ sed -i '/^#/d' CONTENTS
+ install -m644 CONTENTS $pkgdir/var/lib/texmf/arch/installedpkgs/${pkgname}_${_revnr}.pkgs
+ install -m644 $pkgname.maps $pkgdir/var/lib/texmf/arch/installedpkgs/
+ install -m644 $pkgname.fmts $pkgdir/var/lib/texmf/arch/installedpkgs/
+ install -m755 -d $pkgdir/usr/share
+ wanteddirs=$(for d in *; do test -d $d && [[ $d != texmf* ]] && echo $d; done) || true
+ for dir in $wanteddirs; do
+ find $dir -type d -exec install -d -m755 $pkgdir/usr/share/texmf-dist/'{}' \;
+ find $dir -type f -exec install -m644 '{}' $pkgdir/usr/share/texmf-dist/'{}' \;
+ done
+ if [[ -d texmf-dist ]]; then
+ find texmf-dist -type d -exec install -d -m755 $pkgdir/usr/share/'{}' \;
+ find texmf-dist -type f -exec install -m644 '{}' $pkgdir/usr/share/'{}' \;
+ fi
+ if [[ -d $pkgdir/usr/share/texmf-dist/scripts ]]; then
+ find $pkgdir/usr/share/texmf-dist/scripts -type f -exec chmod a+x '{}' \;
+ fi
+ install -m755 -d $pkgdir/usr/bin
+ ln -s /usr/share/texmf-dist/scripts/ulqda/ulqda.pl $pkgdir/usr/bin/ulqda
+}
diff --git a/abs/extra/texlive-science/texlive-science.fmts b/abs/extra/texlive-science/texlive-science.fmts
new file mode 100644
index 0000000..a11d2f1
--- /dev/null
+++ b/abs/extra/texlive-science/texlive-science.fmts
@@ -0,0 +1 @@
+amstex pdftex - -translate-file=cp227.tcx *amstex.ini
diff --git a/abs/extra/texlive-science/texlive-science.maps b/abs/extra/texlive-science/texlive-science.maps
new file mode 100644
index 0000000..f23a145
--- /dev/null
+++ b/abs/extra/texlive-science/texlive-science.maps
@@ -0,0 +1,3 @@
+Map chemarrow.map
+MixedMap stmaryrd.map
+MixedMap yhmath.map