summaryrefslogtreecommitdiffstats
path: root/abs/extra/unison
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/unison
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/unison')
-rw-r--r--abs/extra/unison/PKGBUILD28
-rw-r--r--abs/extra/unison/ocaml-3.08-extnames.patch14
-rw-r--r--abs/extra/unison/unison.desktop13
-rw-r--r--abs/extra/unison/unison.install32
4 files changed, 87 insertions, 0 deletions
diff --git a/abs/extra/unison/PKGBUILD b/abs/extra/unison/PKGBUILD
new file mode 100644
index 0000000..b1efa5b
--- /dev/null
+++ b/abs/extra/unison/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=unison
+pkgver=2.27.57
+pkgrel=1
+pkgdesc="Unison is a file-synchronization tool"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://www.cis.upenn.edu/~bcpierce/unison"
+depends=('glibc')
+#makedepends=('ocaml' 'lablgtk' 'lablgtk2' 'imagemagick')
+makedepends=('ocaml' )
+source=(http://www.cis.upenn.edu/~bcpierce/unison/download/releases/stable/$pkgname-$pkgver.tar.gz \
+ $pkgname.desktop)
+options=(!makeflags)
+install=unison.install
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ CFLAGS=""
+ make clean
+ make UISTYLE=text DEBUGGING=false THREADS=true || return 1
+ mkdir -p $startdir/pkg/usr/bin
+ install -Dm755 unison $startdir/pkg/usr/bin/unison
+}
+md5sums=('4ba0a3e4bf4b4ad0c063f86391371f78'
+ '2daecba7705455a8e4b769e48b059872')
diff --git a/abs/extra/unison/ocaml-3.08-extnames.patch b/abs/extra/unison/ocaml-3.08-extnames.patch
new file mode 100644
index 0000000..e959be2
--- /dev/null
+++ b/abs/extra/unison/ocaml-3.08-extnames.patch
@@ -0,0 +1,14 @@
+diff -ur unison-2.9.1/ubase/uprintf.ml unison-2.9.1.patched/ubase/uprintf.ml
+--- unison-2.9.1/ubase/uprintf.ml 2002-04-11 07:13:23.000000000 +0200
++++ unison-2.9.1.patched/ubase/uprintf.ml 2004-08-08 14:10:09.784776851 +0200
+@@ -10,8 +10,8 @@
+ (* *)
+ (***********************************************************************)
+
+-external format_int: string -> int -> string = "format_int"
+-external format_float: string -> float -> string = "format_float"
++external format_int: string -> int -> string = "caml_format_int"
++external format_float: string -> float -> string = "caml_format_float"
+
+ let fprintf outchan doafter format =
+ let format = (Obj.magic format : string) in
diff --git a/abs/extra/unison/unison.desktop b/abs/extra/unison/unison.desktop
new file mode 100644
index 0000000..3a7e1d7
--- /dev/null
+++ b/abs/extra/unison/unison.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=unison
+Name[de]=unison
+Comment=File synchronisation tool for X11
+Comment[de]=Datei Abgleicher und Synchronisierer
+TryExec=unison-x11
+Exec=unison-x11
+Terminal=false
+Type=Application
+Categories=GTK;Application;Network;
+Icon=unison.png
+StartupNotify=true
diff --git a/abs/extra/unison/unison.install b/abs/extra/unison/unison.install
new file mode 100644
index 0000000..70e70b0
--- /dev/null
+++ b/abs/extra/unison/unison.install
@@ -0,0 +1,32 @@
+# arg 1: the new package version
+post_install() {
+ echo "NOTE:"
+ echo " For gtk1 frontend please add 'gtk' package."
+ echo " For gtk2 frontend please add 'gtk2' package."
+ echo " Default X11 frontend is set to gtk2. "
+ echo ""
+ echo " If you want to default to gtk1 unison:"
+ echo " 'rm /usr/bin/unison-x11'"
+ echo " 'ln -s /usr/bin/unison-gtk /usr/bin/unison-x11'"
+ echo ""
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*