summaryrefslogtreecommitdiffstats
path: root/abs/extra/unison
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-09-02 00:44:23 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-09-02 00:44:23 (GMT)
commitece417c11a9b2f8d89a29ec07bc63c283e2c1ff0 (patch)
tree58d095e30094ded7c53df482972001a60701fd45 /abs/extra/unison
parent8b08e5b127670b6d5fa7170477754fc3144cb309 (diff)
downloadlinhes_pkgbuild-ece417c11a9b2f8d89a29ec07bc63c283e2c1ff0.zip
linhes_pkgbuild-ece417c11a9b2f8d89a29ec07bc63c283e2c1ff0.tar.gz
linhes_pkgbuild-ece417c11a9b2f8d89a29ec07bc63c283e2c1ff0.tar.bz2
unison: 2.3.52
Diffstat (limited to 'abs/extra/unison')
-rw-r--r--abs/extra/unison/PKGBUILD58
-rw-r--r--abs/extra/unison/unison-ssh-ocaml.patch25
-rw-r--r--abs/extra/unison/unison.install4
3 files changed, 60 insertions, 27 deletions
diff --git a/abs/extra/unison/PKGBUILD b/abs/extra/unison/PKGBUILD
index 6b3dc00..9be4f21 100644
--- a/abs/extra/unison/PKGBUILD
+++ b/abs/extra/unison/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 57697 2009-11-01 15:08:02Z tpowa $
+# $Id: PKGBUILD 161432 2012-06-11 13:29:15Z tpowa $
#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=unison
@@ -9,36 +9,48 @@ arch=(i686 x86_64)
license=('GPL2')
url="http://www.cis.upenn.edu/~bcpierce/unison"
depends=('glibc')
-#makedepends=('ocaml' 'lablgtk' 'lablgtk2' 'imagemagick')
-#makedepends=('ocaml' 'imagemagick')
-makedepends=('ocaml' )
-source=(http://www.cis.upenn.edu/~bcpierce/unison/download/releases/stable/$pkgname-$pkgver.tar.gz \
- $pkgname.desktop)
+makedepends=('ocaml' 'lablgtk2' 'imagemagick')
+optdepends=('gtk2: for gtk2 support')
+#http://www.cis.upenn.edu/~bcpierce/unison/download/releases/unison-2.32.52/unison-2.32.52.tar.gz
+source=(http://www.cis.upenn.edu/~bcpierce/unison/download/releases/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz
+ $pkgname.desktop unison-ssh-ocaml.patch)
options=(!makeflags)
-install=unison.install
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < $srcdir/unison-ssh-ocaml.patch
CFLAGS=""
make clean
- make UISTYLE=text DEBUGGING=false THREADS=true || return 1
- mkdir -p $startdir/pkg/usr/bin
- install -Dm755 unison $startdir/pkg/usr/bin/unison
+ make mkProjectInfo
+ make UISTYLE=text DEBUGGING=false THREADS=true
+ mv unison unison-text
+
# clean the builddir and rebuild with gtk support
-# make clean
-# make UISTYLE=gtk DEBUGGING=false THREADS=true || return 1
-# install -Dm755 unison $startdir/pkg/usr/bin/unison-gtk
+ # broken at the moment!
+ # make clean
+ # make mkProjectInfo
+ # make UISTYLE=gtk DEBUGGING=false THREADS=true
+ # install -Dm755 unison "$pkgdir"/usr/bin/unison-gtk
# clean the builddir and rebuild with gtk2 support
-# make clean
-# make UISTYLE=gtk2 DEBUGGING=false THREADS=true || return 1
-# install -Dm755 unison $startdir/pkg/usr/bin/unison-gtk2
+ make clean
+ make mkProjectInfo
+ make UISTYLE=gtk2 DEBUGGING=false THREADS=true
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 unison-text "$pkgdir"/usr/bin/unison
+ install -Dm755 unison "$pkgdir"/usr/bin/unison-gtk2
# install a .desktop file; create a compliant icon from ico file and install the png
- # install -Dm644 ../$pkgname.desktop $startdir/pkg/usr/share/applications/$pkgname.desktop
- # convert win32rc/U.ico unison.png
- # install -Dm644 ${pkgname}-1.png $startdir/pkg/usr/share/pixmaps/$pkgname.png
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ convert win32rc/U.ico unison.png
+ install -Dm644 ${pkgname}-1.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
# make symlink for .desktop file
- # cd $startdir/pkg//usr/bin
- # ln -s unison-gtk2 unison-x11
+ cd "$pkgdir"/usr/bin
+ ln -s unison-gtk2 unison-x11
+ # make versioned symlink #29827
+ ln -s unison unison-2.40
}
md5sums=('0701f095c1721776a0454b94607eda48'
- '2daecba7705455a8e4b769e48b059872')
+ '2daecba7705455a8e4b769e48b059872'
+ '81a28349471434c75a4206d07ad21eb1')
diff --git a/abs/extra/unison/unison-ssh-ocaml.patch b/abs/extra/unison/unison-ssh-ocaml.patch
new file mode 100644
index 0000000..1b9c66c
--- /dev/null
+++ b/abs/extra/unison/unison-ssh-ocaml.patch
@@ -0,0 +1,25 @@
+Index: src/terminal.ml
+===================================================================
+--- src/terminal.ml (révision 463)
++++ src/terminal.ml (copie de travail)
+@@ -191,7 +191,6 @@
+ exit 127
+ end
+ | childPid ->
+- Unix.close slaveFd;
+ (Some masterFd, childPid)
+ end
+
+Index: src/update.mli
+===================================================================
+--- src/update.mli (révision 463)
++++ src/update.mli (copie de travail)
+@@ -1,7 +1,7 @@
+ (* Unison file synchronizer: src/update.mli *)
+ (* Copyright 1999-2009, Benjamin C. Pierce (see COPYING for details) *)
+
+-module NameMap : Map.S with type key = Name.t
++module NameMap : MyMap.S with type key = Name.t
+
+ type archive =
+ ArchiveDir of Props.t * archive NameMap.t
diff --git a/abs/extra/unison/unison.install b/abs/extra/unison/unison.install
index 70e70b0..a3790ab 100644
--- a/abs/extra/unison/unison.install
+++ b/abs/extra/unison/unison.install
@@ -26,7 +26,3 @@ pre_remove() {
post_remove() {
/bin/true
}
-
-op=$1
-shift
-$op $*