summaryrefslogtreecommitdiffstats
path: root/abs/extra/upower
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
commitf591ead4c8a9b64b0630900aa12c260027a7db6f (patch)
tree091b31cdc3a24c0b9108f0ea718ecaad166cc834 /abs/extra/upower
parent9b35fb3e4f637252b4674a78adf9026faeaa5340 (diff)
downloadlinhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.zip
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.gz
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.bz2
compiled/added programs needed by xbmc: Moved some programs out of community into extra.
libmpeg2 pm-utils afpfs-ng fluidsynth libmodplug libnfs libshairport dbus-c__ doxygen libocnfig libffado libimobiledevice libmicrothttpd sdl_image sdl_mixer smpeg upower usbmuxd vdpau-video
Diffstat (limited to 'abs/extra/upower')
-rw-r--r--abs/extra/upower/0001-Send-resume-signal-when-built-with-systemd-and-using.patch35
-rw-r--r--abs/extra/upower/PKGBUILD31
2 files changed, 56 insertions, 10 deletions
diff --git a/abs/extra/upower/0001-Send-resume-signal-when-built-with-systemd-and-using.patch b/abs/extra/upower/0001-Send-resume-signal-when-built-with-systemd-and-using.patch
new file mode 100644
index 0000000..2694334
--- /dev/null
+++ b/abs/extra/upower/0001-Send-resume-signal-when-built-with-systemd-and-using.patch
@@ -0,0 +1,35 @@
+From a5b3dd887dcd60e981626ae2e15c874311fc4fef Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Sun, 2 Sep 2012 04:36:13 +0200
+Subject: [PATCH] Send resume signal when built with systemd and using
+ pm-utils suspend
+
+This case was apparently overlooked when adding systemd support.
+
+Signed-off-by: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+---
+ src/linux/up-backend.c | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/src/linux/up-backend.c b/src/linux/up-backend.c
+index ddd4472..52b430e 100644
+--- a/src/linux/up-backend.c
++++ b/src/linux/up-backend.c
+@@ -603,10 +603,11 @@ gboolean
+ up_backend_emits_resuming (UpBackend *backend)
+ {
+ #ifdef HAVE_SYSTEMD
+- return TRUE;
+-#else
+- return FALSE;
++ if (sd_booted ())
++ return TRUE;
++ else
+ #endif
++ return FALSE;
+ }
+
+ /**
+--
+1.7.12
+
diff --git a/abs/extra/upower/PKGBUILD b/abs/extra/upower/PKGBUILD
index 370f483..d27d378 100644
--- a/abs/extra/upower/PKGBUILD
+++ b/abs/extra/upower/PKGBUILD
@@ -1,27 +1,38 @@
-# $Id$
+# $Id: PKGBUILD 166524 2012-09-09 15:41:20Z heftig $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=upower
-pkgver=0.9.15
+pkgver=0.9.18
pkgrel=2
pkgdesc="Abstraction for enumerating power devices, listening to device events and querying history and statistics"
arch=('i686' 'x86_64')
url="http://upower.freedesktop.org"
license=('GPL')
-depends=('udev' 'libusb' 'polkit' 'pm-utils' 'dbus-glib' 'libimobiledevice')
-makedepends=('intltool' 'docbook-xsl' 'gobject-introspection')
+depends=('systemd-tools' 'libsystemd' 'libusb' 'polkit' 'pm-utils' 'dbus-glib' 'libimobiledevice')
+makedepends=('intltool' 'docbook-xsl' 'gobject-introspection' 'systemd')
options=('!libtool')
-source=($url/releases/$pkgname-$pkgver.tar.xz)
-sha256sums=('d5941480f32dcee47401b3f650485c71f70e7eb0d92537bf4b62410248a6238c')
+source=($url/releases/$pkgname-$pkgver.tar.xz
+ 0001-Send-resume-signal-when-built-with-systemd-and-using.patch)
build() {
- cd "$srcdir/$pkgname-$pkgver"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/upower --disable-static
+ cd "$pkgname-$pkgver"
+
+ # put udev files in /usr/lib
+ sed -i "/slashlibdir=/s#/lib#/usr/lib#" configure
+
+ # https://bugs.freedesktop.org/show_bug.cgi?id=54371
+ patch -Np1 -i ../0001-Send-resume-signal-when-built-with-systemd-and-using.patch
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/$pkgname \
+ --disable-static
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
+md5sums=('bfaaa1e7f8479fca5594406b3c36dff9'
+ '188afea4919dc324b2efbae35d9d216a')