summaryrefslogtreecommitdiffstats
path: root/abs/extra/vdpau-video
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-01-13 22:23:09 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-01-13 22:23:09 (GMT)
commit0bcae6dfc24e333236543070f5b8673d37c5abee (patch)
treee00b1e0c6962e2c2b234b6a5272156fe6d941da2 /abs/extra/vdpau-video
parenta0338a8186759a514731d35f0fe08c68530feaaf (diff)
downloadlinhes_pkgbuild-0bcae6dfc24e333236543070f5b8673d37c5abee.zip
linhes_pkgbuild-0bcae6dfc24e333236543070f5b8673d37c5abee.tar.gz
linhes_pkgbuild-0bcae6dfc24e333236543070f5b8673d37c5abee.tar.bz2
vdpau-video: initial commit. Driver/Backend for VA API
Diffstat (limited to 'abs/extra/vdpau-video')
-rw-r--r--abs/extra/vdpau-video/PKGBUILD26
-rw-r--r--abs/extra/vdpau-video/enable-glx.patch12
2 files changed, 38 insertions, 0 deletions
diff --git a/abs/extra/vdpau-video/PKGBUILD b/abs/extra/vdpau-video/PKGBUILD
new file mode 100644
index 0000000..d98b7c8
--- /dev/null
+++ b/abs/extra/vdpau-video/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 94611 2010-10-08 19:13:12Z ibiru $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+pkgname=vdpau-video
+pkgver=0.7.3.pre4
+pkgrel=1
+pkgdesc="VDPAU backend for VA API"
+arch=('i686' 'x86_64')
+url="http://www.splitted-desktop.com/~gbeauchesne/vdpau-video/"
+license=('GPL')
+depends=('libva' 'libvdpau')
+makedepends=('mesa')
+options=('!libtool')
+source=(http://www.splitted-desktop.com/~gbeauchesne/vdpau-video/${pkgname}-${pkgver}.tar.gz)
+ #enable-glx.patch)
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+# patch -Np1 -i $srcdir/enable-glx.patch
+ autoreconf -fi
+ ./configure --prefix=/usr --enable-glx
+ make
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('704421ffd5b2ba33b1e1260fb7af9d4a')
diff --git a/abs/extra/vdpau-video/enable-glx.patch b/abs/extra/vdpau-video/enable-glx.patch
new file mode 100644
index 0000000..79263d2
--- /dev/null
+++ b/abs/extra/vdpau-video/enable-glx.patch
@@ -0,0 +1,12 @@
+diff -Nur vdpau-video-0.7.2.orig/configure.ac vdpau-video-0.7.2/configure.ac
+--- vdpau-video-0.7.2.orig/configure.ac 2010-10-08 00:09:53.000000000 -0700
++++ vdpau-video-0.7.2/configure.ac 2010-10-08 11:34:00.536686684 -0700
+@@ -203,7 +203,7 @@
+ # error "VA-API version >= 0.30.0-sds$LIBVA_GLX_SDS_VERSION_0_30 is required"
+ # endif
+ #elif VA_MAJOR_VERSION == 0 && VA_MINOR_VERSION == 31
+- # if !defined(VA_SDS_VERSION) || (VA_SDS_VERSION < $LIBVA_GLX_SDS_VERSION_0_31)
++ # if !VA_CHECK_VERSION(0,31,0)
+ # error "VA-API version >= 0.31.0-sds$LIBVA_GLX_SDS_VERSION_0_31 is required"
+ # endif
+ #else