summaryrefslogtreecommitdiffstats
path: root/abs/extra/vte3
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-21 18:07:51 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-21 18:07:51 (GMT)
commitd29e321ff1656298347c228d3badb7d2bb010399 (patch)
tree9a4e1b3ff9f0b5c245fcad30010b31b170f8dfdf /abs/extra/vte3
parentdf4680dd1b0f6080991747ea583ab61b272835bf (diff)
downloadlinhes_pkgbuild-d29e321ff1656298347c228d3badb7d2bb010399.zip
linhes_pkgbuild-d29e321ff1656298347c228d3badb7d2bb010399.tar.gz
linhes_pkgbuild-d29e321ff1656298347c228d3badb7d2bb010399.tar.bz2
vte3: update to 0.42.1
Diffstat (limited to 'abs/extra/vte3')
-rw-r--r--abs/extra/vte3/PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/abs/extra/vte3/PKGBUILD b/abs/extra/vte3/PKGBUILD
index 1019be3..e7797d0 100644
--- a/abs/extra/vte3/PKGBUILD
+++ b/abs/extra/vte3/PKGBUILD
@@ -1,25 +1,26 @@
-# $Id: PKGBUILD 160601 2012-06-02 20:33:51Z ibiru $
+# $Id$
# Maintainer: Ionut Biru <ibiru@archlinux.org>
pkgbase=vte3
pkgname=(vte3 vte-common)
-pkgver=0.32.2
-pkgrel=1
+pkgver=0.42.1
+pkgrel=2
pkgdesc="Virtual Terminal Emulator widget for use with GTK3"
arch=('i686' 'x86_64')
license=('LGPL')
-options=('!libtool' '!emptydirs')
-makedepends=('intltool' 'gobject-introspection' 'gtk3')
+options=('!emptydirs')
+makedepends=('intltool' 'gobject-introspection' 'gtk3' 'vala' 'glade')
url="http://www.gnome.org"
-source=(http://ftp.gnome.org/pub/GNOME/sources/vte/${pkgver%.*}/vte-$pkgver.tar.xz)
-sha256sums=('d69ec071f7a380d8b8b981b35a9a0b891f37c4b6b17d08407f66ac98d619486a')
+source=(http://download.gnome.org/sources/vte/${pkgver::4}/vte-$pkgver.tar.xz)
+sha256sums=('9e00e2e9e94f4202b979c871f407a8815890bc0f4a8448a08534f76ab0fc9d34')
build() {
cd "vte-$pkgver"
./configure --prefix=/usr --sysconfdir=/etc \
--libexecdir=/usr/lib/vte \
--localstatedir=/var --disable-static \
- --enable-introspection
+ --enable-introspection --enable-glade-catalogue
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
make
}
@@ -28,12 +29,12 @@ package_vte3(){
cd "vte-$pkgver"
make DESTDIR="$pkgdir" install
- rm "$pkgdir"/usr/lib/vte/gnome-pty-helper
+ rm "$pkgdir"/etc/profile.d/vte.sh
}
package_vte-common() {
pkgdesc="Common files used by vte and vte3"
cd "vte-$pkgver"
- make -C gnome-pty-helper DESTDIR="$pkgdir" install
+ install -Dm644 src/vte.sh "$pkgdir"/etc/profile.d/vte.sh
}