summaryrefslogtreecommitdiffstats
path: root/abs/extra/wayland-protocols/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-04-18 17:35:34 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-04-18 17:35:34 (GMT)
commita3e950053d847e719d489c13064b6c165425385c (patch)
treefccd4ec9f53e519563c0cfd25833cd8c3caaaa20 /abs/extra/wayland-protocols/PKGBUILD
parentbd44be589a2626bd26a7f31b23c2358fb74e5c95 (diff)
parent0a8de86de9f21f7877075ac2800254239ae84a81 (diff)
downloadlinhes_pkgbuild-a3e950053d847e719d489c13064b6c165425385c.zip
linhes_pkgbuild-a3e950053d847e719d489c13064b6c165425385c.tar.gz
linhes_pkgbuild-a3e950053d847e719d489c13064b6c165425385c.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/wayland-protocols/PKGBUILD')
-rw-r--r--abs/extra/wayland-protocols/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/wayland-protocols/PKGBUILD b/abs/extra/wayland-protocols/PKGBUILD
new file mode 100644
index 0000000..15e4059
--- /dev/null
+++ b/abs/extra/wayland-protocols/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Sébastien Luttringer <seblu@seblu.net>
+
+pkgname=wayland-protocols
+pkgver=1.7
+pkgrel=1
+pkgdesc='Specifications of extended Wayland protocols'
+arch=('any')
+url='https://wayland.freedesktop.org/'
+license=('MIT')
+makedepends=('wayland')
+validpgpkeys=('8307C0A224BABDA1BABD0EB9A6EEEC9E0136164A') # Jonas Ådahl
+source=("https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"{,.sig})
+sha1sums=('c4726694daf5feb1437f5f4f13c3b2a9b94b8118'
+ 'SKIP')
+
+build() {
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+ install -Dm 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: