summaryrefslogtreecommitdiffstats
path: root/abs/extra/wayland-protocols
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-03-28 18:59:19 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-03-28 18:59:19 (GMT)
commit35fde23955ca190bd287fd0750dd866a1d37be69 (patch)
tree5693d6222042ce0f05a054a06a189a7cb9e9a2ff /abs/extra/wayland-protocols
parentf2e5941f08994c68060b419edb6b68d78dcd9614 (diff)
downloadlinhes_pkgbuild-35fde23955ca190bd287fd0750dd866a1d37be69.zip
linhes_pkgbuild-35fde23955ca190bd287fd0750dd866a1d37be69.tar.gz
linhes_pkgbuild-35fde23955ca190bd287fd0750dd866a1d37be69.tar.bz2
wayland-protocols: update to 1.7
Diffstat (limited to 'abs/extra/wayland-protocols')
-rw-r--r--abs/extra/wayland-protocols/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/wayland-protocols/PKGBUILD b/abs/extra/wayland-protocols/PKGBUILD
new file mode 100644
index 0000000..15e4059
--- /dev/null
+++ b/abs/extra/wayland-protocols/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Sébastien Luttringer <seblu@seblu.net>
+
+pkgname=wayland-protocols
+pkgver=1.7
+pkgrel=1
+pkgdesc='Specifications of extended Wayland protocols'
+arch=('any')
+url='https://wayland.freedesktop.org/'
+license=('MIT')
+makedepends=('wayland')
+validpgpkeys=('8307C0A224BABDA1BABD0EB9A6EEEC9E0136164A') # Jonas Ådahl
+source=("https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"{,.sig})
+sha1sums=('c4726694daf5feb1437f5f4f13c3b2a9b94b8118'
+ 'SKIP')
+
+build() {
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+ install -Dm 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: