summaryrefslogtreecommitdiffstats
path: root/abs/extra/web-on-linhes
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-01-09 15:48:34 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-01-09 15:48:34 (GMT)
commitd0045640af11043af151ae0768002c5382259537 (patch)
tree957cbd656df81a107d98f8ba80651f6589964e2c /abs/extra/web-on-linhes
parent8d3d5fc17ddda68793375eb9910213eee8f1bf67 (diff)
downloadlinhes_pkgbuild-d0045640af11043af151ae0768002c5382259537.zip
linhes_pkgbuild-d0045640af11043af151ae0768002c5382259537.tar.gz
linhes_pkgbuild-d0045640af11043af151ae0768002c5382259537.tar.bz2
web-on-linhes: add espn.com
add /home/mythtv/.wol-custom-cmds.sh to run cmds to control a web page
Diffstat (limited to 'abs/extra/web-on-linhes')
-rw-r--r--abs/extra/web-on-linhes/PKGBUILD16
-rw-r--r--abs/extra/web-on-linhes/web-on-linhes.sh5
-rwxr-xr-xabs/extra/web-on-linhes/web-on-linhes_is.conf10
-rwxr-xr-xabs/extra/web-on-linhes/wol-custom-cmds.sh13
4 files changed, 36 insertions, 8 deletions
diff --git a/abs/extra/web-on-linhes/PKGBUILD b/abs/extra/web-on-linhes/PKGBUILD
index 0a28e81..0746933 100644
--- a/abs/extra/web-on-linhes/PKGBUILD
+++ b/abs/extra/web-on-linhes/PKGBUILD
@@ -2,22 +2,26 @@
# Maintainer: Cecil Watson<knoppmyth@gmail.com>
pkgname=web-on-linhes
-pkgver=1.3
-pkgrel=3
+pkgver=1.4
+pkgrel=1
pkgdesc="Added multiple websites with 10' UIs to Play Online Streams."
arch=('i686' 'x86_64')
license=('GPL2')
url="http://www.linhes.org/"
depends=('google-chrome')
install=web-on-linhes.install
-source=('web-on-linhes.sh' 'web-on-linhes_is.conf')
+source=('web-on-linhes.sh' 'web-on-linhes_is.conf' 'wol-custom-cmds.sh')
+backup=('home/mythtv/.wol-custom-cmds.sh')
package() {
cd ${srcdir}
install -d ${pkgdir}/usr/LH/bin
- install -D -m755 *.sh ${pkgdir}/usr/LH/bin
+ install -D -m755 web-on-linhes.sh ${pkgdir}/usr/LH/bin
#add in file for gen_is.xml
install -D -m0744 ${srcdir}/web-on-linhes_is.conf ${pkgdir}/etc/gen_is_xml.d/web-on-linhes_is.conf
+ #add wol-custom-cmds file
+ install -D -o1000 -g1000 -m755 ${srcdir}/wol-custom-cmds.sh ${pkgdir}/home/mythtv/.wol-custom-cmds.sh
}
-md5sums=('3691faa7118ac1251c959d3bcfcba85f'
- '61cafa7e7a11b1387202b6ef908105a7')
+md5sums=('f37e208b713ee5b5b3ac54b63597f39f'
+ '7eb75860715a84e7e75b804e159adf35'
+ '9f59fabdf944a7381919d4c8407ac21c')
diff --git a/abs/extra/web-on-linhes/web-on-linhes.sh b/abs/extra/web-on-linhes/web-on-linhes.sh
index 48414e9..3c458dd 100644
--- a/abs/extra/web-on-linhes/web-on-linhes.sh
+++ b/abs/extra/web-on-linhes/web-on-linhes.sh
@@ -7,7 +7,10 @@ irxPID=$!
stop_xss.sh &
xssPID=$!
#Launches chrome in full screen
-(sleep 1; wmctrl -r "Google Chrome" -b add,fullscreen) &
+(sleep 3; wmctrl -r "Google Chrome" -b add,fullscreen) &
+#Launches file to run any custom cmds
+(sleep 4; /home/mythtv/.wol-custom-cmds.sh $@) &
+#Launch chrome
google-chrome --no-first-run --kiosk $@
#Once done, stops irxevent and stop_xss.sh
kill $irxPID
diff --git a/abs/extra/web-on-linhes/web-on-linhes_is.conf b/abs/extra/web-on-linhes/web-on-linhes_is.conf
index 982bd8e..2913ec0 100755
--- a/abs/extra/web-on-linhes/web-on-linhes_is.conf
+++ b/abs/extra/web-on-linhes/web-on-linhes_is.conf
@@ -1,6 +1,14 @@
<!--#WebOnTV-->
<button>
<type>STREAM</type>
+ <text>ESPN</text>
+ <action>EXEC /usr/LH/bin/web-on-linhes.sh http://www.espn.com/watch</action>
+ </button>
+ <!--#WebOnTV-->
+
+ <!--#WebOnTV-->
+ <button>
+ <type>STREAM</type>
<text>NetFlix</text>
<action>EXEC /usr/LH/bin/web-on-linhes.sh http://netflix.com/WiHome</action>
</button>
@@ -17,7 +25,7 @@
<!--#WebOnTV-->
<button>
<type>STREAM</type>
- <text>TuneIn </text>
+ <text>TuneIn</text>
<action>EXEC /usr/LH/bin/web-on-linhes.sh http://tv.tunein.com/</action>
</button>
<!--#WebOnTV-->
diff --git a/abs/extra/web-on-linhes/wol-custom-cmds.sh b/abs/extra/web-on-linhes/wol-custom-cmds.sh
new file mode 100755
index 0000000..2386378
--- /dev/null
+++ b/abs/extra/web-on-linhes/wol-custom-cmds.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+# Launch commands to control a web page
+# $@ contains the website that was opened
+# The espn example moves the mouse and clicks to make the player active
+# Then the f key is pressed to make the video fullscreen
+
+if [[ $@ == *"espn.com"* ]];
+then
+ sleep 7
+ xdotool mousemove 722 531 click 1 click 1
+ xdotool key f
+fi