summaryrefslogtreecommitdiffstats
path: root/abs/extra/webkitgtk/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-12-15 20:42:09 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-12-15 20:42:09 (GMT)
commitf663bd44b2b9389a70c568329873b3584308344c (patch)
treeadf253fe2627852116f935bcc31d4daef94713b1 /abs/extra/webkitgtk/PKGBUILD
parent81a3a03ddc78443dd645b95200f9f1cf307f525a (diff)
downloadlinhes_pkgbuild-f663bd44b2b9389a70c568329873b3584308344c.zip
linhes_pkgbuild-f663bd44b2b9389a70c568329873b3584308344c.tar.gz
linhes_pkgbuild-f663bd44b2b9389a70c568329873b3584308344c.tar.bz2
libtorrent-rasterbar: update to 0.16.17
Diffstat (limited to 'abs/extra/webkitgtk/PKGBUILD')
-rw-r--r--abs/extra/webkitgtk/PKGBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/abs/extra/webkitgtk/PKGBUILD b/abs/extra/webkitgtk/PKGBUILD
new file mode 100644
index 0000000..93a98cd
--- /dev/null
+++ b/abs/extra/webkitgtk/PKGBUILD
@@ -0,0 +1,61 @@
+# $Id: PKGBUILD 157142 2012-04-24 22:33:15Z ibiru $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgbase=libwebkit
+pkgname=(libwebkit libwebkit3)
+pkgver=1.8.1
+pkgrel=1
+pkgdesc="An opensource web content engine"
+arch=('i686' 'x86_64')
+url="http://webkitgtk.org/"
+license=('custom')
+depends=('libxt' 'libxslt' 'sqlite' 'icu' 'gstreamer0.10-base' 'libsoup' 'enchant' 'libgl'
+ 'geoclue')
+makedepends=('gperf' 'gobject-introspection' 'python2' 'gtk2' 'gtk3' 'mesa')
+options=('!libtool' '!emptydirs')
+source=(http://webkitgtk.org/releases/webkit-$pkgver.tar.xz webkit.patch)
+
+build() {
+ cd "$srcdir/webkit-$pkgver"
+ patch -Np1 < ../webkit.patch
+ mkdir build-gtk{2,3}
+
+ # clear makeflags: race during introspection.
+ # WebKit*.gir should be created before WebKit*.typelib, but isn't
+ MAKEFLAGS=
+
+ ( cd build-gtk2 && _build --with-gtk=2.0 )
+ ( cd build-gtk3 && _build --with-gtk=3.0 )
+}
+
+_build() {
+ PYTHON=/usr/bin/python2 ../configure --prefix=/usr \
+ --enable-introspection \
+ --with-font-backend=freetype \
+ --with-unicode-backend=icu \
+ --enable-spellcheck "$@"
+ make all stamp-po
+}
+
+package_libwebkit() {
+ pkgdesc+=" (for GTK2)"
+ depends+=(gtk2)
+
+ cd "$srcdir/webkit-$pkgver/build-gtk2"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../Source/WebKit/LICENSE "$pkgdir/usr/share/licenses/libwebkit/LICENSE"
+}
+
+package_libwebkit3() {
+ pkgdesc+=" (for GTK3)"
+ depends+=(gtk3)
+
+ cd "$srcdir/webkit-$pkgver/build-gtk3"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../Source/WebKit/LICENSE "$pkgdir/usr/share/licenses/libwebkit3/LICENSE"
+}
+
+
+
+md5sums=('f2f01b1fdc7262a2eede81ebed0970b2'
+ 'dab90271e918f48ed215648521d5a8a0')