summaryrefslogtreecommitdiffstats
path: root/abs/extra/wxgtk
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/wxgtk
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/wxgtk')
-rw-r--r--abs/extra/wxgtk/ChangeLog18
-rw-r--r--abs/extra/wxgtk/PKGBUILD32
-rw-r--r--abs/extra/wxgtk/__changelog1
3 files changed, 51 insertions, 0 deletions
diff --git a/abs/extra/wxgtk/ChangeLog b/abs/extra/wxgtk/ChangeLog
new file mode 100644
index 0000000..03e9f96
--- /dev/null
+++ b/abs/extra/wxgtk/ChangeLog
@@ -0,0 +1,18 @@
+2009-03-06 Eric Belanger <eric@archlinux.org>
+
+ * wxgtk 2.8.9.2-1
+ * Upstream update
+ * Switched to wxpython source tarball
+
+2008-09-26 Eric Belanger <eric@archlinux.org>
+
+ * wxgtk 2.8.9-1
+ * Upstream update
+ * Added mediactrl support (close FS#11220)
+
+2008-07-05 Eric Belanger <eric@archlinux.org>
+
+ * wxgtk 2.8.8-1
+ * Upstream update
+ * Enabled gnomeprint - needed for wxpython to build
+ * Added ChangeLog
diff --git a/abs/extra/wxgtk/PKGBUILD b/abs/extra/wxgtk/PKGBUILD
new file mode 100644
index 0000000..d98ac43
--- /dev/null
+++ b/abs/extra/wxgtk/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 29177 2009-03-06 09:02:47Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Original Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# New Version - Contributor: Bob Finch <w9ya@arrl.net>
+# with help from J. Santiago Hirschfeld <jsantiagoh@yahoo.com.ar> aka Angelus
+
+pkgname=wxgtk
+pkgver=2.8.9.2
+pkgrel=2
+pkgdesc="wxGTK - GTK+ implementation of wxWidgets API for GUI"
+arch=('i686' 'x86_64')
+url="http://wxwidgets.org"
+license=('custom:wxWindows')
+depends=('gtk2>=2.12.11' 'mesa' 'libjpeg')
+#makedepends=('libgnomeprintui')
+#source=(http://downloads.sourceforge.net/wxwindows/wxGTK-${pkgver}.tar.bz2)
+source=(http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2)
+md5sums=('e3d89746af98b9279e4ff39a57f6dc63')
+sha1sums=('a0d58d8b9606d04a35b9853da15eb7dfb08d5637')
+
+build() {
+ cd ${srcdir}/wxPython-src-${pkgver}
+ ./configure --prefix=/usr --libdir=/usr/lib --with-gtk=2 --with-opengl --enable-unicode \
+ --enable-graphics_ctx --without-gnomeprint --disable-optimize || return 1
+ make || return 1
+ make -C locale allmo || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ cd contrib/src
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+ install -D -m644 ../../docs/licence.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+}
diff --git a/abs/extra/wxgtk/__changelog b/abs/extra/wxgtk/__changelog
new file mode 100644
index 0000000..3bf8bed
--- /dev/null
+++ b/abs/extra/wxgtk/__changelog
@@ -0,0 +1 @@
+remove libgnomeprint