summaryrefslogtreecommitdiffstats
path: root/abs/extra/xbmc/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2012-04-10 07:35:36 (GMT)
committerCecil <knoppmyth@gmail.com>2012-04-10 07:35:36 (GMT)
commitbc096e5878149993d838bb57b957a6e0734563a7 (patch)
tree32c60c9104957470615fa3ef649bdc2bc316314a /abs/extra/xbmc/PKGBUILD
parentd0525a9f1df778729f96591e72e0363d26ff47ef (diff)
downloadlinhes_pkgbuild-bc096e5878149993d838bb57b957a6e0734563a7.zip
linhes_pkgbuild-bc096e5878149993d838bb57b957a6e0734563a7.tar.gz
linhes_pkgbuild-bc096e5878149993d838bb57b957a6e0734563a7.tar.bz2
xbmc:Bumped to 11.0-4. Added xbmc.sh which stops XScreensaver. Modified menu entry to call xbmc.sh.
Diffstat (limited to 'abs/extra/xbmc/PKGBUILD')
-rw-r--r--abs/extra/xbmc/PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/abs/extra/xbmc/PKGBUILD b/abs/extra/xbmc/PKGBUILD
index def2927..49166cc 100644
--- a/abs/extra/xbmc/PKGBUILD
+++ b/abs/extra/xbmc/PKGBUILD
@@ -9,12 +9,12 @@ _prefix=/usr
pkgname=xbmc
pkgver=11.0
-pkgrel=3
+pkgrel=4
pkgdesc="A software media player and entertainment hub for digital media"
arch=('i686' 'x86_64')
url="http://xbmc.org"
license=('GPL' 'custom')
-depends=('hicolor-icon-theme' 'fribidi' 'lzo2' 'smbclient' 'libtiff' 'libva' 'libpng' 'libcdio' 'yajl' 'libmysqlclient' 'libjpeg' 'libsamplerate' 'glew' 'libssh' 'libmicrohttpd' 'libxrandr' 'sdl_mixer' 'sdl_image' 'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'mesa-demos' 'xorg-xdpyinfo' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez')
+depends=('hicolor-icon-theme' 'fribidi' 'lzo2' 'smbclient' 'libtiff' 'libva' 'libpng' 'libcdio' 'yajl' 'libmysqlclient' 'libjpeg' 'libsamplerate' 'glew' 'libssh' 'libmicrohttpd' 'libxrandr' 'sdl_mixer' 'sdl_image' 'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'mesa-demos' 'xorg-xdpyinfo' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez' 'linhes-scripts>=7-31')
makedepends=('boost' 'cmake' 'gperf' 'nasm' 'libxinerama' 'zip' 'vdpau-video' 'libcec' 'udisks' 'upower' 'bluez')
optdepends=(
'libcec: support for Pulse-Eight USB-CEC adapter'
@@ -26,7 +26,7 @@ optdepends=(
'unrar: access compressed files without unpacking them'
)
install="${pkgname}.install"
-source=("http://mirrors.xbmc.org/releases/source/xbmc-$pkgver.tar.gz" xbmc11.patch)
+source=("http://mirrors.xbmc.org/releases/source/xbmc-$pkgver.tar.gz" 'xbmc11.patch' 'xbmc.sh')
build() {
cd "${srcdir}/xbmc-$pkgver"
@@ -98,7 +98,11 @@ package() {
for licensef in LICENSE.GPL copying.txt; do
mv "${pkgdir}${_prefix}/share/doc/xbmc/${licensef}" "${pkgdir}${_prefix}/share/licenses/${pkgname}"
done
+
+ mkdir -p ${pkgdir}/usr/LH/bin
+ install -D -m 0755 ${srcdir}/xbmc.sh ${pkgdir}/usr/LH/bin
}
# vim:set ts=2 sw=2 et:
md5sums=('9e8a26ee25173c7268abea7f1d82d428'
- '5aa2e21a1f9fea60a2e5bb345e5aefd0')
+ '5aa2e21a1f9fea60a2e5bb345e5aefd0'
+ 'f30d9a68daedd28482813ee40134f243')