summaryrefslogtreecommitdiffstats
path: root/abs/extra/xbmc/xbmc.install
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2010-12-28 02:58:41 (GMT)
committerCecil <knoppmyth@gmail.com>2010-12-28 02:58:41 (GMT)
commit72badd6113d9ee29f6705e44f71fb7701d2375b4 (patch)
treeb60881975517b9849d1ced7ff212c6be5a626ce4 /abs/extra/xbmc/xbmc.install
parent82638e7cf91b4fc5035d4c223345c1a51416c8f8 (diff)
downloadlinhes_pkgbuild-72badd6113d9ee29f6705e44f71fb7701d2375b4.zip
linhes_pkgbuild-72badd6113d9ee29f6705e44f71fb7701d2375b4.tar.gz
linhes_pkgbuild-72badd6113d9ee29f6705e44f71fb7701d2375b4.tar.bz2
xbmc:Updated to XBMC 10.0.
Diffstat (limited to 'abs/extra/xbmc/xbmc.install')
-rw-r--r--abs/extra/xbmc/xbmc.install29
1 files changed, 24 insertions, 5 deletions
diff --git a/abs/extra/xbmc/xbmc.install b/abs/extra/xbmc/xbmc.install
index eb4e9d4..a59d22b 100644
--- a/abs/extra/xbmc/xbmc.install
+++ b/abs/extra/xbmc/xbmc.install
@@ -1,7 +1,26 @@
post_install() {
- echo ">> If XBMC won't start, but just segfaults, double check your X.Org config"
- echo ">> so that your display depth is at least 24-bit. Eg: change "
- echo ">> \"DefaultDepth 16\" under the \"Screen\" section so it says 24 instead"
- echo ">> of 16."
- /bin/true
+ echo ">> If XBMC won't start, but just segfaults, double check your X.Org config."
+ echo ">> The display depth has to be at least 24-bit, ie"
+ echo ">> set \"DefaultDepth 24\" under the \"Screen\" section of your xorg.conf file."
+ echo ">> If you have problems or suggestions for this PKGBUILD, have a look at its"
+ echo ">> dedicated forum thread: http://bbs.archlinux.org/viewtopic.php?pid=559107"
+ echo ">> or the wiki: http://xbmc.org/wiki/?title=XBMC_on_Arch_Linux_(Unofficial)."
+ echo ">> Note that this is a development version of XBMC."
+ echo ">> If you encounter problems with XBMC don't forget to consult the official"
+ echo ">> xbmc forums found here: http://forum.xbmc.org "
+ echo ">> and report bugs to the xbmc bugtracker found here: http://trac.xbmc.org."
+ echo
+
+ [[ $(type -p gtk-update-icon-cache) ]] && /usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
+ [[ $(type -p update-desktop-database) ]] && /usr/bin/update-desktop-database -q usr/share/applications
+}
+
+post_upgrade() {
+ [[ $(type -p gtk-update-icon-cache) ]] && /usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
+ [[ $(type -p update-desktop-database) ]] && /usr/bin/update-desktop-database -q usr/share/applications
+}
+
+post_remove() {
+ [[ $(type -p gtk-update-icon-cache) ]] && /usr/bin/gtk-update-icon-cache -qtf usr/share/icons/hicolor
+ [[ $(type -p update-desktop-database) ]] && /usr/bin/update-desktop-database -q usr/share/applications
}