summaryrefslogtreecommitdiffstats
path: root/abs/extra/xcb-util-keysyms/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <mihanson@linhes.org>2012-01-26 03:55:34 (GMT)
committerMichael Hanson <mihanson@linhes.org>2012-01-26 03:55:34 (GMT)
commit0a67bbb2581429c090a360e63ae0eb49cac528ae (patch)
tree9b69a3c93cb3c1850d7e7eeeeaabc434c7e5f12e /abs/extra/xcb-util-keysyms/PKGBUILD
parent313a94f68fd59f80e6aa04235c4ae4b602793a04 (diff)
downloadlinhes_pkgbuild-0a67bbb2581429c090a360e63ae0eb49cac528ae.zip
linhes_pkgbuild-0a67bbb2581429c090a360e63ae0eb49cac528ae.tar.gz
linhes_pkgbuild-0a67bbb2581429c090a360e63ae0eb49cac528ae.tar.bz2
xcb-util-keysyms: initial commit. dep of vlc-nogui
Diffstat (limited to 'abs/extra/xcb-util-keysyms/PKGBUILD')
-rw-r--r--abs/extra/xcb-util-keysyms/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/extra/xcb-util-keysyms/PKGBUILD b/abs/extra/xcb-util-keysyms/PKGBUILD
new file mode 100644
index 0000000..efec398
--- /dev/null
+++ b/abs/extra/xcb-util-keysyms/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=xcb-util-keysyms
+pkgver=0.3.8
+pkgrel=1
+pkgdesc="Utility libraries for XC Binding - Standard X key constants and conversion to/from keycodes"
+arch=('i686' 'x86_64')
+url="http://xcb.freedesktop.org"
+license=('custom')
+depends=('libxcb>=1.7')
+makedepends=('xorg-util-macros')
+options=('!libtool')
+source=("http://xcb.freedesktop.org/dist/${pkgname}-${pkgver}.tar.bz2"
+ 'LICENSE')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m644 "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+md5sums=('c75bb20e709093580a67eaf263251b50'
+ '2672c2e72dedb40f773e989dd622f298')