summaryrefslogtreecommitdiffstats
path: root/abs/extra/xdg-utils/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 20:52:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 20:52:45 (GMT)
commit46e08095675d8e2185bf65fa116742cb5a4cda2e (patch)
tree764d6a8c15d83b99b19c6b1990f9e1b62d914d59 /abs/extra/xdg-utils/PKGBUILD
parent4db5cee76c1bcb1cc400b95ae16f5059a8d71561 (diff)
downloadlinhes_pkgbuild-46e08095675d8e2185bf65fa116742cb5a4cda2e.zip
linhes_pkgbuild-46e08095675d8e2185bf65fa116742cb5a4cda2e.tar.gz
linhes_pkgbuild-46e08095675d8e2185bf65fa116742cb5a4cda2e.tar.bz2
xdg-utils 1.1.0
Diffstat (limited to 'abs/extra/xdg-utils/PKGBUILD')
-rw-r--r--abs/extra/xdg-utils/PKGBUILD41
1 files changed, 29 insertions, 12 deletions
diff --git a/abs/extra/xdg-utils/PKGBUILD b/abs/extra/xdg-utils/PKGBUILD
index c707346..94e715e 100644
--- a/abs/extra/xdg-utils/PKGBUILD
+++ b/abs/extra/xdg-utils/PKGBUILD
@@ -1,19 +1,36 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 160047 2012-05-28 14:14:28Z andyrtr $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=xdg-utils
-pkgver=1.0.2
-pkgrel=1
-pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks."
-arch=(i686 x86_64)
+pkgver=1.1.0
+_gitdate=20120520
+pkgrel=2.${_gitdate}
+pkgdesc="Command line tools that assist applications with a variety of desktop integration tasks"
+arch=('any')
url="http://portland.freedesktop.org/"
-license=(MIT)
-source=(http://portland.freedesktop.org/download/$pkgname-$pkgver.tgz)
-md5sums=('348a5b91dc66426505022c74a64b2940')
+license=('MIT')
+depends=('sh' 'xorg-xset') # xset needed inside xdg-screensaver
+makedepends=('docbook-xsl' 'lynx' 'xmlto')
+optdepends=('kdebase-runtime: for KDE support in xdg-open'
+ 'libgnome: for GNOME support in xdg-open'
+ 'exo: for Xfce support in xdg-open'
+ 'xorg-xprop: for Xfce support in xdg-open'
+ 'pcmanfm: for LXDE support in xdg-open'
+ 'perl-file-mimeinfo: for generic support in xdg-open')
+source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.${_gitdate}.tar.gz # last git commit 2012-03-10 13:55:24 (GMT) allow DESKTOP_SESSION='Xfce Session' to match xfce
+)
+md5sums=('4e37d65322dbc4763e85b8ba461f919b')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install
+ cd ${srcdir}/${pkgname}-5be359a49d4d8dc3c5f814ab89b8422ad522d837
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make scripts-clean -C scripts # needed if it's a git snapshot
+ make man scripts -C scripts # needed if it's a git snapshot
+# make # for release builds
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-5be359a49d4d8dc3c5f814ab89b8422ad522d837
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}