summaryrefslogtreecommitdiffstats
path: root/abs/extra/xe
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-05 14:44:31 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-05 14:44:31 (GMT)
commitd8dde5d1afa8398d81ca5f2cf0c590d183c9ed67 (patch)
tree0cc5e0dd6cc61964d00bd9a7de916231474c7873 /abs/extra/xe
parentfa4c95a2891767e4f3337cf8da68c3148c82af4c (diff)
downloadlinhes_pkgbuild-d8dde5d1afa8398d81ca5f2cf0c590d183c9ed67.zip
linhes_pkgbuild-d8dde5d1afa8398d81ca5f2cf0c590d183c9ed67.tar.gz
linhes_pkgbuild-d8dde5d1afa8398d81ca5f2cf0c590d183c9ed67.tar.bz2
xe : 2.6.2 updated pkgbuild to remove hardcoded 32 bit stuff.
This is a game emulator
Diffstat (limited to 'abs/extra/xe')
-rw-r--r--abs/extra/xe/PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/abs/extra/xe/PKGBUILD b/abs/extra/xe/PKGBUILD
index a6c6330..bbe2393 100644
--- a/abs/extra/xe/PKGBUILD
+++ b/abs/extra/xe/PKGBUILD
@@ -8,10 +8,19 @@ pkgdesc="A multi system emulator, that emulates many console and handheld video
arch=('i686' 'x86_64')
depends=('gtk2>=2.10.11')
url="http://www.xe-emulator.com"
-source=('http://www.xe-emulator.com/files/xe-x86-32-bin.2.16.2.tar.bz2' 'http://www.xe-emulator.com/files/bios.zip')
+if [ $CARCH="X86_64" ]
+then
+ xearch="x86-64"
+ xedir="xe-x64"
+else
+ xearch="x86-32"
+ xedir="xe-x86"
+fi
+
+source=("http://www.xe-emulator.com/files/xe-$xearch-bin.2.16.2.tar.bz2" 'http://www.xe-emulator.com/files/bios.zip')
install=xe.install
build() {
- cd $startdir/src/xe-x86
+ cd $startdir/src/$xedir
make
mkdir -p $startdir/pkg/usr/bin
mkdir -p $startdir/pkg/usr/lib/xe
@@ -19,5 +28,5 @@ build() {
cp -rf xe modules rc manual.html $startdir/pkg/usr/lib/xe
cp -a ../bios/* $startdir/pkg/usr/lib/xe/bios
}
-md5sums=('3ea92f686722cde768c0e008bb0b5ec3'
+md5sums=('adcf3872f41cd0f0ea1ac28ea90abc00'
'8f883e062242a2493e66c2b7f1f7807b')