summaryrefslogtreecommitdiffstats
path: root/abs/extra/xfsdump
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/xfsdump
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/xfsdump')
-rw-r--r--abs/extra/xfsdump/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra/xfsdump/PKGBUILD b/abs/extra/xfsdump/PKGBUILD
new file mode 100644
index 0000000..1d40228
--- /dev/null
+++ b/abs/extra/xfsdump/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 26569 2009-02-09 18:40:22Z paul $
+# Maintainer: judd <jvinet@zeroflux.org>
+pkgname=xfsdump
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Additional XFS filesystem utilities"
+arch=(i686 x86_64)
+license=('LGPL')
+url="http://oss.sgi.com/projects/xfs/"
+depends=('xfsprogs>=3.0.0' 'attr>=2.4.39' 'acl>=2.2.45' 'dmapi')
+options=('!makeflags')
+source=(ftp://oss.sgi.com/projects/xfs/cmd_tars/xfsdump-${pkgver}.tar.gz)
+md5sums=('')
+options=(!emptydirs)
+
+build() {
+ cd $startdir/src/xfsdump-$pkgver
+ autoconf
+ ./configure --prefix=/usr
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+ # fixes
+ rm -f $startdir/pkg/usr/lib/*.la
+ rm -f $startdir/pkg/usr/bin/{xfsdump,xfsrestore}
+}