summaryrefslogtreecommitdiffstats
path: root/abs/extra/xulrunner/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-07 01:40:32 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-07 01:40:32 (GMT)
commit6beefb5ec67b7f4d0467aabfa46ebf2115a96cbd (patch)
tree877221889668eb70c6fff1c2bfe9ab7d42032b0b /abs/extra/xulrunner/PKGBUILD
parent2e46e520ec07484d37f97f257d712e2161928024 (diff)
downloadlinhes_pkgbuild-6beefb5ec67b7f4d0467aabfa46ebf2115a96cbd.zip
linhes_pkgbuild-6beefb5ec67b7f4d0467aabfa46ebf2115a96cbd.tar.gz
linhes_pkgbuild-6beefb5ec67b7f4d0467aabfa46ebf2115a96cbd.tar.bz2
xulrunner: upgrade
Diffstat (limited to 'abs/extra/xulrunner/PKGBUILD')
-rw-r--r--abs/extra/xulrunner/PKGBUILD86
1 files changed, 56 insertions, 30 deletions
diff --git a/abs/extra/xulrunner/PKGBUILD b/abs/extra/xulrunner/PKGBUILD
index da6d8cd..36ed257 100644
--- a/abs/extra/xulrunner/PKGBUILD
+++ b/abs/extra/xulrunner/PKGBUILD
@@ -1,43 +1,69 @@
-# $Id: PKGBUILD 36430 2009-04-22 12:03:12Z pierre $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
-# Contributor: Jan de Groot <jgc@archlinux.org>
+# $Id: PKGBUILD 97209 2010-10-27 20:57:31Z ibiru $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
pkgname=xulrunner
-pkgver=1.9.1.1
-_ffoxver=3.5.1
-pkgrel=5
+pkgver=1.9.2.12
+_ffoxver=3.6.12
+pkgrel=1
pkgdesc="Mozilla Runtime Environment"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
-depends=('gtk2>=2.16.0' 'gcc-libs>=4.3.3' 'libidl2>=0.8.13' 'mozilla-common' 'nss>=3.12.3' 'libxt' 'lcms'
- 'hunspell>=1.2.8' 'startup-notification>=0.9')
-makedepends=('zip' 'pkgconfig' 'diffutils' 'libgnomeui>=2.24.1')
-provides=(gecko-sdk)
-replaces=(gecko-sdk)
+depends=('gtk2>=2.22.0' 'gcc-libs' 'libidl2>=0.8.13' 'mozilla-common' 'nss>=3.12.8' 'libxt' 'hunspell>=1.2.8' 'startup-notification>=0.10' 'mime-types' 'dbus-glib>=0.86' 'alsa-lib>=1.0.23' 'libevent')
+makedepends=('zip' 'pkg-config' 'diffutils' 'libgnomeui' 'python2' 'wireless_tools' 'autoconf2.13')
+optdepends=('libgnomeui: GNOME integration and MIME handling'
+ 'wireless_tools: Location aware browsing')
url="http://wiki.mozilla.org/XUL:Xul_Runner"
-source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}-source.tar.bz2
- mozconfig)
-md5sums=('18169e189785d680827d4fce94524449'
- '6509d12e6b17bfc51c09e1dc35259035')
-install=xulrunner.install
+source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}.source.tar.bz2
+ mozconfig
+ mozilla-pkgconfig.patch
+ fix-mozilla-launcher.patch
+ xulrunner-version.patch
+ xulrunner-png14.patch
+ enable-x86_64-tracemonkey.patch
+ python2.7.patch)
+md5sums=('80f4d83f23a7c45fc3f1904964ea2a5a'
+ 'e195cdcd51a8fb6fc77f0f653ff1e582'
+ '2d2d7143a4e0bfe71149a51f8dbbab2f'
+ '63eee2d1da3b43c9d604f2253f242f40'
+ '371303c5bdc4fa0d955d14521b93b69d'
+ '3bd0566180ad2daa32743b3ce58b2095'
+ 'cbd938cd1fb8210cd8a2c41833489af9'
+ 'ab3dc9aecae7f08b9492fb3c00a5fd28')
build() {
- cd ${startdir}/src/mozilla-1.9.1
- cp ${startdir}/src/mozconfig .mozconfig
+ cd "${srcdir}/mozilla-1.9.2"
+ cp "${srcdir}/mozconfig" .mozconfig
+
+ #fix libdir/sdkdir - fedora
+ patch -Np1 -i "${srcdir}/mozilla-pkgconfig.patch"
+
+ #Fix stub launcher - archlinux
+ patch -Np0 -i "${srcdir}/fix-mozilla-launcher.patch"
+
+ #Force installation to the same path for every version
+ patch -Np1 -i "${srcdir}/xulrunner-version.patch"
+
+ #Fix compile with libpng 1.4
+ patch -Np0 -i "${srcdir}/xulrunner-png14.patch"
+
+ #Tracemonkey for x86_64
+ patch -Np0 -i "${srcdir}/enable-x86_64-tracemonkey.patch"
+
+ #python2.7
+ patch -Np0 -i "${srcdir}/python2.7.patch"
unset CFLAGS
unset CXXFLAGS
- export LDFLAGS="-Wl,-rpath,/usr/lib/xulrunner-1.9"
-
- make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
- make -j1 DESTDIR=${startdir}/pkg install || return 1
- ln -sf xulrunner-${pkgver} ${pkgdir}/usr/lib/xulrunner-1.9
- ln -sf xulrunner-devel-${pkgver} ${pkgdir}/usr/lib/xulrunner-devel-1.9
- ln -sf xulrunner-${pkgver} ${pkgdir}/usr/include/xulrunner-1.9
- ln -sf xulrunner-${pkgver} ${pkgdir}/usr/share/idl/xulrunner-1.9
+ make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS"
+ make -j1 DESTDIR="${pkgdir}" install
- # The ubuntu patch adds these... get rid of it, NSS/NSPR has it.
- rm -f ${startdir}/pkg/usr/lib/pkgconfig/mozilla-ns{s,pr}.pc || return 1
+ #Remove included dictionaries, add symlink to system myspell path.
+ #Note: this will cause file conflicts when users have installed dictionaries in the old location
+ rm -rf "${pkgdir}/usr/lib/xulrunner-1.9.2/dictionaries"
+ ln -sf /usr/share/myspell "${pkgdir}/usr/lib/xulrunner-1.9.2/dictionaries"
- sed -i -e "s/xulrunner-${pkgver}/xulrunner-1.9/g" -e "s/xulrunner-devel-${pkgver}/xulrunner-devel-1.9/g" ${pkgdir}/usr/lib/pkgconfig/*.pc || return 1
+ # add xulrunner library path to ld.so.conf
+ install -d ${pkgdir}/etc/ld.so.conf.d
+ echo "/usr/lib/xulrunner-1.9.2" > ${pkgdir}/etc/ld.so.conf.d/xulrunner.conf
}