summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-12-02 18:13:59 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-12-02 18:13:59 (GMT)
commit066bcb38c4b416f0c380e9c8292a50f9103b72b6 (patch)
tree07de64551a26f8a292dd1fff09f006334d7e1396 /abs/extra
parentb0043b3d2e43f154d7a4d48db95ef59f2d504fdd (diff)
parentb5cb0290860bd55f2fd25238996601f2fd749615 (diff)
downloadlinhes_pkgbuild-066bcb38c4b416f0c380e9c8292a50f9103b72b6.zip
linhes_pkgbuild-066bcb38c4b416f0c380e9c8292a50f9103b72b6.tar.gz
linhes_pkgbuild-066bcb38c4b416f0c380e9c8292a50f9103b72b6.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/community/codecs/PKGBUILD39
-rw-r--r--abs/extra/fceu/ChangeLog21
-rw-r--r--[-rwxr-xr-x]abs/extra/fceu/PKGBUILD47
-rw-r--r--abs/extra/fceu/fceux.desktop10
-rw-r--r--abs/extra/fceu/fceux.pngbin0 -> 583 bytes
-rw-r--r--abs/extra/qscintilla/PKGBUILD79
-rw-r--r--abs/extra/qscintilla/configure.py-objdir-support.diff39
-rw-r--r--abs/extra/scons/PKGBUILD34
-rw-r--r--abs/extra/wireshark/PKGBUILD62
-rw-r--r--abs/extra/wireshark/wireshark-gtk.install11
-rw-r--r--abs/extra/wireshark/wireshark.install19
11 files changed, 264 insertions, 97 deletions
diff --git a/abs/extra/community/codecs/PKGBUILD b/abs/extra/community/codecs/PKGBUILD
index 8cf80be..416ff37 100644
--- a/abs/extra/community/codecs/PKGBUILD
+++ b/abs/extra/community/codecs/PKGBUILD
@@ -1,33 +1,22 @@
-# $Id: PKGBUILD 27228 2009-02-17 05:58:02Z thayer $
-# Contributor: Thomas Baechler <thomas@archlinux.org>
-# Maintainer: Thayer Williams <thayer@archlinux.org>
+# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
pkgname=codecs
-pkgver=20071007
-pkgrel=3
-pkgdesc="Non-linux native codec pack. (Win32, Real9, QuickTime)"
-arch=('i686' 'x86_64')
+pkgver=20100303
+pkgrel=4
+pkgdesc="Non-linux native codec pack."
+arch=('i686')
+url="http://www.mplayerhq.hu/design7/dload.html"
license=('unknown')
-# The codec packages are different
-# only the 32 bit package needs legacy libstdc++
-[ "$CARCH" = "i686" ] && depends=('libstdc++5')
-[ "$CARCH" = "x86_64" ] && depends=('gcc-libs')
+depends=('libstdc++5')
+conflicts=('codecs-extra')
+replaces=('codecs-extra')
options=('!strip')
-url="http://www.mplayerhq.hu/design7/dload.html"
-
-md5sums=('4ea9c2dbd0945c83af1a8d0dd363993c')
-_arch=""
-if [ "${CARCH}" = "x86_64" ]; then
- _arch="-amd64"
- md5sums=('8e1ceeec51469f5baac65e56fac709e8')
-fi
-source=(http://www.mplayerhq.hu/MPlayer/releases/codecs/essential${_arch}-${pkgver}.tar.bz2)
+source=(http://www.mplayerhq.hu/MPlayer/releases/codecs/all-$pkgver.tar.bz2)
+md5sums=('4a7eb1a706f4ed9950bf6dd7f063ef68')
build() {
- mkdir -p ${pkgdir}/usr/lib/codecs
- cd ${pkgdir}/usr/lib
- ln -s codecs win32
- install -m755 ${srcdir}/essential${_arch}-${pkgver}/* ${pkgdir}/usr/lib/codecs
- rm ${pkgdir}/usr/lib/codecs/README
+ install -d $pkgdir/usr/lib/codecs
+ ln -s codecs ${pkgdir}/usr/lib/win32
+ install -m644 $srcdir/all-$pkgver/* $pkgdir/usr/lib/codecs
}
diff --git a/abs/extra/fceu/ChangeLog b/abs/extra/fceu/ChangeLog
new file mode 100644
index 0000000..93ba8b3
--- /dev/null
+++ b/abs/extra/fceu/ChangeLog
@@ -0,0 +1,21 @@
+2009-11-06 Eric Belanger <eric@archlinux.org>
+
+ * fceux 2.1.2-1
+ * Upstream update
+
+2009-08-05 Eric Belanger <eric@archlinux.org>
+
+ * fceux 2.1.1-1
+ * gfceux 2.1.1-1
+ * Upstream update
+ * Implemented split packages
+
+2009-04-06 Eric Belanger <eric@archlinux.org>
+
+ * fceux 2.1.0a-1
+ * Upstream update
+
+2009-03-06 Eric Belanger <eric@archlinux.org>
+
+ * fceux 2.0.3-1
+ * Added to [community] repo to replace fceu
diff --git a/abs/extra/fceu/PKGBUILD b/abs/extra/fceu/PKGBUILD
index cdae29a..532a8fd 100755..100644
--- a/abs/extra/fceu/PKGBUILD
+++ b/abs/extra/fceu/PKGBUILD
@@ -1,24 +1,35 @@
-# Maintainer: Eric Belanger <belanger@astro.umontreal.ca>
+# $Id: PKGBUILD 31918 2010-11-07 20:45:58Z lcarlier $
+# Maintainer: Eric Belanger <eric@archlinux.org>
# Contributor: Jo Christian Bergskås <jcberg@gmail.com>
-pkgname=fceu
-pkgver=0.98.15
-pkgrel=1
-pkgdesc="FCE Ultra is a fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support."
+pkgname=fceux
+pkgver=2.1.4a
+pkgrel=4
arch=('i686' 'x86_64')
-url="http://fceultra.sourceforge.net"
-license="GPL"
-options=('docs')
-depends=('sdl' 'zlib')
-source=(ftp://ftp.knoppmyth.net/R6/sources/$pkgname-$pkgver-src.tar.bz2)
-md5sums=('bfe9aa7f91c19fa17bb6e5424dc5901b')
+url="http://fceux.com/web/home.html"
+pkgdesc="A fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support"
+license=('GPL')
+depends=('sdl' 'lua' 'gtk2')
+makedepends=('scons' 'mesa')
+optdepends=('xchm: for viewing the help manual')
+provides=('fceu' 'gfceux')
+replaces=('fceu' 'gfceux')
+source=(http://downloads.sourceforge.net/fceultra/$pkgname-${pkgver}.src.tar.bz2 \
+ fceux.desktop fceux.png)
+md5sums=('a1252a888cdc8b2c42ae031211f2fad6'
+ '30baf915c936926fa50f59d8276f6575'
+ '3fe753731ac46b5fee528b1f73abd3e3')
build() {
- cd $startdir/src/fceu
- ./configure --prefix=/usr --with-opengl --build=i686-linux-gnu
- make || return 1
- make DESTDIR=$startdir/pkg install
- install -D -m644 $startdir/src/fceu/Documentation/fceu-sdl.6 $startdir/pkg/usr/man/man6/fceu.6
- install -d $startdir/pkg/usr/share/doc/fceu-doc
- cp -r $startdir/src/fceu/Documentation/* $startdir/pkg/usr/share/doc/fceu-doc
+ cd "${srcdir}/fceu$pkgver"
+ scons
+
+ sed -i "s|/usr/local|${pkgdir}/usr|" SConstruct
+ scons install
+
+ install -D -m644 bin/$pkgname.chm "${pkgdir}/usr/share/doc/$pkgname/$pkgname.chm"
+ install -D -m644 "$srcdir"/fceux.desktop "${pkgdir}"/usr/share/applications/fceux.desktop
+ install -D -m644 "$srcdir"/fceux.png "$pkgdir"/usr/share/pixmaps/fceux.png
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/fceu/fceux.desktop b/abs/extra/fceu/fceux.desktop
new file mode 100644
index 0000000..c166755
--- /dev/null
+++ b/abs/extra/fceu/fceux.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Fceux
+GenericName=NES/Famicom emulator
+Exec=fceux
+Icon=/usr/share/pixmaps/fceux.png
+Type=Application
+Categories=Game;Emulator;
+Encoding=UTF-8
+
+
diff --git a/abs/extra/fceu/fceux.png b/abs/extra/fceu/fceux.png
new file mode 100644
index 0000000..1cf27b1
--- /dev/null
+++ b/abs/extra/fceu/fceux.png
Binary files differ
diff --git a/abs/extra/qscintilla/PKGBUILD b/abs/extra/qscintilla/PKGBUILD
index 9b3bf94..9ba5a39 100644
--- a/abs/extra/qscintilla/PKGBUILD
+++ b/abs/extra/qscintilla/PKGBUILD
@@ -1,55 +1,60 @@
# $Id: PKGBUILD 46926 2009-07-22 04:56:17Z pierre $
-# Maintainer: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
# Contributor: Michal Krenek <mikos@sg1.cz>
-# Bug #8577 Modifications made by DaNiMoTh <jjdanimoth.aur@gmail.com>
+# Contributor: DaNiMoTh <jjdanimoth.aur@gmail.com>
-pkgname=qscintilla
-pkgver=2.4.0
-_pkgver=2.4
-pkgrel=1
+pkgbase=qscintilla
+pkgname=(qscintilla python-qscintilla)
+pkgver=2.4.5
+pkgrel=4
license=('GPL')
-pkgdesc="A port to Qt4 of Neil Hodgson's Scintilla C++ editor class."
arch=('i686' 'x86_64')
-url="http://www.riverbankcomputing.co.uk/software/qscintilla/download"
-depends=('qt')
-provides=('qscintilla2')
-conflicts=('qscintilla2')
-replaces=('qscintilla2')
-source=(http://riverbankcomputing.com/static/Downloads/QScintilla2/QScintilla-gpl-$_pkgver.tar.gz)
-md5sums=('dd69520ec91f1acb97a4eb74ddde37c9')
+url="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+makedepends=('pyqt')
+source=(http://riverbankcomputing.com/static/Downloads/QScintilla2/QScintilla-gpl-${pkgver}.tar.gz
+ configure.py-objdir-support.diff)
+md5sums=('8063f8f933513959432c27c5ffecf56b'
+ '8cf9c06252e2f11ab00e62848e322fd3')
+
build() {
- cd $srcdir/QScintilla-gpl-$_pkgver/Qt4
- sed -i "s|DESTDIR = .*|DESTDIR = $pkgdir/usr/lib|g" qscintilla.pro
- sed -i "s|header.path = .*|header.path = $pkgdir/usr/include|g" qscintilla.pro
- sed -i "s|trans.path = .*|trans.path = $pkgdir/usr/share/qt/translations|g" qscintilla.pro
- sed -i "s|qsci.path = .*|qsci.path = $pkgdir/usr/share/qt/translations|g" qscintilla.pro
+ cd $srcdir/QScintilla-gpl-$pkgver
+ patch -Np1 -i "${srcdir}/configure.py-objdir-support.diff"
+ cd Qt4
qmake qscintilla.pro
- sed -i 's|$(MOVE) $(TARGET)|$(COPY) $(TARGET)|g' Makefile
- make || return 1
- make DESTDIR=$pkgdir install
+ make
cd ../designer-Qt4
+ qmake designer.pro INCLUDEPATH+=../Qt4 QMAKE_LIBDIR+=../Qt4
+ make
- # Qt4 designer qscintilla2 plugin
- mkdir -p $pkgdir/usr/lib/qt/plugins/designer
+ cd ../Python
+ python2 configure.py -n ../Qt4/ -o ../Qt4 -c -p 4
+ make
+}
- echo "INCPATH += ../Qt4" >> designer.pro
- sed -i "s|LIBS.*|LIBS += -L../Qt4 -lqscintilla2|g" designer.pro
- qmake designer.pro
- make || return 1
- cp libqscintillaplugin.so $pkgdir/usr/lib/qt/plugins/designer/ || return 1
+package_qscintilla() {
+ pkgdesc="A port to Qt4 of Neil Hodgson's Scintilla C++ editor class"
+ provides=('qscintilla2')
+ conflicts=('qscintilla2')
+ replaces=('qscintilla2' 'qscintilla')
+ depends=('qt')
- msg "Installing the libs to the right place"
+ cd ${srcdir}/QScintilla-gpl-${pkgver}/Qt4
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
- cd ../Qt4
+ cd ${srcdir}/QScintilla-gpl-${pkgver}/designer-Qt4
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+}
- cp libqscintilla2.so.5.1.0 $pkgdir/usr/lib/ || return 1
+package_python-qscintilla() {
+ pkgdesc="Python bindings for QScintilla2"
+ conflicts=('python-qscintilla2')
+ replaces=('python-qscintilla2')
+ depends=('qscintilla' 'pyqt')
- pushd $pkgdir/usr/lib/
- ln -s libqscintilla2.so.5.1.0 libqscintilla2.so
- ln -s libqscintilla2.so.5.1.0 libqscintilla2.so.5
- ln -s libqscintilla2.so.5.1.0 libqscintilla2.so.5.1
- popd
+ cd "${srcdir}/QScintilla-gpl-${pkgver}/Python"
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
}
diff --git a/abs/extra/qscintilla/configure.py-objdir-support.diff b/abs/extra/qscintilla/configure.py-objdir-support.diff
new file mode 100644
index 0000000..b595de1
--- /dev/null
+++ b/abs/extra/qscintilla/configure.py-objdir-support.diff
@@ -0,0 +1,39 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 02_configure.dpatch by Torsten Marek <shlomme@debian.org>
+##
+## DP: patch the configure script for the Python bindings to support object dir builds
+
+@DPATCH@
+Index: qscintilla2-2.4.2/Python/configure.py
+===================================================================
+--- qscintilla2-2.4.2.orig/Python/configure.py 2010-01-20 20:56:09.000000000 +0100
++++ qscintilla2-2.4.2/Python/configure.py 2010-01-27 22:54:35.603870417 +0100
+@@ -33,6 +33,7 @@
+ import glob
+ import optparse
+
++src_dir = os.path.dirname(os.path.abspath(__file__))
+
+ # Import SIP's configuration module so that we have access to the error
+ # reporting. Then try and import the configuration modules for both PyQt3 and
+@@ -162,7 +163,7 @@
+ if os.access(sciglobal, os.F_OK):
+ # Get the QScintilla version string.
+ _, sciversstr = sipconfig.read_version(sciglobal, "QScintilla", "QSCINTILLA_VERSION", "QSCINTILLA_VERSION_STR")
+-
++ return # Debian: do not check for the installed version, we're good this way.
+ if glob.glob(os.path.join(opts.qscilibdir, "*qscintilla2*")):
+ # Because we include the Python bindings with the C++ code we can
+ # reasonably force the same version to be used and not bother about
+@@ -232,9 +233,9 @@
+ argv.append(buildfile)
+
+ if pyqt.pyqt_version >= 0x040000:
+- argv.append("sip/qscimod4.sip")
++ argv.append(os.path.join(src_dir, "sip/qscimod4.sip"))
+ else:
+- argv.append("sip/qscimod3.sip")
++ argv.append(os.path.join(src_dir, "sip/qscimod3.sip"))
+
+ os.system(" ".join(argv))
+
diff --git a/abs/extra/scons/PKGBUILD b/abs/extra/scons/PKGBUILD
new file mode 100644
index 0000000..edc4fbc
--- /dev/null
+++ b/abs/extra/scons/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 90304 2010-09-10 14:41:36Z schiv $
+# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+# Contributor: Lukas Sabota <punkrockguy318@comcast.net>
+# Contributor: Brice Carpentier <brice@dlfp.org>
+
+pkgname=scons
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Extensible Python-based build utility"
+arch=('any')
+url="http://scons.org"
+license=('MIT')
+depends=('python2')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('beca648b894cdbf85383fffc79516d18')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python2 setup.py install --standard-lib \
+ --prefix=/usr \
+ --install-data=/usr/share \
+ --optimize=1 \
+ --root="$pkgdir"
+
+ # fix for python 2.7
+ sed -i 's:^#!.*bin/env python:#!/usr/bin/env python2:' "$pkgdir"/usr/bin/*
+
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+
diff --git a/abs/extra/wireshark/PKGBUILD b/abs/extra/wireshark/PKGBUILD
index 4b7a88c..3d6b90e 100644
--- a/abs/extra/wireshark/PKGBUILD
+++ b/abs/extra/wireshark/PKGBUILD
@@ -1,26 +1,54 @@
-# $Id: PKGBUILD 34765 2009-04-11 14:17:32Z hugo $
-# Maintainer: Hugo Doria <hugo@archlinux.org>
-
-pkgname=wireshark
-pkgver=1.2.0
-pkgrel=3
-pkgdesc="A free network protocol analyzer for Unix/Linux and Windows"
+# $Id: PKGBUILD 94904 2010-10-12 06:47:49Z guillaume $
+# Maintainer: Guillaume ALAUX <guillaume at alaux dot net>
+# Contributor: Florian Pritz <bluewind at jabber dot ccc dot de>
+pkgname=(wireshark-cli wireshark-gtk)
+pkgbase=wireshark
+pkgver=1.4.1
+pkgrel=1
arch=('i686' 'x86_64')
license=('GPL2')
-depends=('gtk2>=2.14.5' 'heimdal>=1.2.1' 'libpcap>=1.0.0' 'bash' 'gnutls>=2.4.1' 'libcap>=2.16')
-makedepends=('bison' 'flex')
+makedepends=('bison' 'flex' 'gtk2' 'heimdal' 'libpcap' 'bash' 'gnutls' 'libcap')
url="http://www.wireshark.org/"
-replaces=('ethereal')
options=(!libtool)
-source=(http://www.wireshark.org/download/src/${pkgname}-${pkgver}.tar.gz wireshark.desktop wireshark.png)
+source=(http://www.wireshark.org/download/src/${pkgbase}-${pkgver}.tar.bz2)
+md5sums=('1719d20a10990e7c2cb261df7021aab6')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgbase}-${pkgver}"
export CFLAGS="-fno-unit-at-a-time ${CFLAGS}"
- ./configure --prefix=/usr --with-ssl || return 1
- make all || return 1
- make DESTDIR=${pkgdir} install || return 1
- install -Dm644 ${srcdir}/wireshark.png ${pkgdir}/usr/share/icons/wireshark.png
- install -Dm644 ${srcdir}/wireshark.desktop ${pkgdir}/usr/share/applications/wireshark.desktop
+ ./configure --prefix=/usr --with-ssl
+ make all
+}
+
+package_wireshark-cli() {
+ pkgdesc="A free network protocol analyzer for Unix/Linux and Windows - CLI version"
+ depends=('heimdal' 'libpcap' 'bash' 'gnutls' 'libcap' 'glib2')
+ install=wireshark.install
+ conflicts=(wireshark)
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ #wireshark uid group is 150
+ chgrp 150 "${pkgdir}/usr/bin/dumpcap"
+ chmod 754 "${pkgdir}/usr/bin/dumpcap"
+ rm "$pkgdir/usr/bin/wireshark"
+}
+
+package_wireshark-gtk() {
+ pkgdesc="A free network protocol analyzer for Unix/Linux and Windows - GTK frontend"
+ depends=('gtk2' 'wireshark-cli')
+ install=wireshark-gtk.install
+ replaces=(wireshark)
+ conflicts=(wireshark)
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ install -Dm755 .libs/wireshark "$pkgdir/usr/bin/wireshark"
+ for d in 16 32 48; do
+ install -Dm644 image/hi${d}-app-wireshark.png ${pkgdir}/usr/share/icons/hicolor/${d}x${d}/apps/wireshark.png
+ done
+ install -Dm644 wireshark.desktop ${pkgdir}/usr/share/applications/wireshark.desktop
}
diff --git a/abs/extra/wireshark/wireshark-gtk.install b/abs/extra/wireshark/wireshark-gtk.install
new file mode 100644
index 0000000..6b1b64b
--- /dev/null
+++ b/abs/extra/wireshark/wireshark-gtk.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/abs/extra/wireshark/wireshark.install b/abs/extra/wireshark/wireshark.install
new file mode 100644
index 0000000..8936256
--- /dev/null
+++ b/abs/extra/wireshark/wireshark.install
@@ -0,0 +1,19 @@
+post_install() {
+ if getent group wireshark >/dev/null 2>&1; then
+ groupmod -g 150 wireshark &>/dev/null
+ else
+ groupadd -g 150 wireshark &>/dev/null
+ fi
+ setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' usr/bin/dumpcap
+ echo "NOTE: To run wireshark as normal user you have to add yourself into wireshark group"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ if getent group wireshark >/dev/null 2>&1; then
+ groupdel wireshark
+ fi
+}