summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2019-01-28 19:32:34 (GMT)
committerBritney Fransen <brfransen@gmail.com>2019-01-28 19:32:34 (GMT)
commit18ec55d40d0de65ec28cbe7c79f16bb122b64697 (patch)
tree0171a08d1e521155eb44b367fb1cd1243b486861 /abs/extra
parent776f1109282499fed8106fa7f19d6d3c50400e49 (diff)
downloadlinhes_pkgbuild-18ec55d40d0de65ec28cbe7c79f16bb122b64697.zip
linhes_pkgbuild-18ec55d40d0de65ec28cbe7c79f16bb122b64697.tar.gz
linhes_pkgbuild-18ec55d40d0de65ec28cbe7c79f16bb122b64697.tar.bz2
java-hamcrest: inital inclusion
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/java-hamcrest/LICENSE.txt27
-rw-r--r--abs/extra/java-hamcrest/PKGBUILD38
2 files changed, 65 insertions, 0 deletions
diff --git a/abs/extra/java-hamcrest/LICENSE.txt b/abs/extra/java-hamcrest/LICENSE.txt
new file mode 100644
index 0000000..5ebe92c
--- /dev/null
+++ b/abs/extra/java-hamcrest/LICENSE.txt
@@ -0,0 +1,27 @@
+BSD License
+
+Copyright (c) 2000-2006, www.hamcrest.org
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+Redistributions of source code must retain the above copyright notice, this list of
+conditions and the following disclaimer. Redistributions in binary form must reproduce
+the above copyright notice, this list of conditions and the following disclaimer in
+the documentation and/or other materials provided with the distribution.
+
+Neither the name of Hamcrest nor the names of its contributors may be used to endorse
+or promote products derived from this software without specific prior written
+permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
+SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
+BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY
+WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
+DAMAGE.
diff --git a/abs/extra/java-hamcrest/PKGBUILD b/abs/extra/java-hamcrest/PKGBUILD
new file mode 100644
index 0000000..f707fb0
--- /dev/null
+++ b/abs/extra/java-hamcrest/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
+_libname=hamcrest
+pkgname=java-${_libname}
+pkgver=1.3
+pkgrel=4
+pkgdesc='Java matcher objects library'
+arch=('any')
+url='https://code.google.com/p/hamcrest'
+license=('BSD')
+depends=('java-runtime-headless')
+_url='https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/hamcrest'
+source=(${_url}/${_libname}-core-${pkgver}.jar
+ ${_url}/${_libname}-library-${pkgver}.jar
+ ${_url}/${_libname}-generator-${pkgver}.jar
+ ${_url}/${_libname}-integration-${pkgver}.jar
+ LICENSE.txt)
+noextract=(${_libname}-core-${pkgver}.jar
+ ${_libname}-library-${pkgver}.jar
+ ${_libname}-generator-${pkgver}.jar
+ ${_libname}-integration-${pkgver}.jar)
+sha256sums=('66fdef91e9739348df7a096aa384a5685f4e875584cce89386a7a47251c4d8e9'
+ '711d64522f9ec410983bd310934296da134be4254a125080a0416ec178dfad1c'
+ '84c810cafabd046d0e5599f9b5fc1514b2a6ce45313997e020a47076ba27d035'
+ '70f418efbb506c5155da5f9a5a33262ea08a9e4d7fea186aa9015c41a7224ac2'
+ '1cde867cab5c8e842929da5391cef98b4017314822270e934e8e2eef3767c666')
+
+package() {
+ cd "${srcdir}"
+
+ install -dm755 ${pkgdir}/usr/share/java/${_libname}
+ for j in core library generator integration; do
+ cp ${_libname}-${j}-${pkgver}.jar ${pkgdir}/usr/share/java/${_libname}/${j}-${pkgver}.jar
+ ln -s ${j}-${pkgver}.jar ${pkgdir}/usr/share/java/${_libname}/${j}.jar
+ ln -s ${_libname}/${j}-${pkgver}.jar ${pkgdir}/usr/share/java/${_libname}-${j}.jar
+ done
+
+ install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}