summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-06 00:21:38 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-06 00:21:38 (GMT)
commit666d9ffbfd0244bfda3fddd9841a2749f26a979b (patch)
tree8ec40fd0a4fe89bc690b74c635e93193f9510d5e /abs/extra
parent8821f4948b460a8b5a4921ea45b5c9b450968022 (diff)
downloadlinhes_pkgbuild-666d9ffbfd0244bfda3fddd9841a2749f26a979b.zip
linhes_pkgbuild-666d9ffbfd0244bfda3fddd9841a2749f26a979b.tar.gz
linhes_pkgbuild-666d9ffbfd0244bfda3fddd9841a2749f26a979b.tar.bz2
dri3proto: initial inclusion. dep of mesa. refs #964
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/dri3proto/COPYING21
-rw-r--r--abs/extra/dri3proto/PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/abs/extra/dri3proto/COPYING b/abs/extra/dri3proto/COPYING
new file mode 100644
index 0000000..313c8f1
--- /dev/null
+++ b/abs/extra/dri3proto/COPYING
@@ -0,0 +1,21 @@
+/*
+ * Copyright © 2013 Keith Packard
+ *
+ * Permission to use, copy, modify, distribute, and sell this software and its
+ * documentation for any purpose is hereby granted without fee, provided that
+ * the above copyright notice appear in all copies and that both that copyright
+ * notice and this permission notice appear in supporting documentation, and
+ * that the name of the copyright holders not be used in advertising or
+ * publicity pertaining to distribution of the software without specific,
+ * written prior permission. The copyright holders make no representations
+ * about the suitability of this software for any purpose. It is provided "as
+ * is" without express or implied warranty.
+ *
+ * THE COPYRIGHT HOLDERS DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+ * INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+ * EVENT SHALL THE COPYRIGHT HOLDERS BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+ * CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+ * DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+ * TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE
+ * OF THIS SOFTWARE.
+ */
diff --git a/abs/extra/dri3proto/PKGBUILD b/abs/extra/dri3proto/PKGBUILD
new file mode 100644
index 0000000..02e81e4
--- /dev/null
+++ b/abs/extra/dri3proto/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+
+pkgname=dri3proto
+pkgver=1.0
+pkgrel=1
+pkgdesc="X11 DRI3 protocol"
+arch=('any')
+url="http://xorg.freedesktop.org/"
+license=('custom')
+source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2
+ COPYING)
+sha256sums=('01be49d70200518b9a6b297131f6cc71f4ea2de17436896af153226a774fc074'
+ '5e46864ede2fda46c3cb7cfe3a7b9f9e4bd36d8d21d8010a284caa64b81d465a')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+
+ # license is still missing
+ # COPYING is taken from top of /usr/include/X11/extensions/dri3proto.h
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 ${srcdir}/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}