summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-17 00:04:46 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:05 (GMT)
commit867f417be1293cd89097d00bd9422fb0b0cb345e (patch)
treee01bba314ea718b0b5d0b4f733432eaf2613916f /abs/extra
parent24ed89c67ae43e56a5ce8c42557dc47f768efa4d (diff)
downloadlinhes_pkgbuild-867f417be1293cd89097d00bd9422fb0b0cb345e.zip
linhes_pkgbuild-867f417be1293cd89097d00bd9422fb0b0cb345e.tar.gz
linhes_pkgbuild-867f417be1293cd89097d00bd9422fb0b0cb345e.tar.bz2
etherwake, ethtool, gconf:
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/etherwake/PKGBUILD4
-rw-r--r--abs/extra/ethtool/PKGBUILD9
-rw-r--r--abs/extra/gconf/PKGBUILD22
-rw-r--r--abs/extra/gconf/gconf.install5
4 files changed, 21 insertions, 19 deletions
diff --git a/abs/extra/etherwake/PKGBUILD b/abs/extra/etherwake/PKGBUILD
index bbe4f6a..4d53d1e 100644
--- a/abs/extra/etherwake/PKGBUILD
+++ b/abs/extra/etherwake/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=etherwake
pkgver=1.09
-pkgrel=5
+pkgrel=6
arch=(i686 x86_64)
pkgdesc="Utility for waking up computers via wake-on-lan (wol)"
license="GPL"
@@ -19,7 +19,7 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver.orig"
- install -Dm0755 etherwake "$pkgdir/usr/sbin/etherwake"
+ install -Dm0755 etherwake "$pkgdir/usr/bin/etherwake"
install -Dm0644 etherwake.8.gz "$pkgdir/usr/share/man/man8/etherwake.8"
}
diff --git a/abs/extra/ethtool/PKGBUILD b/abs/extra/ethtool/PKGBUILD
index 27ba9a5..cdf5122 100644
--- a/abs/extra/ethtool/PKGBUILD
+++ b/abs/extra/ethtool/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 161868 2012-06-16 00:18:47Z ibiru $
+# $Id: PKGBUILD 196480 2013-10-14 08:50:55Z ioni $
# Maintainer : Ionut Biru <ibiru@archlinux.org>
# Contributor: Paul Mattal <paul@archlinux.org>
# Contributor: Martin Kemp <mdkemp@elys.com>
pkgname=ethtool
-pkgver=3.4
+pkgver=3.11
pkgrel=1
epoch=1
pkgdesc="Utility for controlling network drivers and hardware"
@@ -16,7 +16,8 @@ source=(http://www.kernel.org/pub/software/network/$pkgname/$pkgname-$pkgver.tar
build() {
cd $pkgname-$pkgver
- ./configure --prefix=/usr --mandir=/usr/share/man
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --sbindir=/usr/bin
make
}
@@ -24,4 +25,4 @@ package() {
cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
-md5sums=('cc4c4cf3ac086a53cd24f17d426f2b8f')
+md5sums=('5f3a0ed1b3510ca0695db0b4debdd292')
diff --git a/abs/extra/gconf/PKGBUILD b/abs/extra/gconf/PKGBUILD
index 9a4d1f6..d7fc7e6 100644
--- a/abs/extra/gconf/PKGBUILD
+++ b/abs/extra/gconf/PKGBUILD
@@ -1,15 +1,14 @@
-# $Id: PKGBUILD 156770 2012-04-23 09:05:12Z ibiru $
+# $Id: PKGBUILD 197971 2013-10-30 12:00:18Z allan $
# Maintainer: Jan de Groot <jan@archlinux.org>
pkgname=gconf
-pkgver=3.2.5
-pkgrel=2
+pkgver=3.2.6
+pkgrel=3
pkgdesc="A configuration database system"
arch=(i686 x86_64)
license=('LGPL')
-depends=('libxml2' 'polkit' 'libldap' 'dbus-glib' 'gtk3')
+depends=('libxml2' 'polkit' 'libldap' 'dbus-glib')
makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
-options=('!libtool')
install=gconf.install
url="http://www.gnome.org"
source=(http://ftp.gnome.org/pub/gnome/sources/GConf/3.2/GConf-$pkgver.tar.xz
@@ -17,14 +16,15 @@ source=(http://ftp.gnome.org/pub/gnome/sources/GConf/3.2/GConf-$pkgver.tar.xz
gconfpkg
gconf-reload.patch
01_xml-gettext-domain.patch)
-sha256sums=('4ddea9503a212ee126c5b46a0a958fd5484574c3cb6ef2baf38db02e819e58c6'
+sha256sums=('1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c'
'ee6b6e6f4975dad13a8c45f1c1f0547a99373bdecdcd6604bfc12965c328a028'
'bf1928718caa5df2b9e54a13cfd0f15a8fe0e09e86b84385ce023616a114e898'
'567b78d8b4b4bbcb77c5f134d57bc503c34867fcc6341c0b01716bcaa4a21694'
'c883dec2b96978874a53700cfe7f26f24f8296767203e970bc6402b4b9945eb8')
-build() {
+prepare() {
cd "GConf-$pkgver"
+
# Patch from fedora - reloads gconf after installing schemas
patch -Np1 -i "$srcdir/gconf-reload.patch"
# http://bugzilla.gnome.org/show_bug.cgi?id=568845
@@ -32,10 +32,14 @@ build() {
# Python2 fix
sed -i '1s|#!/usr/bin/env python$|&2|' gsettings/gsettings-schema-convert
+}
+
+build() {
+ cd "GConf-$pkgver"
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --libexecdir=/usr/lib/GConf \
- --disable-static --enable-defaults-service --with-gtk=3.0 \
+ --disable-static --enable-defaults-service \
--disable-orbit
make pkglibdir=/usr/lib/GConf
@@ -47,5 +51,5 @@ package() {
install -m755 -d "$pkgdir/etc/gconf/gconf.xml.system"
install -m755 "$srcdir/gconf-merge-schema" "$pkgdir/usr/bin/"
- install -Dm755 "$srcdir/gconfpkg" "$pkgdir/usr/sbin/gconfpkg"
+ install -m755 "$srcdir/gconfpkg" "$pkgdir/usr/bin/gconfpkg"
}
diff --git a/abs/extra/gconf/gconf.install b/abs/extra/gconf/gconf.install
index f7945d1..a5ea777 100644
--- a/abs/extra/gconf/gconf.install
+++ b/abs/extra/gconf/gconf.install
@@ -9,10 +9,7 @@ post_upgrade() {
chmod 755 etc/gconf/gconf.xml.system
usr/bin/gio-querymodules usr/lib/gio/modules
- PID=`pidof gconfd-2`
- if [ ! -z "${PID}" ]; then
- kill ${PID}
- fi
+ pkill /usr/lib/GConf/gconfd-2 || return 0
}
post_remove() {