summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:41:12 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:41:12 (GMT)
commit8cd3a89c94b2720c9104db2b0dd99a919fa0592d (patch)
treeb24217dd71e683c031a3e1fac68e5fbfd650bd3d /abs/extra
parent162e9d1b44e3d7a7f76053653100de66f024b9f1 (diff)
downloadlinhes_pkgbuild-8cd3a89c94b2720c9104db2b0dd99a919fa0592d.zip
linhes_pkgbuild-8cd3a89c94b2720c9104db2b0dd99a919fa0592d.tar.gz
linhes_pkgbuild-8cd3a89c94b2720c9104db2b0dd99a919fa0592d.tar.bz2
cifs-utils 5.5
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/cifs-utils/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra/cifs-utils/PKGBUILD b/abs/extra/cifs-utils/PKGBUILD
new file mode 100644
index 0000000..f220fa4
--- /dev/null
+++ b/abs/extra/cifs-utils/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 161430 2012-06-11 13:06:12Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+pkgname=cifs-utils
+pkgver=5.5
+pkgrel=1
+pkgdesc="CIFS filesystem user-space tools"
+arch=(i686 x86_64)
+url="http://wiki.samba.org/index.php/LinuxCIFS_utils"
+license=('GPL')
+depends=('libcap-ng' 'keyutils' 'krb5' 'talloc' 'libwbclient')
+source=(ftp://ftp.samba.org/pub/linux-cifs/cifs-utils/$pkgname-$pkgver.tar.bz2)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" ROOTSBINDIR=/usr/bin install
+ # set mount.cifs uid, to enable none root mounting form fstab
+ chmod +s $pkgdir/usr/bin/mount.cifs
+}
+md5sums=('4de6c660ccdb9506d0e2cff4f37b8707')