summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-10 18:26:33 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-10 18:26:33 (GMT)
commita7f7a5acda2da4c00448d672c55ca143c5c15bb9 (patch)
tree4ae348594829a8766a58b5c586144c368da838d5 /abs/extra
parentcc7bcb1cb6630056983940f0761b0bd4458ff793 (diff)
downloadlinhes_pkgbuild-a7f7a5acda2da4c00448d672c55ca143c5c15bb9.zip
linhes_pkgbuild-a7f7a5acda2da4c00448d672c55ca143c5c15bb9.tar.gz
linhes_pkgbuild-a7f7a5acda2da4c00448d672c55ca143c5c15bb9.tar.bz2
chrpath: initial inclusion. dep of iniparser. refs #961
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/chrpath/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/extra/chrpath/PKGBUILD b/abs/extra/chrpath/PKGBUILD
new file mode 100644
index 0000000..4c5d2a2
--- /dev/null
+++ b/abs/extra/chrpath/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+pkgname=chrpath
+pkgver=0.16
+pkgrel=1
+pkgdesc="Change or delete the rpath or runpath in ELF files"
+arch=('i686' 'x86_64')
+url="http://directory.fsf.org/project/chrpath/"
+license=('GPL2')
+depends=('glibc')
+source=("https://alioth.debian.org/frs/download.php/latestfile/813/chrpath-$pkgver.tar.gz")
+md5sums=('2bf8d1d1ee345fc8a7915576f5649982')
+
+prepare() {
+ cd "${srcdir}"/$pkgname-$pkgver
+# rm -f config.guess
+# aclocal
+# libtoolize
+# automake --add-missing
+# autoconf
+}
+
+build() {
+ cd "${srcdir}"/$pkgname-$pkgver
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+ make DESTDIR="${pkgdir}" docdir=/usr/share/doc/chrpath install
+}