summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-06-12 16:33:24 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-06-12 16:33:24 (GMT)
commitada13c3f17134c5885f686509d128080450efa1b (patch)
tree515f3e4d1d577d9827d86c4f1473bb0184772165 /abs/extra
parenta3e950053d847e719d489c13064b6c165425385c (diff)
parent39939b77f5be04020bce74f1d4aaf7bb5d0c4c00 (diff)
downloadlinhes_pkgbuild-ada13c3f17134c5885f686509d128080450efa1b.zip
linhes_pkgbuild-ada13c3f17134c5885f686509d128080450efa1b.tar.gz
linhes_pkgbuild-ada13c3f17134c5885f686509d128080450efa1b.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/ffmpeg-compat/PKGBUILD85
-rw-r--r--abs/extra/ffmpeg-compat/__changelog1
-rw-r--r--abs/extra/ffmpeg-compat/ffmpeg-0.10-libvpx-1.5.patch24
-rw-r--r--abs/extra/ffmpeg2.8/PKGBUILD14
-rw-r--r--abs/extra/google-chrome/PKGBUILD12
-rw-r--r--abs/extra/handbrake/PKGBUILD52
-rw-r--r--abs/extra/handbrake/handbrake-fix-missing-x265-link-flag.patch13
-rw-r--r--abs/extra/lm_sensors/PKGBUILD16
-rw-r--r--abs/extra/openpht/PKGBUILD8
-rw-r--r--abs/extra/plex-media-server/PKGBUILD4
-rw-r--r--abs/extra/tigervnc/PKGBUILD54
-rw-r--r--abs/extra/tigervnc/gethomedir.patch20
-rw-r--r--abs/extra/tigervnc/vncserver.service2
-rw-r--r--abs/extra/tigervnc/xorg118.patch27
-rw-r--r--abs/extra/web-on-linhes/PKGBUILD8
-rw-r--r--abs/extra/web-on-linhes/web-on-linhes.sh2
16 files changed, 75 insertions, 267 deletions
diff --git a/abs/extra/ffmpeg-compat/PKGBUILD b/abs/extra/ffmpeg-compat/PKGBUILD
deleted file mode 100644
index 5b5879f..0000000
--- a/abs/extra/ffmpeg-compat/PKGBUILD
+++ /dev/null
@@ -1,85 +0,0 @@
-# $Id$
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
-# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Contributor: Ionut Biru <ibiru@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-# Contributor: Paul Mattal <paul@archlinux.org>
-
-pkgname=ffmpeg-compat
-pkgver=0.10.16
-pkgrel=4
-epoch=1
-pkgdesc='Complete and free Internet live audio and video broadcasting solution'
-arch=('i686' 'x86_64')
-url='http://ffmpeg.org/'
-license=('GPL')
-depends=(
- 'alsa-lib' 'bzip2' 'gsm' 'lame' 'libass' 'libmodplug'
- 'libtheora' 'libva' 'opencore-amr' 'openjpeg' 'rtmpdump' 'schroedinger'
- 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
- 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so' 'libx264.so'
-)
-makedepends=('libvdpau' 'yasm' 'x264')
-provides=('libavcodec.so' 'libavutil.so' 'libpostproc.so' 'libswscale.so'
- 'libswresample.so' 'libavformat.so' 'libavfilter.so' 'libavdevice.so')
-source=(http://ffmpeg.org/releases/ffmpeg-$pkgver.tar.bz2{,.asc}
- ffmpeg-0.10-libvpx-1.5.patch)
-validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8') # ffmpeg-devel
-sha256sums=('e77823cbd58dfdb61f88059476070bc432d80e3821c14abcf804ef709d2f3fd1'
- 'SKIP'
- 'd6797973889582b82b7c81b91a39c222e09b5ccf8a7e031c364ae1e9275a497d')
-
-
-prepare() {
- cd ffmpeg-$pkgver
- patch -p1 -i ../ffmpeg-0.10-libvpx-1.5.patch
-}
-
-build() {
- cd ffmpeg-$pkgver
-
- CFLAGS+=" -I/usr/include/openjpeg-1.5" \
- ./configure \
- --prefix=/usr \
- --incdir=/usr/include/ffmpeg-compat \
- --libdir=/usr/lib/ffmpeg-compat \
- --shlibdir=/usr/lib/ffmpeg-compat \
- --disable-debug \
- --disable-static \
- --enable-gpl \
- --enable-libass \
- --enable-libfreetype \
- --enable-libgsm \
- --enable-libmodplug \
- --enable-libmp3lame \
- --enable-libopencore_amrnb \
- --enable-libopencore_amrwb \
- --enable-libopenjpeg \
- --disable-libpulse \
- --enable-librtmp \
- --enable-libschroedinger \
- --enable-libspeex \
- --enable-libtheora \
- --enable-libv4l2 \
- --enable-libvorbis \
- --enable-libvpx \
- --enable-libx264 \
- --enable-libxvid \
- --enable-postproc \
- --enable-runtime-cpudetect \
- --enable-shared \
- --enable-vdpau \
- --enable-version3 \
- --enable-x11grab
-
- make
-}
-
-package() {
- cd ffmpeg-$pkgver
- make DESTDIR="$pkgdir" install
- rm -rf "$pkgdir"/usr/{bin,share}
-
- install -dm755 "$pkgdir"/etc/ld.so.conf.d/
- echo -e '/usr/lib/\n/usr/lib/ffmpeg-compat/' > "$pkgdir"/etc/ld.so.conf.d/$pkgname.conf
-}
diff --git a/abs/extra/ffmpeg-compat/__changelog b/abs/extra/ffmpeg-compat/__changelog
deleted file mode 100644
index 105d5aa..0000000
--- a/abs/extra/ffmpeg-compat/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD - remove libpulse as dep and disable pulse in compile
diff --git a/abs/extra/ffmpeg-compat/ffmpeg-0.10-libvpx-1.5.patch b/abs/extra/ffmpeg-compat/ffmpeg-0.10-libvpx-1.5.patch
deleted file mode 100644
index 740bb74..0000000
--- a/abs/extra/ffmpeg-compat/ffmpeg-0.10-libvpx-1.5.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/libavcodec/libvpxenc.c b/libavcodec/libvpxenc.c
-index 1d33ce9..dface51 100644
---- a/libavcodec/libvpxenc.c
-+++ b/libavcodec/libvpxenc.c
-@@ -78,19 +78,11 @@ typedef struct VP8EncoderContext {
-
- /** String mappings for enum vp8e_enc_control_id */
- static const char *ctlidstr[] = {
-- [VP8E_UPD_ENTROPY] = "VP8E_UPD_ENTROPY",
-- [VP8E_UPD_REFERENCE] = "VP8E_UPD_REFERENCE",
-- [VP8E_USE_REFERENCE] = "VP8E_USE_REFERENCE",
-- [VP8E_SET_ROI_MAP] = "VP8E_SET_ROI_MAP",
-- [VP8E_SET_ACTIVEMAP] = "VP8E_SET_ACTIVEMAP",
-- [VP8E_SET_SCALEMODE] = "VP8E_SET_SCALEMODE",
- [VP8E_SET_CPUUSED] = "VP8E_SET_CPUUSED",
- [VP8E_SET_ENABLEAUTOALTREF] = "VP8E_SET_ENABLEAUTOALTREF",
- [VP8E_SET_NOISE_SENSITIVITY] = "VP8E_SET_NOISE_SENSITIVITY",
-- [VP8E_SET_SHARPNESS] = "VP8E_SET_SHARPNESS",
- [VP8E_SET_STATIC_THRESHOLD] = "VP8E_SET_STATIC_THRESHOLD",
- [VP8E_SET_TOKEN_PARTITIONS] = "VP8E_SET_TOKEN_PARTITIONS",
-- [VP8E_GET_LAST_QUANTIZER] = "VP8E_GET_LAST_QUANTIZER",
- [VP8E_SET_ARNR_MAXFRAMES] = "VP8E_SET_ARNR_MAXFRAMES",
- [VP8E_SET_ARNR_STRENGTH] = "VP8E_SET_ARNR_STRENGTH",
- [VP8E_SET_ARNR_TYPE] = "VP8E_SET_ARNR_TYPE",
diff --git a/abs/extra/ffmpeg2.8/PKGBUILD b/abs/extra/ffmpeg2.8/PKGBUILD
index c676e62..f203567 100644
--- a/abs/extra/ffmpeg2.8/PKGBUILD
+++ b/abs/extra/ffmpeg2.8/PKGBUILD
@@ -6,11 +6,11 @@
# Contributor: Paul Mattal <paul@archlinux.org>
pkgname=ffmpeg2.8
-pkgver=2.8.9
-pkgrel=1
+pkgver=2.8.11
+pkgrel=2
pkgdesc='Complete solution to record, convert and stream audio and video'
arch=('i686' 'x86_64')
-url='http://ffmpeg.org/'
+url='https://ffmpeg.org/'
license=('GPL3')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame'
'libass' 'libbluray' 'libmodplug' 'libsoxr' 'libssh'
@@ -23,14 +23,14 @@ optdepends=('ladspa: LADSPA filters')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
'libswscale.so')
-source=("http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2"
- "http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2.asc"
+source=("http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"
+ "http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz.asc"
'ffmpeg-2.8-kodi.patch'
'ffmpeg-2.8-Resolve-plex-direct-domains.patch'
'ffmpeg-99.0011-mpeg4video-Signal-unsupported-GMC-with-more-than-one.patch'
'ffmpeg-Speed_up_wtv_index_creation.patch'
)
-validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8') # ffmpeg-devel
prepare() {
cd ${srcdir}/ffmpeg-${pkgver}
@@ -101,7 +101,7 @@ package() {
# vim: ts=2 sw=2 et:
-md5sums=('67adbe4671838e3a203bd425ff94fde6'
+md5sums=('b8c6953c65d0c9ef120a878064282c75'
'SKIP'
'83bc99a06f1ca6fd70ed35056937a522'
'6c1e7519c3b5d414ca98ad624691517d'
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index 0c3a393..dd41c55 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,7 +5,7 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=57.0.2987.110
+pkgver=59.0.3071.86
pkgrel=1
pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
arch=('x86_64')
@@ -15,16 +15,15 @@ depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nss')
optdepends=('kdialog: needed for file dialogs in KDE'
'gnome-keyring: for storing passwords in GNOME keyring'
'kwallet: for storing passwords in KWallet'
- 'ttf-liberation: fix fonts for some PDFs (CRBug #369991)')
+ 'libunity: download progress on KDE'
+ 'ttf-liberation: fix fonts for some PDFs (CRBug #369991)'
+ 'xdg-utils')
options=('!emptydirs' '!strip')
install=$pkgname.install
_channel=stable
source=("google-chrome-${_channel}_${pkgver}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_amd64.deb"
"$url/browser/privacy/eula_text.html"
'google-chrome-stable.sh')
-md5sums=('ba137093ddd19e643988e66d5821eb3d'
- 'SKIP'
- 'ed4cf73982461af7d0d944c1cbf9f4e8')
package() {
msg2 "Extracting the data.tar.xz..."
@@ -54,3 +53,6 @@ package() {
rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/opt/google/chrome/cron/
rm "$pkgdir"/opt/google/chrome/product_logo_*.png
}
+md5sums=('686ea970b43c71f4cff37cf58d9c7738'
+ 'da54da9383ddffa44c5db45513239da2'
+ 'ed4cf73982461af7d0d944c1cbf9f4e8')
diff --git a/abs/extra/handbrake/PKGBUILD b/abs/extra/handbrake/PKGBUILD
index 3b0c3e4..bf66a04 100644
--- a/abs/extra/handbrake/PKGBUILD
+++ b/abs/extra/handbrake/PKGBUILD
@@ -4,52 +4,34 @@
# Contributor: Sebastien Piccand <sebcactus gmail com>
pkgname=('handbrake' 'handbrake-cli')
-pkgver=1.0.2
-pkgrel=1
+pkgver=1.0.7
+pkgrel=2
arch=('i686' 'x86_64')
url="https://handbrake.fr/"
license=('GPL')
-makedepends=('intltool' 'python2' 'yasm' 'wget' 'bzip2' 'gcc-libs' 'libnotify'
- 'gst-plugins-base' 'gtk3' 'dbus-glib' 'fribidi' 'libass' 'lame'
- 'fontconfig' 'freetype2' 'libxml2' 'libogg' 'libvorbis' 'cmake'
- 'libtheora' 'libsamplerate' 'ffmpeg' 'x264' 'libx264' 'x265'
- 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev')
-source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2
- handbrake-fix-missing-x265-link-flag.patch)
-sha256sums=('18e4563cc150309df03f7e73462b823ba2eca61644a7a536c9930611f3f9aa1e'
- '05e212e76b6e0b94a04de02cbeb7bf9db607059e19297b5bd3d0d143135285c4')
-
-prepare() {
- cd "$srcdir/HandBrake-$pkgver"
-
- # https://bugs.gentoo.org/show_bug.cgi?id=552792
- patch -Np1 -i ../handbrake-fix-missing-x265-link-flag.patch
-
- # Use more system libs
- # Bundled libbluray is kept because it is patched locally
- for _lib in ffmpeg x265 libvpx libdvdnav libdvdread; do
- sed -i "/MODULES += contrib\/$_lib/d" make/include/main.defs
- done
-}
+makedepends=('intltool' 'python2' 'yasm' 'wget' 'cmake' 'bzip2' 'gcc-libs'
+ 'zlib' 'libnotify' 'gst-plugins-base' 'gtk3' 'dbus-glib' 'libass'
+ 'lame' 'libxml2' 'opus' 'libvorbis' 'libtheora' 'libsamplerate'
+ 'x264' 'libx264' 'jansson' 'librsvg' 'libgudev')
+source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2)
+sha256sums=('ffdee112f0288f0146b965107956cd718408406b75db71c44d2188f5296e677f')
build() {
cd "$srcdir/HandBrake-$pkgver"
- ./configure \
- --prefix=/usr \
- --disable-gtk-update-checks
+ ./configure --prefix=/usr
make -C build
}
package_handbrake() {
pkgdesc="Multithreaded video transcoder"
- depends=('bzip2' 'gcc-libs' 'gst-plugins-base' 'libnotify' 'dbus-glib'
- 'fribidi' 'libass' 'lame' 'gtk3' 'fontconfig' 'freetype2' 'libxml2'
- 'libogg' 'libvorbis' 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264'
- 'x265' 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev'
+ depends=('bzip2' 'gcc-libs' 'zlib' 'gst-plugins-base' 'libnotify' 'dbus-glib'
+ 'gtk3' 'libass' 'lame' 'libxml2' 'opus' 'libvorbis' 'libtheora'
+ 'libsamplerate' 'libx264' 'jansson' 'librsvg' 'libgudev'
'desktop-file-utils' 'hicolor-icon-theme')
optdepends=('gst-plugins-good: for video previews'
- 'gst-libav: for video previews')
+ 'gst-libav: for video previews'
+ 'libdvdcss: for decoding encrypted DVDs')
cd "$srcdir/HandBrake-$pkgver/build"
@@ -59,9 +41,9 @@ package_handbrake() {
package_handbrake-cli() {
pkgdesc="Multithreaded video transcoder (CLI)"
- depends=('bzip2' 'gcc-libs' 'zlib' 'fribidi' 'libass' 'lame' 'libxml2'
- 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264' 'x265' 'libvpx'
- 'libdvdnav' 'jansson')
+ depends=('bzip2' 'gcc-libs' 'zlib' 'libass' 'lame' 'libxml2' 'opus'
+ 'libvorbis' 'libtheora' 'libsamplerate' 'libx264' 'jansson')
+ optdepends=('libdvdcss: for decoding encrypted DVDs')
cd "$srcdir/HandBrake-$pkgver/build"
install -D HandBrakeCLI "$pkgdir/usr/bin/HandBrakeCLI"
diff --git a/abs/extra/handbrake/handbrake-fix-missing-x265-link-flag.patch b/abs/extra/handbrake/handbrake-fix-missing-x265-link-flag.patch
deleted file mode 100644
index a963fe0..0000000
--- a/abs/extra/handbrake/handbrake-fix-missing-x265-link-flag.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Written by: Peter Foley <pefoley2@pefoley.com>
-Gentoo Bug: #552792
-
---- a/test/module.defs
-+++ b/test/module.defs
-@@ -25,6 +25,7 @@
-
- ifeq (1,$(FEATURE.x265))
- TEST.GCC.D += USE_X265
-+ TEST.GCC.l += x265
- endif
-
- TEST.GCC.l += $(foreach m,$(MODULES.NAMES),$($m.OSL.libs))
diff --git a/abs/extra/lm_sensors/PKGBUILD b/abs/extra/lm_sensors/PKGBUILD
index 78f622e..43c813e 100644
--- a/abs/extra/lm_sensors/PKGBUILD
+++ b/abs/extra/lm_sensors/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Eric Bélanger <eric@archlinux.org>
pkgname=lm_sensors
-pkgver=3.3.5
-pkgrel=1
+pkgver=3.4.0
+pkgrel=2
pkgdesc="Collection of user space tools for general SMBus access and hardware monitoring"
arch=('i686' 'x86_64')
url="http://www.lm-sensors.org/"
@@ -12,31 +12,31 @@ depends=('perl' 'sysfsutils')
makedepends=('rrdtool')
optdepends=('rrdtool: for logging with sensord')
backup=('etc/sensors3.conf' 'etc/healthd.conf' 'etc/conf.d/sensord')
-source=(http://dl.lm-sensors.org/lm-sensors/releases/lm_sensors-${pkgver}.tar.bz2{,.sig}
+source=($pkgname-$pkgver::https://github.com/groeck/lm-sensors/archive/V${pkgver//\./-}.tar.gz
healthd healthd.conf healthd.service sensord.conf
lm_sensors-fancontrol.patch)
-sha1sums=('179989a52bae8f01ba8ed77e8a15af6ec653d89e'
- 'SKIP'
+sha1sums=('4a9026e4db894c98ee7cea0bec1188108e415f71'
'1c91ae403d3cd02b6177ad1f1b2f2c3a7a3257f5'
'1edd4d72ade22adfc128fb8d670e85c633fd1d18'
'd72ec328e9303acef86342483b6f8537de6117d9'
'f4b5f21fdb3b2a55aa353afa1603f953b207b73b'
'b0bc977348610d6a008d75a43f65800251c4c9f7')
+validpgpkeys=('7CA69F4460F1BDC41FD2C858A5526B9BB3CD4E6A')
prepare() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgname/_/-}-${pkgver//\./-}
sed -i 's|/etc/sysconfig|/etc/conf.d|' prog/{detect/sensors-detect,init/{sensord,lm_sensors}.service}
sed -i 's/EnvironmentFile=/EnvironmentFile=-/' prog/init/lm_sensors.service
patch -p0 -i "${srcdir}/lm_sensors-fancontrol.patch"
}
build() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgname/_/-}-${pkgver//\./-}
make PREFIX=/usr
}
package() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgname/_/-}-${pkgver//\./-}
make PROG_EXTRA=sensord BUILD_STATIC_LIB=0 \
PREFIX=/usr SBINDIR=/usr/bin MANDIR=/usr/share/man DESTDIR="${pkgdir}" install
diff --git a/abs/extra/openpht/PKGBUILD b/abs/extra/openpht/PKGBUILD
index 06afae1..4962a65 100644
--- a/abs/extra/openpht/PKGBUILD
+++ b/abs/extra/openpht/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Daniel Wallace <daniel.wallace@gatech.edu>
pkgname=openpht
-pkgver=1.7.1.137
-_pkghash=b604995c
-pkgrel=2
+pkgver=1.8.0.148
+_pkghash=573b6d73
+pkgrel=1
pkgdesc='OpenPHT is a community driven fork of Plex Home Theater'
arch=('i686' 'x86_64')
url='https://github.com/RasPlex/OpenPHT/'
@@ -65,7 +65,7 @@ package() {
# add in plex_lib.conf
install -D -m0744 ${srcdir}/plex_lib.conf ${pkgdir}/etc/gen_lib_xml.d/plex_lib.conf
}
-md5sums=('9a7a2205a30f1002b2600cf8e240fb98'
+md5sums=('cd2fff943de57123008c0f10f7fb20d1'
'b9524fe29d0cc65087ba447d1b892da2'
'a5980579c1b6341a6d06e80d9da2a924'
'e530e2b4d8333863ba1c87862c291ba1')
diff --git a/abs/extra/plex-media-server/PKGBUILD b/abs/extra/plex-media-server/PKGBUILD
index 6d14e83..52425c2 100644
--- a/abs/extra/plex-media-server/PKGBUILD
+++ b/abs/extra/plex-media-server/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=plex-media-server
pkgver=1.5.5.3634
_pkgsum=995f1dead
-pkgrel=1
+pkgrel=2
pkgdesc='Plex Media Server'
arch=('armv7h' 'i686' 'x86_64')
url='https://plex.tv/'
@@ -47,6 +47,8 @@ package() {
install -m 644 plexmediaserver.conf.d "${pkgdir}"/etc/conf.d/plexmediaserver
install -Dm 644 "$srcdir/plex.sysusers" "$pkgdir/usr/lib/sysusers.d/plex.conf"
+ install -m 755 -D plexmediascanner.sh "${pkgdir}"/usr/LH/bin/plexmediascanner.sh
+
install -dm 755 "${pkgdir}"/usr/share/licenses/${pkgname}
install -m 644 terms.txt "${pkgdir}"/usr/share/licenses/${pkgname}/
}
diff --git a/abs/extra/tigervnc/PKGBUILD b/abs/extra/tigervnc/PKGBUILD
index db327ef..8460632 100644
--- a/abs/extra/tigervnc/PKGBUILD
+++ b/abs/extra/tigervnc/PKGBUILD
@@ -2,16 +2,16 @@
# Maintainer: Uroš Vampl <mobile.leecher at gmail dot com>
pkgname=tigervnc
-pkgver=1.6.0
+pkgver=1.8.0
pkgrel=2
-_xorgver=1.18.0
+_xorgver=1.19.3
pkgdesc="Suite of VNC servers and clients. Based on the VNC 4 branch of TightVNC."
arch=('i686' 'x86_64')
url="http://www.tigervnc.org"
license=('GPL')
depends=('fltk' 'pam' 'gnutls' 'libjpeg-turbo' 'libxtst' 'libxfont' 'pixman'
'xorg-xauth' 'xorg-xsetroot' 'xkeyboard-config' 'xorg-xkbcomp'
- 'libgl' 'libgcrypt' 'perl' 'libxdamage')
+ 'libgl' 'libgcrypt' 'perl' 'libxdamage' 'libxfont2')
makedepends=('cmake' 'nasm' 'xorg-font-util' 'xorg-util-macros' 'bigreqsproto'
'compositeproto' 'damageproto' 'randrproto' 'resourceproto'
'scrnsaverproto' 'videoproto' 'xcmiscproto' 'xf86vidmodeproto'
@@ -23,27 +23,21 @@ install=tiger.install
source=($pkgname-$pkgver.tar.gz::https://github.com/TigerVNC/tigervnc/archive/v${pkgver}.tar.gz
ftp://ftp.freedesktop.org/pub/xorg/individual/xserver/xorg-server-${_xorgver}.tar.bz2
vncserver.service
- vncviewer.desktop
- vncsvc.rules
- gethomedir.patch
- xorg118.patch)
+ vncsvc.rules
+ vncviewer.desktop)
prepare() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- patch -Np1 -i ${srcdir}/xorg118.patch
- patch -Np1 -i ${srcdir}/gethomedir.patch
- sed -i 's/iconic/nowin/' unix/vncserver
-
+ cd "$srcdir"/${pkgname}-${pkgver}
cd unix/xserver
- cp -r ${srcdir}/xorg-server-${_xorgver}/* .
- patch -Np1 -i ../xserver117.patch
+ cp -r "$srcdir"/xorg-server-${_xorgver}/* .
+ patch -Np1 -i ../xserver119.patch
}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "$srcdir"/${pkgname}-${pkgver}
- cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -G "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr
make
cd unix/xserver
@@ -54,19 +48,19 @@ build() {
--disable-xwin --disable-xephyr --disable-kdrive --disable-xwayland \
--disable-config-hal --disable-config-udev --with-pic \
--disable-unit-tests --disable-devel-docs --disable-selective-werror \
- --disable-dri --enable-dri2 --enable-dri3 --enable-glx --enable-glx-tls
+ --disable-dri --enable-dri2 --enable-dri3 --enable-glx
make
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
+ cd "$srcdir"/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir" install
cd unix/xserver/hw/vnc
- make DESTDIR=${pkgdir} install
- install -Dm0644 ${srcdir}/${pkgname}-${pkgver}/contrib/systemd/user/vncserver@.service \
- $pkgdir/usr/lib/systemd/user/vncserver@.service
- install -Dm0644 $srcdir/vncserver.service $pkgdir/usr/lib/systemd/system/vncserver.service
- install -Dm0644 $srcdir/vncviewer.desktop $pkgdir/usr/share/applications/vncviewer.desktop
+ make DESTDIR="$pkgdir" install
+ install -Dm0644 "$srcdir"/${pkgname}-${pkgver}/contrib/systemd/user/vncserver@.service \
+ "$pkgdir"/usr/lib/systemd/user/vncserver@.service
+ install -Dm0644 "$srcdir"/vncserver.service "$pkgdir"/usr/lib/systemd/system/vncserver.service
+ install -Dm0644 "$srcdir"/vncviewer.desktop "$pkgdir"/usr/share/applications/vncviewer.desktop
#LinHES sudo rules
mkdir -p $pkgdir/etc/sudoers.d/
@@ -74,10 +68,8 @@ package() {
chown -R root:root $pkgdir/etc/sudoers.d
install -o root -g root -m 0750 $srcdir/vncsvc.rules $pkgdir/etc/sudoers.d/vncsvc-tigervnc
}
-md5sums=('78b736445781d86c48e942465a391ccc'
- '3c1c1057d3ad27380d8dd87ffcc182cd'
- '1aad8f06504b3e29a24ccfbaab617973'
- 'b200d83c60e80c6f9693ea19a2d9f5b0'
+md5sums=('5c9a80dd4b99b4eb19f535db5ce5830f'
+ '015d2fc4b9f2bfe7a626edb63a62c65e'
+ 'a8a20685c23a50f86a13c33ce96a7ba7'
'f333a228ddbefffc6ce945754bc9c5c5'
- '22f1523a0eca56ad79cfabd0db6e2cf6'
- '2fd32181679077eb7f7ca06cf25f443f')
+ 'b200d83c60e80c6f9693ea19a2d9f5b0')
diff --git a/abs/extra/tigervnc/gethomedir.patch b/abs/extra/tigervnc/gethomedir.patch
deleted file mode 100644
index 5f3542d..0000000
--- a/abs/extra/tigervnc/gethomedir.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -ur tigervnc-1.2.0.orig/unix/xserver/hw/vnc/Makefile.am tigervnc-1.2.0/unix/xserver/hw/vnc/Makefile.am
---- tigervnc-1.2.0.orig/unix/xserver/hw/vnc/Makefile.am 2011-10-31 09:14:40.000000000 +0100
-+++ tigervnc-1.2.0/unix/xserver/hw/vnc/Makefile.am 2012-09-06 19:44:04.431123087 +0200
-@@ -5,6 +5,7 @@
- RDR_LIB=$(LIB_DIR)/rdr/librdr.la
- NETWORK_LIB=$(LIB_DIR)/network/libnetwork.la
- XREGION_LIB=$(LIB_DIR)/Xregion/libXregion.la
-+OS_LIB=$(LIB_DIR)/os/libos.la
- COMMON_LIBS=$(NETWORK_LIB) $(RFB_LIB) $(RDR_LIB) $(XREGION_LIB)
-
- noinst_LTLIBRARIES = libvnccommon.la
-@@ -55,7 +56,7 @@
-
- libvnc_la_LDFLAGS = -module -avoid-version
-
--libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS)
-+libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS) $(OS_LIB)
-
- EXTRA_DIST = Xvnc.man
-
diff --git a/abs/extra/tigervnc/vncserver.service b/abs/extra/tigervnc/vncserver.service
index 0c257b3..40151ac 100644
--- a/abs/extra/tigervnc/vncserver.service
+++ b/abs/extra/tigervnc/vncserver.service
@@ -18,7 +18,7 @@ Description=Remote desktop service (VNC)
After=syslog.target network.target
[Service]
-Type=forking
+Type=simple
User=
ExecStartPre=/bin/sh -c '/usr/bin/vncserver -kill %i >/dev/null 2>&1 || true'
diff --git a/abs/extra/tigervnc/xorg118.patch b/abs/extra/tigervnc/xorg118.patch
deleted file mode 100644
index 7484200..0000000
--- a/abs/extra/tigervnc/xorg118.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -wbBur tigervnc-1.5.0/unix/xserver/hw/vnc/Input.c tigervnc-1.5.0.q/unix/xserver/hw/vnc/Input.c
---- tigervnc-1.5.0/unix/xserver/hw/vnc/Input.c 2015-07-11 16:00:36.000000000 +0300
-+++ tigervnc-1.5.0.q/unix/xserver/hw/vnc/Input.c 2015-11-25 19:04:24.278747038 +0300
-@@ -300,6 +300,8 @@
- #if XORG < 111
- n = GetKeyboardEvents(eventq, dev, action, kc);
- enqueueEvents(dev, n);
-+#elif XORG > 117
-+ QueueKeyboardEvents(dev, action, kc);
- #else
- QueueKeyboardEvents(dev, action, kc, NULL);
- #endif
-diff -wbBur tigervnc-1.5.0/unix/xserver/hw/vnc/xorg-version.h tigervnc-1.5.0.q/unix/xserver/hw/vnc/xorg-version.h
---- tigervnc-1.5.0/unix/xserver/hw/vnc/xorg-version.h 2015-07-11 16:00:36.000000000 +0300
-+++ tigervnc-1.5.0.q/unix/xserver/hw/vnc/xorg-version.h 2015-11-25 19:02:47.688751421 +0300
-@@ -48,8 +48,10 @@
- #define XORG 116
- #elif XORG_VERSION_CURRENT < ((1 * 10000000) + (17 * 100000) + (99 * 1000))
- #define XORG 117
-+#elif XORG_VERSION_CURRENT < ((1 * 10000000) + (18 * 100000) + (99 * 1000))
-+#define XORG 118
- #else
--#error "X.Org newer than 1.17 is not supported"
-+#error "X.Org newer than 1.18 is not supported"
- #endif
-
- #endif
diff --git a/abs/extra/web-on-linhes/PKGBUILD b/abs/extra/web-on-linhes/PKGBUILD
index 4e52115..660efb5 100644
--- a/abs/extra/web-on-linhes/PKGBUILD
+++ b/abs/extra/web-on-linhes/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=web-on-linhes
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Added multiple websites with 10' UIs to Play Online Streams."
arch=('i686' 'x86_64')
license=('GPL2')
@@ -16,8 +16,8 @@ package() {
cd ${srcdir}
install -d ${pkgdir}/usr/LH/bin
install -D -m755 *.sh ${pkgdir}/usr/LH/bin
- #add in file for gen_is.xml
- install -D -m0744 ${srcdir}/web-on-linhes_is.conf ${pkgdir}/etc/gen_is_xml.d/web-on-linhes_is.conf
+ #add in file for gen_is.xml
+ install -D -m0744 ${srcdir}/web-on-linhes_is.conf ${pkgdir}/etc/gen_is_xml.d/web-on-linhes_is.conf
}
-md5sums=('b04992d48e45411bdeed23e6aa9f95f7'
+md5sums=('c38cbf334b0b6c35a1fd49da9924a0f5'
'475addc194b389ecc4bc5cde3aa5a8ea')
diff --git a/abs/extra/web-on-linhes/web-on-linhes.sh b/abs/extra/web-on-linhes/web-on-linhes.sh
index 7d9b99b..115d0b0 100644
--- a/abs/extra/web-on-linhes/web-on-linhes.sh
+++ b/abs/extra/web-on-linhes/web-on-linhes.sh
@@ -7,7 +7,7 @@ irxPID=$!
stop_xss.sh &
xssPID=$!
#Launches chrome in full screen
-google-chrome --no-first-run --user-data-dir=/home/mythtv/.cache/google-chrome/Default/ --kiosk $@
+google-chrome --no-first-run --kiosk $@
#Once done, stops irxevent and stop_xss.sh
kill $irxPID
kill $xssPID