summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-03-05 19:45:15 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-03-05 19:45:15 (GMT)
commitd25a4fbd6a135c232c447dd17b0f15d7391cd40f (patch)
tree4cced235bd74c47af1c79f222e5f996ccb4cc48b /abs/extra
parente2e9871666fc207bc453329ef8cc1b9656a9ab31 (diff)
downloadlinhes_pkgbuild-d25a4fbd6a135c232c447dd17b0f15d7391cd40f.zip
linhes_pkgbuild-d25a4fbd6a135c232c447dd17b0f15d7391cd40f.tar.gz
linhes_pkgbuild-d25a4fbd6a135c232c447dd17b0f15d7391cd40f.tar.bz2
plex-home-theater: update to 1.3.6
Diffstat (limited to 'abs/extra')
-rwxr-xr-xabs/extra/plex-home-theater/PKGBUILD12
-rw-r--r--abs/extra/plex-home-theater/plex-lirc-socket.patch27
2 files changed, 7 insertions, 32 deletions
diff --git a/abs/extra/plex-home-theater/PKGBUILD b/abs/extra/plex-home-theater/PKGBUILD
index 122105a..2f2c087 100755
--- a/abs/extra/plex-home-theater/PKGBUILD
+++ b/abs/extra/plex-home-theater/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Daniel Wallace <daniel.wallace@gatech.edu>
pkgname=plex-home-theater
-_pkgver=1.2.3.378-0c92ed32
+_pkgver=1.3.6.441-309e72d1
pkgver=${_pkgver%-*}
pkgrel=1
pkgdesc='Plex Home Theater'
@@ -14,11 +14,12 @@ depends=('boost-libs' 'curl' 'ffmpeg-compat' 'glew' 'libcdio' 'libmad'
'libmicrohttpd' 'libmpeg2' 'libsamplerate' 'libssh' 'libusb-compat'
'libvdpau' 'libxrandr' 'lzo' 'sdl_image' 'sdl_mixer' 'smbclient'
'taglib' 'tinyxml' 'yajl')
-makedepends=('boost' 'cmake' 'doxygen' 'java-environment' 'libcec' 'libplist'
- 'libshairport' 'nasm' 'swig' 'unzip' 'zip')
+makedepends=('boost' 'cmake' 'doxygen' 'java-environment' 'libcec'
+ 'libplist' 'libshairport' 'nasm' 'swig' 'unzip' 'zip')
optdepends=('libplist: AirPlay support'
'libshairport: AirPlay support'
'libcec: Pulse-Eight USB-CEC adapter support')
+install="${pkgname}.install"
source=("https://github.com/plexinc/plex-home-theater-public/archive/v${_pkgver}.tar.gz"
'plex-ffmpeg-compat.patch'
'plex-libcec-2.2.0.patch'
@@ -58,6 +59,7 @@ package() {
install -dm 755 "${pkgdir}"/usr/{lib/plexhometheater,share/{applications,pixmaps}}
mv "${pkgdir}"/usr/bin/{system,xbmc-xrandr} "${pkgdir}"/usr/lib/plexhometheater/
mv "${pkgdir}"/usr/share/XBMC "${pkgdir}"/usr/share/plexhometheater
+ rm -rf "${pkgdir}"/usr/bin/*.so
install -m 755 "${srcdir}"/plexhometheater.sh "${pkgdir}"/usr/bin/
install -m 644 ../plex/Resources/plexhometheater.desktop "${pkgdir}"/usr/share/applications/
install -m 644 ../plex/Resources/plex-icon-256.png "${pkgdir}"/usr/share/pixmaps/plexhometheater.png
@@ -68,9 +70,9 @@ package() {
}
# vim: ts=2 sw=2 et:
-md5sums=('59f6d8386d9533b7c9a0c9e559a83c0f'
+md5sums=('370627c3d9e190e7af2cb8cf2a67f488'
'6704244166497db7fa6b3ddd43a0e53b'
'066484ad4949f96ddddaa8b1d4d709e1'
- 'b96a1d70174d80d3f2272bdc5b48e4a3'
+ '09e67d694093eb6bd243fb9a4ddf5d70'
'8735a4e7857bc85085482c4f8bcb1d01'
'8fae1350cc36f40ed65fbf96128a02d0')
diff --git a/abs/extra/plex-home-theater/plex-lirc-socket.patch b/abs/extra/plex-home-theater/plex-lirc-socket.patch
index 7110252..0a7ebf3 100644
--- a/abs/extra/plex-home-theater/plex-lirc-socket.patch
+++ b/abs/extra/plex-home-theater/plex-lirc-socket.patch
@@ -27,30 +27,3 @@ index 002245a..85ad398 100644
AC_ARG_ENABLE([udev],
diff --git a/plex/CMakeModules/PlatformConfigLINUX.cmake b/plex/CMakeModules/PlatformConfigLINUX.cmake
index 078fafb..3afa5c1 100644
---- a/plex/CMakeModules/PlatformConfigLINUX.cmake
-+++ b/plex/CMakeModules/PlatformConfigLINUX.cmake
-@@ -126,7 +126,7 @@ if(DEFINED OPENGL_FOUND)
- endif()
-
- #### default lircdevice
--set(LIRC_DEVICE "/dev/lircd")
-+set(LIRC_DEVICE "/var/run/lirc/lircd")
-
- #### on linux we want to use a "easy" name
- set(EXECUTABLE_NAME "plexhometheater")
-diff --git a/plex/CMakeModules/PlatformConfigRPI.cmake b/plex/CMakeModules/PlatformConfigRPI.cmake
-index 82aa751..367cdc9 100644
---- a/plex/CMakeModules/PlatformConfigRPI.cmake
-+++ b/plex/CMakeModules/PlatformConfigRPI.cmake
-@@ -103,7 +103,7 @@ list(APPEND CONFIG_INTERNAL_LIBS lib_dllsymbols)
-
-
- #### default lircdevice
--set(LIRC_DEVICE "/dev/lircd")
-+set(LIRC_DEVICE "/var/run/lirc/lircd")
-
- #### on linux we want to use a "easy" name
- set(EXECUTABLE_NAME "plexhometheater")
---
-2.1.3
-